Inactive [SEC] NoCheat v3.5.0 [CB 1.2.4 R1.0][ABANDONED]

Discussion in 'Inactive/Unsupported Plugins' started by Evenprime, Feb 15, 2011.

  1. Offline


    Xp10d3, Dereku, MyPictures and 35 others like this.
  2. Offline


    k thanks a lot, i will test it.

    Any value recomendation of delay for:

    interact.durability.actions.0 = "durabilityLog interactCancel mykick"
    blockplace.reach.actions.0 = "reachLog blockplaceCancel mykick"
    blockbreak.direction.actions.0 = "directionLog blockbreakCancel mykick"
    blockplace.reach.actions.0 = "reachLog blockplaceCancel mykick"
    blockplace.onliquid.actions.0 = "onliquidLog blockplaceCancel mykick"


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  3. Offline


    For those it should be safe to have little to no delay for kicking.

    Only the "onliquid" check. Some people report that their players get warnings because of that, without doing anything wrong. But I haven't been able to reproduce that at all. So if you experience people getting kicked because of that a lot, you may want to change the delay or not kick players for that.
  4. Offline


    thanks mate, it helps

    So with the logs, when we can be sure:

    failed runfly/vertical - this can happen from lag or is 100%?

    failed blockbreak.direction: tried to destroy a block out of line of sight. - i saw some of people that were laggin

    tried to interact with a block over distance XXX. - i saw some of people that were laggin, not even sure when to panic about this. 5-30 usualy, after 10 should i be worried?

    Sent 350 more packets than expected. Total violation level 320.00. - here when to panic, after 60? can be a false positive from lag? or just go for the ban?


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  5. Offline


    Evenprime can u reply to the questions above, when u have time mate? I read 20 pages, and i still do to get some good answers:p

  6. Offline


    Almost 100%. If you get that multiple times per minute from a player, he is very likely trying to fly or use some feature of some plugin that isn't (yet) compatible with NoCheat.

    Is normally not lag dependant. But if you get that multiple times from the same player in a short timeframe, he is very likely doing something bad.

    Again should not be lag dependant. If it happens a lot in a row for the same player, I'd at least ask him what he was trying to do.

    NoCheat tries to handle lag in that case as good as possible. As long as the player hasn't lag of over 2 seconds, it should not be flagged as cheating at all. When the server lags, this check gets deactivated, so server lag can never be the reason.

    There is however 1 bug in Bukkit that can cause this. It happens when a plugin cancels move events. There aren't many that do that (I only know of "Authme", and that may already have fixed it). If it wasn't a plugin, the 350 means he sent almost 20 times more move packets than usual. That's pretty extreme and would only be plausible if he had a constant lag of over 15 seconds. Another explaination is how some "teleport" hacks work. They would send an awful lot of move packets at once to the server, with each move packet being only a small step into the direction they want to go.
  7. Offline


  8. Offline


    Just want to chime in -- pretty sure the update worked. I haven't seen or been notified about people dying when falling into water since updating and removing the nofall permission.
  9. Offline


    good to hear that. :)

    btw. new update 2.06b: reactivated the blockbreak.reach check for creative mode. It will automatically have a bigger distance limit (because creative has a bigger distance limit for blockbreaking than survival).

    Seems like PermissionsEX support is broken if you use a too new craftbukkit build. Probably the result of changes to the permission system. I'll see if I can fix that on my side.

    Just verified it. PermissionsEX crashes when loading. Can't fix it on my side, as it is not a NoCheat bug/problem.

    21:51:43 [SCHWERWIEGEND] Error occurred while enabling PermissionsEx v1.13 (Is it up to date?): org.bukkit.plugin.PluginDescriptionFile.getPermissions()Ljava/util/ArrayList;
    java.lang.NoSuchMethodError: org.bukkit.plugin.PluginDescriptionFile.getPermissions()Ljava/util/ArrayList;
    at ru.tehkode.permissions.bukkit.BukkitPermissions.collectPermissions(
    at ru.tehkode.permissions.bukkit.BukkitPermissions.<init>(
    at ru.tehkode.permissions.bukkit.PermissionsEx.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(

    Please go to the PermissionsEX thread and tell them about it, such that they can fix it asap.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  10. Offline


    Just a FYI:
    You might want to try updating to PermissionsEx v1.14 dev build: I do not get this error with 2.06a (unless its 2.06b specifically?)

    Edit: yea, upon checking logs, I was getting NoSuchMethod Errors before updating to PermissionsEx 1.14 dev build, not just for nocheat but also for essentials.
  11. Offline


    Just caught this in nocheat 2.06a + 1183
    2011-09-21 21:59:28 [SEVERE] Could not pass event PLAYER_CHAT to NoCheat
    java.lang.StringIndexOutOfBoundsException: String index out of range: 8
     at java.lang.String.charAt(Unknown Source)
     at java.util.regex.Matcher.appendReplacement(Unknown Source)
     at java.util.regex.Matcher.replaceAll(Unknown Source)
     at java.lang.String.replaceAll(Unknown Source)
     at org.bukkit.plugin.RegisteredListener.callEvent(
     at org.bukkit.plugin.SimplePluginManager.callEvent(
     at net.minecraft.server.NetServerHandler.a(
     at net.minecraft.server.Packet3Chat.a(
     at net.minecraft.server.NetworkManager.b(
     at net.minecraft.server.NetServerHandler.a(
     at org.getspout.spout.SpoutNetServerHandler.a(
     at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
     at net.minecraft.server.MinecraftServer.h(
  12. Offline


    hm, looks like the player had some illegal characters in his name, like "$" or "\". I can fix that, but I can't guarantee that commands really do what you expect them to do in such cases (e.g. if you want to do something else with that player), or that the name will be correctly displayed in your console (and not have strange side effects when it gets printed there).

    I'd recommend if you are using an offline mode server (which you most likely do, as minecraft doesn't allow special characters like the above in names), to use a plugin that disallows players connecting with any characters that are not in a-z, A-Z or 0-9 in their name.

    EDIT: Forget that. The player used illegal characters in his chat message, that's what caused the error. Anyway, I'll still fix that, of course. Expect it to be in the next version.
  13. Offline


    possible bug with trying to place seeds on dirt near water, but the user could have been intentionally trying to fake it by trying to place on the water and not the dirt :p. I could place the seeds though since I am not checked by nocheat.
    I'll post more info soon.

    EDIT: meh, i removed nodes

    from myself and still able to place, i guess ill have to deop myself aswell
    couldnt recreate it myself but here's a ss after removing all water from the room
  14. Offline


    So it only happens for that player and only with seeds? Hm, I'll see if I can reproduce it somehow.
  15. Offline


    Love this plugin, see a lot of "x tried to break block out of sight" and "sent more packets than needed" due to lag, and some players are frustrated when farming because it says "x could not place blocks on liquids"

    Any ideas on this liquid thing? It looks newly introduced
  16. Offline


    yea sorry i cant provide better parameters :( if i spent more time on it maybe i could give you more accurate info. I wouldn't spend alot of time on it, the guy is constantly setting of various checks. If he wont tell me what client mods he's using i don't know that it would be accurate. My server is kind an interesting battle, i dont normally ban players for client mods but they are against the rules. So they just try to hide them -.- and complain when something doesnt work right.
    Just today a guy was dying when falling into water. i asked him when it occurred because I installed the latest update the night before and mentioned it should be fixed now unless someone is using a mod that prevents fall damage. He waited a few minutes, relogged and said "Oh its fixed now i just had to relog i guess" -.-
  17. Offline

    Ronny Lawson

    the onliquid check is preventing users from placing blocks in water/lava at all, even when they have a solid block targeted.
  18. Offline


    It doesn't do that for me, it never did, and by god, I tried to reproduce that problem. I can place blocks underwater just fine, as I can place seeds just fine, no matter when or where, as long as I use the original minecraft client.

    I've now made a modification to what is displayed when that happens, such that it should be easier to reproduce. I'm now uploading the new version. You can download it in approx. 15 minutes. It will then show where the block should be placed, against which existing block it will be placed, and what type the block that gets placed has.

    @Ronny Lawson

    Uploaded new version 2.07:

    + more information when getting "onliquid" logs. Should be enough for you to trace what the players are really trying to do. If you find out, please come back and tell me, such that I can try to reproduce it or fix it.
    + fixed Spam check throwing exceptions in case the spam message contains illegal characters
    + changed Permissions description!! Due to the RB 1185 setting all permissions to OP by default, I am no longer doing that myself. Plus I ditched the ".*" permissions in favour of the shorter parent permissions without them (probably doesn't make a difference for you, as almost all permissions plugins treated those the same anyway).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  19. Offline


    Well, 1185 is out now, so I guess that fixes that problem...
  20. Offline


    Yes. Finally I can get the website bukkitdev to say that the file(s) are for CB 1185.
  21. Offline


    I haven't been able to change the config.txt file at all. everytime i change it and save. it goes right back to previous state. Also, I can't get this to stop clashing with my rocketboots plugin. Which is a donator feature. Can ya shine a little light on this. I had to take it out for the time being.
  22. Offline


    Im having a bug where in the nether i cant fly, when flying is enabled in .properties and in permissions :p is this a known bug? :D
  23. Offline


    Help me please when I start up the program I get this error.
    22:53:00 [SEVERE] Permission node 'nocheat' in plugin description file for NoChe
    at v2.07 is invalid
    java.lang.IllegalArgumentException: Child 'nocheat.admin' contains invalid value

    at org.bukkit.permissions.Permission.extractChildren(
    at org.bukkit.permissions.Permission.loadPermission(

    at org.bukkit.plugin.PluginDescriptionFile.loadPermissions(PluginDescrip
    at org.bukkit.plugin.PluginDescriptionFile.loadMap(PluginDescriptionFile
    at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    at net.minecraft.server.MinecraftServer.init(
  24. Offline


    The config files get rewritten every time the plugin loads. The "config.txt" will remove all options that are no longer supported and add new options when doing that. I've made it that way, because previously people would have entries in their config files that had no use any longer for months after they became useless. The "default_actions.txt" will also be overwritten every single time. If you need to change things, only change the values of the config.txt and use the "actions.txt" instead of the "default_actions.txt".

    As long as you move up a little bit while using them (rocketboots), they should work. At least I can fly around infinitely that way. I'll see if I can change some things to make them less likely to be seen as cheating when used to move down in a very flat ark like a paraglider.

    If you can't use them at all, then something else is wrong. If you use a relatively old version of CraftBukkit, it may be that. Spout also had for a long time sabotaged NoCheat and prevented it from getting vital data that is needed to get stuff like rocketboots to work.

    No idea why that would be. NoCheat doesn't care about seperate worlds, as long as you don't use multiple config files for different worlds. Maybe your permissions plugin only sets permissions for one world and not for the nether?

    You have to use the RB 1185 with NoCheat 2.07. Bukkit made a change to how permissions can be defined, and I rely on that change with 2.07. It should work fine with RB 1185 of CraftBukkit. If not, please come back and I'll see what I can do.
    Doidle likes this.
  25. Offline


    Can you give me an example? The only thing I really use nocheat for is to keep people who shouldn't be flying from flying. What do I need to do to use nocheat for this?
  26. Offline


    Not sure I understood that question. You want to know what part of NoCheat is needed to prevent people from flying?

    That would be the "runfly" check. Just make sure that in the config.txt you have "moving.runfly.check = true" and "moving.runfly.allowflying = false". That is pretty much the minimalistic setup.
  27. Offline


    Hes saying that all he uses nocheat is to keep people that shouldn't be flying from flying nothing else, so hes asking why he needs all this extra stuff he doesn't use. Reading the post above it looks like I might be wrong? Only trying to help but he is being a bit confusing ;( Or maybe since he only uses it to keep people from flying he is wondering if he needs to enable anything else?
  28. Offline


    I tried going into the config.txt and putting everything else false EXCEPT the fly detection. But, everytime i do that it goes right back to everything being true. What do i need to do to have it only check for fly. That and how do i keep it from stopping my mods, admins from flying. Which gets rather annoying. That and all the stuff that pops up in the chat.
  29. Offline


    people are still able to zombie fly hack D: how do i stop them?
  30. Offline



    Ice floor 2 blocks up a roof. then sprinting and holding jump = SPEED HACK <3
  31. Offline


    That should normally work. I tried again, and if I do in "config.txt" e.g.:

    moving.morepackets.check = "false"

    and restart the server/reload the plugin, it stays "false" after the restart. Are you maybe accidentially changing the character encoding of the file? Maybe if you use a different text editor to edit the file, it will work.

    I want to soon switch over to bukkits integrated and now updated configuration system. Maybe that prevents such problems. But that'll probably still take some weeks to do, so waiting for that is likely not a good idea.

    You mean they fly with "Zombes Modpack"? They shouldn't be able to do that. Maybe they are OP/have permission to do so or the plugin didn't load correctly. Please try the command "/reload" and look closely at the console, if all of your plugins start correctly without any error messages. Also, do you get any messages in the "nocheat.log" file when people are flying? If not, then clearly NoCheat wasn't loaded (correctly). If you do get messages but people still can fly, it is likely another plugin that blocks NoCheat from doing its thing (NoCheat needs to be able to teleport players, if another plugin prevents teleportations completely, it won't work).

    I know. I intentionally support that, because it is "vanilla" gameplay and people do that speedhack accidentially all the time. I hoped Mojang would fix it (they disabled "bunny-hopping" in 1.9), but now they want to put it back in. Maybe they'll add think of another way (shouldn't be hard) to stop the acceleration that comes from sprinting and jumping at the same time.

Share This Page