Inactive [SEC] NoCheat v3.5.0 [CB 1.2.4 R1.0][ABANDONED]

Discussion in 'Inactive/Unsupported Plugins' started by Evenprime, Feb 15, 2011.

  1. Offline


    Xp10d3, Dereku, MyPictures and 35 others like this.
  2. Offline


    By the way, honestly, i have no idea how id run a server without your plugin :) Thanks so much :D
  3. Offline


    When players use the home-teleport of MyHome, NoCheat fires moving violation, returns them somewhere and then they suffocate in nothing (air). Atleast according to the deathmessage plugin.
    NoCheat v1.07 + MyHome 1.9.5 + CB#953
    Posting this to both threads.
    (Other teleports seem to work fine)
  4. Offline


    NoCheat is firing moving violations upon players teleporting. Its Spamming the admins

    CB 953
    NoCheat v 1.07
    MyHome 2.0dev
  5. Offline


    Just coming here to post this. I'm using 953, Essentials and StarGate are my tele plugins
  6. Offline


    AMAZING, sames me sooo much time. Takes care of hackers >:D
  7. Offline


    Can someone tell me wtf happened? I did a reload all to update some stuff (not related to NoCheat) and I get this as NoCheat is disabling.
  8. Offline


  9. Offline


    I'm currently working on this, but I couldn't reproduce it (yet). What exact setting did you use (e.g. cooldown), did it happen for all teleports or only respawns?
  10. Offline


    coolDownNotify = false   #Whether or not players will be notified after they've cooled down
    respawnToHome = true   #Whether or not players will respawn to their homes (false means to global spawn)
    adminsObeyWarmsCools = false   #Whether or not admins obey the WarmUp + CoolDown times (false means they don't)
    allowSetHome = false   #Whether MyHome should also watch for /sethome - This may cause conflicts with Essentials
    coolDownSetHome = 0   #The number of seconds between each use of /home set
    coolDown = 0   #The number of seconds between when users can go to a home
    warmUpNotify = true   #Whether or not players will be notified after they've warmed up
    compassPointer = true   #Whether or not users' compasses point to home
    warmUp = 5   #The number of seconds after a user uses a home command before it takes them
    There is no problems respawning, only when users return to their homes from mining trips and such.
    Moving violation of monstrous proportions is triggered (hundreds of blocks) and users are returned somewhere and die of suffocation. They are NOT returned to where they used the /home command. (Atleast they can't be seen there and their items don't drop there)
  11. Offline


    I believe I've now found a way to reliably cope with CraftBukkits new move/teleport event system (and I hope it doesn't break anything else).

    I'm now just doing some final tests for the obvious problems (e.g. with vehicles) and then will upload the new version in approx. 1-2 hours. Thank you for the bug reports and your patience.

    Too Many Items is not a hack. The mod is only a fancy gui that can be used instead of typing "/give ..." or "/item ..." or whatever server command is used to spawn items. If players can spawn items with Too Many Items, then they are probably OP or you have setup your Permissions system incorrectly.

    @Paah :
    @Odjit :
    @Flenix :

    Your problems should be fixed in the new 1.07a version. I tested a lot with that new version and was no longer able to trigger the problem. If however you still experience the problem, please come back and tell me.

    That problem happens usually when some plugin gets updated. Replacing plugins with different versions sometimes causes this kind of problem. Only restarting the server fixes it.

    About some of them, yes. But I haven't started yet with working on these.

    Version 1.07a (for CB 953+)

    • Fixed teleporting (this time for real)
    • Ignore move events of dead players

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  12. Offline


    so OP's or people with a * as permission can use too many items?
    lol, installing it now :)
  13. Offline



    Would it be possible to add a config, to make this ignore plugins which ajust speed etc? for example we have a server-side sprinting plugin for our Assassin race, which makes that player move faster when sneaking. Another example, is we have a Psychic race, who can throw other players around and launch themselves into the air. I don't want to give them the permissions to ignore the movement checks, because then they might use client mods too...
  14. Offline


    So is it possible to make it so it doesn't kick players? I just want it to prevent people from doing it, but people get kicked even when not cheating, one of my friends has bad lag and I don't want people with bad lag to get kicked constantly.
  15. Offline


    You have little issue. When player die, "teleport to respawn" not working, player respawn at die place.
  16. Offline


    I would love to, but that is currently hard to impossible to do. Sadly there is no reliable way to find out if such movement is caused by a client mod or by some server plugin, if the plugin uses "setVelocity" to achieve the movement.

    My plugin doesn't kick people from the server. It will only teleport them to one of their previous locations.

    Which version of bukkit and NoCheat were you using? There have been some big problems in the transition from CB 860 to CB 953, which I only was able to fix today with NoCheat version 1.07a. If you were using the latest version already, did you use some other plugin that sets/changes respawn points?

    I just tried respawning to beds, to respawn point, to custom respawn points (e.g. those by the MyHome plugin), respawning in another world and all of these worked well.
  17. Offline


    I know this isn't related to NoCheat, but you guys are great help. ToomanyItems. When I use it on SMP ( I own the server, so I have '*') but It never gives me the items. It simply says 'Given ...' but nothing is in my inventory..
  18. Offline


    Latest CB
  19. Offline


    Usually it is just a problem with the client GUI not updating correctly. Try clicking the first empty slot in your hotbar after using TooManyItems to create an item. That should make the item that is in that slot visible. If that doesn't work, you may need to change the configuration of TooManyItems. There is some place where you can define what server command will be used to create items. Maybe it's set to a command that is only part of a specific server plugin (e.g. Essentials) instead of the standard Minecraft command.

    Should be fixed now.

    Version 1.07b (for CB 953+)

    • Fixed rare exception in case of teleports between worlds
  20. Offline


  21. I've been busting my head for the past 2 days trying to figure out WHY the pistons on my 953 server dont work....after trial and error i figured its the NoCheat plugin. I wonder how come noone else had the same problem.
    The problem is described here :

    Basically i cant make works once but then when i restart the server noone can make pistons anymore.
    So i think you should reconsider the 953+ build. There is definitely something wrong with it.

    Since i took the plugin out....i've been making pistons like crazy.

    Check it out plz.
  22. Offline


    @Sandbird :

    You haven't heard about that because you are wrong. There is no way that NoCheat would prevent crafting of pistons, or placing of pistons, or in any other way modify your world map or make it impossible to place pistons. It doesn't hook into crafting or crafting recipes, nor does it manipulate in any way or form the world. It only listens to events, and everytime it actually does something it will be logged somewhere (unless you deactivated logging in the config file).

    Your problem definitely must lie elsewhere.

    Just to be sure I tried crafting and placing pistons with 953 and NoCheat 1.07a/1.07b and everything fully works as expected. But I'd like others to check as well and tell me if they can/can't use pistons and if they can relate that to NoCheat. So please everybody who uses NoCheat and CB 953 please try if pistons work for you.

    PS: The only thing I could think of that could be your problem is you either use an outdated version BukkitContrib (a plugin which actually does hook a lot into inventory stuff), or some other plugin that adds recipes/modifies recipes. The effect that NoCheat seems to be the problem could then come from the order that plugins are loaded in. If such another plugin doesn't use the "depends" and "softdepends" instructions in their plugin.yml file correctly and just "hopes" that the plugins they depend on gets loaded before theirs gets loaded (again, probably something that depends on BukkitContrib or similar), it could cause your problems.
  23. Offline


    NoCheat is not blocking a SpeedModifier in Zombe's Mod Pack. NoCheat blocks flying, SpeedModifier while flying, but not SpeedModifer while on the ground. This essentially allows modders to run a lot faster than usual. Please fix. Using CB953, NoCheat 1.07b.
  24. Hi again,

    That is definitely bad took me forever to find that out and now what you are saying makes sense so i have to use the NoCheat in conjunction with other plugins also...omg....thats another day ...

    Just be looking at these can you spot the trouble maker ?

    The problem is that when "this bad thing" happens i have to restore the map, and plugins folder and start again....imagine that with every single plugin comparing with NoCheat.

    Ok i just tried it again with NoCheat On and it did it again....but the nocheat log is totally empty.
    Is it possible to tweak the yml file and actually see something there ?

  25. Offline


    hey there, one question might be dumb but here it goes..
    is there anyway for the logging message to ingamechat stop, i know that the plugin works and they really cant fly but the logging message keeps bugging me like every minute and then some newb just spamms it-.-, pretty much anoying me. Can you please help me how to stop the ingamechat logging when they try to fly or speedhack:]

    Please and Thanks You!!
  26. Offline


    Uh, sorry, forgot.
    CB 953, NC 1.07b
  27. I FOUND IT !!!!! Woohoooo...i was was at the beginning of the list.
    Its the CommandHelper (link) plugin. If NoCheat and CommandHelper are running together then you cant make pistons anymore.
    hmm so now what... I'll notify the author also but how are we gonna come to a solution here ?
    Both plugins are important. :(
  28. Offline


    I guess you use seperate WorldEdit and CommandHelper plugins (and use the CommandHelper plugin that doesn't contain WorldEdit already - there seem to be two different packages)?
    If so, the problem is likely that WorldEdit gets loaded after CommandHelper, instead of before. You can enforce that WorldEdit is always loaded before CommandHelper by adding the following line to CommandHelpers "plugin.yml" (the one that's in the jar-archive):

    depend: [ WorldEdit ]
    (= load WorldEdit first, then CommandBook)


    softdepend: [ WorldEdit ]
    (= try to load WorldEdit first, and independent of if it worked load CommandBook afterwards)
  29. Yes you are right, i am using commandhelper without the worldedit plugin embedded. I run it seperately.
    I realize what you mean now but is it sure that Nocheat will run first before all the others or is it like its going to wait to load after the others are finished ?

    Right now in the yml in the jar you have:
    softdepend: [ Permissions, CraftIRC ]
    Should i just do it :

    softdepend: [ Permissions, CraftIRC, WorldEdit ]

    Thanks again,
  30. Offline


    Hey, could you add smth that block player from using the piston item doublication bug ?
    would be great !
  31. Offline


    Currently NoCheat only waits for "Permissions" and "CraftIRC" to load (if they exist), because it can use some functionality of those two. It doesn't care e.g. if iConomy or other plugins are loaded before or afterwards. If you want to load NoCheat explicitly after WorldEdit, then the above line would do that. In any case you should enforce that WorldEdit gets definitely loaded before CommandHelper.

    So if you want the load order 1. WorldEdit -> 2. CommandHelper -> 3. NoCheat you'd have to add WorldEdit as a dependency in CommandHelpers plugin.yml and CommandHelper as a dependency in NoCheats plugin.yml

    These (soft-)dependencies also influence the order in which plugins are unloaded (exactly the opposite order). So in my case the "softdepend" also means that NoCheat gets unloaded before Permissions and CraftIRC get unloaded. Now that I think of it, the fact that it worked for you exactly 1 time after setting up a new map could point to a problem with unloading, e.g. CommandHelper tries to use some functionality of WorldEdit after WorldEdit is already (partly) unloaded, therefore potentially corrupting the world. That would also be fixed by adding WorldEdit as a (soft)dependency in CommandHelper's plugin.yml.

    This works for all plugins btw, because it's a bukkit feature. So you can change/adapt the order of plugin loading/unloading by editing their respective plugin.yml files. Just try not to create circle dependencies, e.g. A depends on B, B depends on C, C depends on A.

Share This Page