Inactive [SEC/MECH] LWC v4.1.1 :: Lightweight Protection for Chests, Furnaces, Dispensers, and more! [1.2]

Discussion in 'Inactive/Unsupported Plugins' started by Hidendra, Jan 17, 2011.

  1. Offline


    LWC v4.1.1 3/1/2012
    [​IMG] Download
    [​IMG] Bleeding-edge builds
    [​IMG] Feature requests, Suggestions and Issues
    [​IMG] IRC - Live Chat ( #LWC )
    [​IMG] github
    [​IMG] wiki (not fully up to date yet, sorry!)
    [​IMG] Donate

    Using LWC

    [​IMG] Modules
    Modules are seperate plugins much like LWC but extend LWC in some way, usually by giving extra functionality. While there may be more than already listed here, these modules are ones that are officially supported by LWC and maintained by the same author (Hidendra).

    [​IMG] LWC-Economy 1.30 - [​IMG] Download
    Configuration file: plugins/LWC/iconomy.yml

    LWC-Economy allows players to buy protections with economy money. At the moment, iConomy, BOSEconomy and Essentials are supported (have an Econ plugin that you want supported? PM me!) It can be configured on a per-user and per-group basis. It does not use Register.

    Aside from purchasing, when a user removes a protection, they will also be refunded what they initially paid for the protection.

    Discounts can also be given to each individual group, player, or by default. A discount is defined by giving X amount of protections for Y price, e.g 5 protections for free (0). After getting 5 protections for free, they pay full price again. They cannot get another discount again unless one of the following becomes true: a. an admin manually resets them b. the discounted amount of protections is increases (e.g increasing from 5 to 6 will mean said player gets 1 more for free) or c. the discount price itself changes (which means they will again get 5 protections for the new price.)

    What can be protected?
    • Chests
    • Dispensers
    • Furnaces
    • Doors
    • Signs
    • Trap doors
    • Anything else! Protections can be customized to anything you wish.

    • Plug 'n play! LWC handles all dependency resolution -- you just put LWC.jar in your plugins directory
    • Has reached a level where its routinely safe and stable.
    • Protections can be: Public, Password, and Private (by User and/or Groups)
    • If the block has a persistent inventory (ex. chest), LWC can protect it! (Unless the server owner disabled the protection of a specific block!)
    • Limits of how many protections a user or group can lock
    • Small memory footprint. No flat files.
    • For chests, only 1 side of the chest needs to be protected. The plugin saves space by dynamically linking connected chests as protected
    • Much, much more. This post would be extremely long if I were to post every feature LWC has to offer.


    If your server would benefit more from a version of LWC in your native tongue, or you just want to do it because LWC is awesome, I'm open to allow translations to (almost any) language. Almost all LWC messages are editable.
    Locale files can be UTF-8, but are limited by Minecraft's charset (Latin-1.)

    The current and latest English locale can be found here:

    Currently, the following languages are officially bundled with LWC:
    • German - de - @Dawodo
    • Polish - pl - @Geoning @dudsonowa and @andrewkm
    • French - fr - @Cehel
    • Dutch - nl - @MadZero & @aoa2003
    • Czech - cz - @hofec
    • Swedish - sv - @christley
    • Russian - ru - @IlyaGulya - requires a Cyrillic font mod for the MInecraft client
    • Spanish - es - Raul " @RME " Martinez & David " @DME " Martinez
    • Danish - da - @TCarlsen

    Changelog (open)

    LWC 3.54
    • FIX: Exploit related to Showcase & LWC
    • /lwc admin report has been fixed

    LWC 3.53
    • FIX: All Permission plugins will now work as they should. In SuperPerms, lwc.protect will default to true. if you are using Permissions 2/3/GroupManager/etc, lwc.protect will default to false

    LWC 3.52
    • FIX: Permissions 2/3 stopped working correctly in 3.51

    LWC 3.51
    • lwc.protect has been changed to be default false again in SuperPerms

    LWC 3.50
    • Remove the permission metadata from defined commands so the endless onslaught of "LWC throwing Dave error !" stops

    LWC 3.49
    • FIX: Double console output

    LWC 3.48
    • 3.48 and 4.00 alphas can now be interchanged without receiving errors.
    • FIX: lwc.protect now defaults to true for SuperPerms, so Permissions 2/3 can be used without receiving Dave errors

    LWC 3.47
    • NEW: iConomy 6 support. LWC-Economy does not need to be updated, only LWC.jar

    LWC 3.46
    • FIX: The Redstone event was not being propagated via the new events

    LWC 3.45
    • FIX: plugins/LWC/locale/ (Locale override) could not create new key values such as grass, stone, etc.
    • Feature: The "nospam" mode now hides notices.
    • Feature: Double wooden doors will now also auto open when opening them. They must both be protected.

    LWC 3.44
    • FIX: LWC would not auto reconnect to MySQL after sitting idle for a few hours

    LWC 3.43
    • NEW: Native PermissionsEx (PEX) support
    • NEW: /lwc admin purgebanned can now take -remove as an argument to also remove the removed blocks & item contents (e.g: /lwc admin purgebanned -remove)
    • FIX: An exception would be thrown when using /lwc admin cleanup while using SQLite
    • FIX: A Bukkit bug would throw an exception when a block was pushed above a chest via piston
    • FIX: The /permissions command on PermissionsBukkit 1.2 (not 1.1) was not working correctly.
    • The Polish localization has been updated courtesy of @Geoning

    LWC-Economy 1.30
    • NEW: Native Essentials Econ support
    • NEW: type: has been added to discounts (very latest iconomy.yml) to allow you to revert to the old way of how discounts were given (default: EXACT, old way: TOTAL)
    • NEW: Refunds can now be disabled by making iConomy.refunds false

    LWC 3.42
    • The flag "EXEMPTION" has been added to allow you to exempt flags from commands such as ADMIN PURGE and ADMIN EXPIRE; it prevents the protection from being removed unnecessarily. It can only be activated by LWC admins. Use /cexempt on or the usual /lwc flag exempt on
    • FIX: Some servers were experiencing a freezing issue on startup which is now fixed
    • FIX: Disabled modes were not properly disabled, despite being told the mode was disabled.

    LWC-Economy 1.21
    • FIX: On some servers LWC-Economy would not bootstrap itself into LWC correctly
    • LWC is unaffected, but due to how automatic provisioning works, the binary will be different from the last due it modifying the build number in /lwc admin version

    • FIX: Servers with autoUpdate set to true would find 3.40 would crash all of the time due to a stackoverflow exception.
    • FIX: PermissionsBukkit /permissions command was unusable due to LWC making it load when the server first started, not when it normally would.

    LWC-Economy 1.20
    • LWC-iConomy.jar has now become LWC-Economy.jar -- please update accordingly.
    • BOSEconomy is now supported alongside iConomy. No extra setup is necessary for either!
    • Money paid for protections can now be refunded when you destroy the protection, even if the person who paid (the owner) is offline.
    • Discounts now give out the exact amount of protections for the discounted price. For example, if 'newCharge' is set to 0 and 'amount' is set to 5, a player will be able to create 5 protections for free after it takes effect.

    LWC 3.40
    • Almost all current LWC Module events have been deprecated. They have been replaced with events such as: `onProtectionInteract(LWCProtectionInteractEvent event)`
    • Fixed PermissionsBukkit compatibility: some commands did not work correctly
    • `/lwc admin cleanup` has accelerated to warp 5
    • Servers without any Permissions plugin would find anyone would have LWC Admin access
    • The mode "nospam" has been added to prevent protection creation messages from popping up (e.g "created protection successfully.") Use /cnospam or /lwc mode nospam, which toggles it on and off.
    • Protection history. LWC now logs all protection creations/destructions -- in the future, this may log chest access, but if it happens it will be a separate plugin such as LWC-Economy
    • -remove flags have been added to `/lwc admin expire` and `/lwc admin purge <player>` to remove the associated protection block. For example, if you use `/lwc admin purge -remove Hidendra`, it will remove all protections by Hidendra, and also all of the blocks protected in the world, along with any chest contents.
    • If LWC loses connection to MySQL, LWC will prevent access to chests until the connection is regained. This is to prevent stealing from chests if the connection is somehow lost and cannot be immediately regained.
    • Pistons can no longer destroy protected doors and so on.
    • Multitude of bug fixes and minor corrections
    • Minor optimizations

    • PermissionsBukkit is now officially supported. LWC will still work on builds pre-1000
    • lwc.blockinventory has been renamed to lwc.deny - please take note
    • Fixed a bug where protections would be loaded from any world
    • Fixes to the Danish translation

    • Added core.ignoreExplosions to core.yml to allow an admin to allow creeper explosions / TnT to destroy protections
    • Protections will now keep track of the last time they were interacted with
    • Added the command /lwc admin expire to allow you to expire protections that have not been used in so long. Example: /lwc admin expire 2 weeks
    • Added the command /lwc admin purgebanned to remove protections of every played in banned-players.txt
    • Added the command /lwc admin query to allow raw queries on the physical database
    • Drop transferring could not be disabled, it is now fixed.
    • Various bug fixes

    • Fix "fetch size" error
    • Removed the auto-removal of the very old players table


    • Very important bug fix for those who are using MySQL and prefixes. Prefixes will now work correctly and any issues arisen from MySQL usage should now be resolved
    • Fixed lang-defined block names being used in core.yml - protections instead of the english variant, otherwise all protections are broken.

    • It's not all about me! I've tried my hardest and /lwc credits was the result. It turns out there is a lot more people I am extremely thankful to than can fit on one chat page, so instead it scrolls.
    • Many, many people helped with LWC in vastly different ways and it's impossible to credit every single person accurately, thus I missed a few people.

    This update introduces three more languages: Russian, Spanish, and Dutch.
    • Russian - @IlyaGulya - requires a Cyrillic font mod for the Client
    • Spanish - Raul " @RME " Martinez
    • Spanish - David " @DME " Martinez
    • Dutch - @Tcarlsen

    Chunk corruption workaround
    • Have you ever noticed, when you /cinfo'd something, it said "That air is not registered"? Or when chests randomly stop working? If you get this a lot, you are most likely affected by an issue in Bukkit where chunks will mysteriously report Air (or some other block) for each block in the chunk. Please refer to this bug report on Leaky Bukkit:
    • @morganm graciously found a way to workaround this issue, and it involves forcing every single protection to be cached and some other magical tidbits (without getting too technical.) To enable this, open up plugins/LWC/core.yml and then change bukkitBug656workaround to true. If you don't see it under core:, add it:
          bukkitBug656workaround: true

    • Trap doors are now available as a default protection for any new configurations: they will not automatically add themselves to existing LWC configurations
    • The default value for magnet.yml - perSweep has been changed from 20 to 40
    • The command /lwc debug has been added to test your permissions and show you precisely what you have access to
    • LWC now displays the git commit and Jenkins build ( in version strings (e.g /lwc admin version or /lwc admin report).

    • Translation: Swedish! Thank you @christley!
    • Bug fix for block placement

    • Translation: Czech! Thank you @hofec
    • The default value for core.showMyNotices has been changed to false (does not affect current installs.)
    • Burning furnaces have been fixed
    • Iron doors have been fixed
    • Redstone fix
    • Fixed auto register allowing registrations without having lwc.protect
    • Feature: auto openable Iron Doors. On by default -- iron doors (including double doors) will open (or close) when you click them provided they are both protected and you have access to them. "openAndClose," which closes the door automatically after x seconds (3 by default) is available but currently may not work as expected (works oppositely for doors facing North or South; doors will stay open.)
    • Trap doors (aka hatches) have been added to the default protection list. However, if you have an existing core.yml, and want trap doors, you either need to delete core.yml and restart the server (thus redownloading it) or adding trap_door to protections.blocks, e.g
                  enabled: true
                  autoRegister: off

    • Sign names have been normalized to "Sign" (e.g Wall sign and Sign post are shown as just Sign)
    • Added locale values for "you" and block names (chest, furnace, dispenser, wooden_door, iron_door, and so on.) Custom block names can be defined if you have custom protections.
    • Dutch translation -- thank you to @MadZero and @aoa2003

    • Notices will be shown correctly to admins when showMyNotices is disabled.

    • Limit the amount of queries the Magnet module can use (can be changed with magnet.perSweep, default 20. Delete magnet.yml to auto-regen it). On larger worlds, this was a severe issue
    • magnet.enabled now works correctly

    • MySQL prefix is now working as it should
    • Minor fix with the cache update in 3.02

    • Cache null protections as well, to prevent massive redstone spam

    LWC 3.01

    Thank you so much to the many, many people who provided feedback and suggestions on 3.00.
    This changelog may be incomplete as I probably missed some obscure changes.

    The following languages are now available in LWC:

    Lists support
    • LWC supports the Lists plugin which allows you to create a list for your protections to use. Anyone in this list attached to the protection can access your protection
    • When modifing/creating the protection, use l:ListName or list:ListName, e.g: /cmodify l:Test or /cprivate l:Test

    • is now gone. It has been replaced by multiple .yml files, e.g core.yml, limits.yml, worldguard.yml, and so on.
    • Your old is still automatically converted.

    • The old in-database limits has been fully removed. It is replaced by an on-disk alternative, limits.yml. This very easily allows much more in-depth limits management (e.g only: 5 chests, 2 furnaces, 0 doors)

    Custom protections
    • It is now extremely easy to create your own custom protections, or remove existing ones (core.yml -> protections:). For example, this is how you would make Note Blocks protectable, and allow people to play them (But not change the note!):
                enabled: true
                ignoreLeftClick: true

    • [I hope] final major revision to the LWC Api. New additions will allow other plugins to hook into LWC much more easily and do things that were not possible before. Features can be seamlessly integrated into LWC as if they were in LWC itself.
    • PhysDB.getPrivateAccess is now deprecated -- please use protection.getAccess instead!
    • Protections can be more easily modified utilizing methods in their objects: save() (queued save), saveNow(), remove(), removeCache() (just removes the protection from the cache, not the database), and update() (just updates the cached protection, save()/saveNow() already does this)

    LWC Modules
    • Modules can be thought of as a plugin inside LWC itself -- more or less they will change LWC's behaviour in some way, depending on the module.
    • Very easily implemented by developers: cancel protection registrations, cancel that damn protection message, and way more! More info on the wiki.

    Admin customization
    • There are now a ton of permissions nodes; there is one for each admin command. For example, for every Admin command, you could use: lwc.admin or lwc.admin.*. For just "find" and "forceowner", you could give a group/player the following: lwc.admin.find and lwc.admin.forceowner. Full list on the wiki.
    • Please note that lwc.admin.* only grants all Admin commands; lwc.admin still has a higher authority over the former (e.g, lwc.admin is considered the owner of any protection, while lwc.admin.* is not !!)

    Player customization
    • Like the admin commands, the main LWC commands can now be customized via permissions. lwc.protect still functions the same (all functionality); some examples of new nodes are: lwc.create or lwc.create.* (create anything), lwc.create.private (only be able to create private protections), (/cinfo), lwc.modify (/cmodify), lwc.unlock (/cunlock), and so on. Full list on the wiki.
    • Please note that without lwc.protect, you need to manually assign flags. E.g: lwc.flag.* or / lwc.flag.magnet

    Magnet flag
    • The chest will act as a magnet and suck up nearby items (within a 3 block radius.) This can be very useful for automatic farms (e.g animals or crops.) It is compatible with double chests.
    • Can also specify items that these special chests will not pick up (in magnet.yml)
    • Compatible with Double Chests

    • It is now possible to sell protections with the fully optional LWC-iConomy bridge module. You just throw LWC-iConomy.jar into your plugins folder and then edit iconomy.yml in plugins/LWC/ when it's generated on the next startup!
    • You can also allow players to have a certain amount of protections at a reduced price (or even free) e.g free protections while you have less than 5 (but regular price after that.)

    • LWC now does major caching of protections in memory. Previously, LWC hit the database everytime a protection is opened; now they are routinely stored in cache without a huge hit on memory usage (very minimal.) It can be increased from the default of 10000 if you wish in core.yml (core.cacheSize). More will most likely be cached in the future
    • Access rights are now stored with Protections (for the curious, it uses an OUTER JOIN, so just 1 query.)
    • Protections are precached (as many as possible) when the server is started
    • Lots of bug fixes (mostly miscellaneous.)

    • MySQL prefix can now be configured (if you change it with an existing MySQL install, it will fix that automatically, don't worry!)
    • /cpersist or /lwc mode persist now acts as a toggle for the mode
    • Added the following aliases: /cpersist , /cdroptransfer , /cmagnet , and /cadmin
    • /climits displays your protection limit and how many protections you have protected.
    • Minor changes all around


    • Security bugfix regarding an issue in minecraft itself (thanks sycot)

    • Native German translation! If you wish to use LWC in German, please change "locale" in to de. Many thanks to @Dawodo for doing the translation!
    • /lwc admin cleanup will now show the correct values instead of variable names when outputting results
    • enforce-worldguard-regions is now compatible with WorldGuard 5.x
    • Redstone is now changed again. All set redstone flags are reset. Redstone will obey the deny-redstone config value (which is false by default), meaning if it is set to false, you need to explciitly set the flag to disable redstone (/lwc flag redstone on), and if it is set to true, all doors prevent redstone by default so you need to set the flag to allow redstone.

    • Minor bug fixes

    • By default, redstone WILL NOT open doors (at the moment, it appears dispensers are unaffected, hopefully they will be fixed in CraftBukkit). In order to allow redstone to open your door, you need to issue this: /lwc flag redstone on. Using /lwc flag will show you the available protection flags -- these are "switches", only on/off (only redstone flag exists at the moment)
    • Bug fix: Protections will auto protect themselves again when being placed

    • Official support for RB builds >600 now that I am back home
    [hit max thread length]

    enjoy, gents
  2. Offline


    okay, waiting for update. THANKS!
  3. Offline


    i dont want multiworld support, i really dont give a crap xD
    could you post one for upload without multiworld support? so its not being an asshole xD
    --- merged: Mar 7, 2011 10:41 PM ---
    more detail:
    #Minecraft server properties
    #Sun Mar 06 00:28:52 EST 2011
    Please note: My IP doesnt seem to need to be there, is that whats wrong?
  4. Offline


    I changed your config file quite a bit so it didn't have un necessary stuff

    try this:
    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    #   Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    #   Does not work for the default world.
    #  Example: copies: Derp    -  This will clone the permissions of the world Derp
    # Make sure to rename this file to the name of the world that is in under
    # level-name.  So if it is level-name: world  then this should be world.yml and in the
    # plugins/Permissions directory (ie. plugins/Permissions/world.yml)
    # NOTE: Do not use tabs while editing this document.  Use only spaces.  A good way to avoid
    # doing this is to use Notepad++ and replace the tab with 4 spaces.
            system: default
    # AntiBuild is included with this.  To disable a group from being able to build then
    # set the build: flag to false (build: false).  If you want a group to be able to build
    # then set it to true.
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:" like so:
    #   Example:
    #       inheritance:
    #           - Default
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #       - 'general.spawn'
    #   Otherwise errors will happen!
    #   Globalized Permission settings:
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #           - 'general.*'
    #       This will allow you to use all general commands.
    #   Single Asterisk denotes all commands:
    #       - '*'
    #   If you give a group this permissions, do not have the group inherit any permissions
    #   from other groups.  Any users assigned to this group should NOT be given any additional
    #   permissions either.
    #   To exempt a node use the - prefix like so:
    #       - '-general.time'
    #   prefix: and suffix: do not do anything on their own.  You need another outside plugin
    #   such as iChat or HeroChat in order for these to do anything.
            default: true
                prefix: ''
                suffix: ''
                build: false
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Outsider
                - 'lwc.protect'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Civilian
            default: false
                prefix: ''
                suffix: ''
                build: true
                - '*'
    # Users denote which users are included in which group.
    # TheNo1Yeti is in the Admin group
    # Herpina is a member of the Moderator group but also has access
    # to the herp.derp permissions
    # Derpina is a member of the admin group but does not have access
    # to the derp.derp permission node
    # Users can also have a prefix and suffix as seen with Herpina
            group: Admins
            group: Moderator
                prefix: 'Moo'
                suffix: 'Cow'
    No, that's normal
  5. Offline


    1,508 kb
  6. Offline


    kk, well its still not working but I really do apreciate all your effort, :)

    ## LWC configuration file
    # + Github project page:
    # + Bukkit thread link:
    #Mon Mar 07 18:10:19 EST 2011
    this is the last thing i could think to post ):

    Edit: it seems it just says I dont have permission D:
    18:14:34 [INFO] Starting minecraft server version Beta 1.3
    18:14:34 [INFO] Loading properties
    18:14:34 [INFO] Starting Minecraft server on *:25565
    18:14:34 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-493-
    g8b5496e-b493jnks (MC: 1.3)
    18:14:34 [INFO] Preparing level "world"
    18:14:34 [INFO] Preparing start region
    18:14:34 [INFO] LWC     [v1.57] Loading shared objects
    18:14:34 [INFO] Config  [v1.57] Loaded 13 config entries
    18:14:34 [INFO] LWC     [v1.57] Native library: plugins/LWC/lib/native/Windows/a
    18:14:35 [INFO] Updater [v1.57] Update detected for LWC
    18:14:35 [INFO] Updater [v1.57] Latest version: 1.58
    18:14:35 [INFO] ChatBukkit v0.0.1 is enabled!
    18:14:35 [INFO] CraftBookCommon 3.0-alpha1 enabled.
    18:14:35 [INFO] CraftBookCircuits 3.0-alpha1 enabled.
    18:14:35 [INFO] CraftBookMechanisms 3.0-alpha1 enabled.
    18:14:35 [INFO] CraftBookVehicles 3.0-alpha1 enabled.
    18:14:35 [INFO] GroupManager - INFO - Scheduled Data Saving is set for every 10
    18:14:35 [INFO] GroupManager version 1.0(pre-alpha-3) is enabled!
    18:14:35 [INFO] Fake Permissions version 2.5 is enabled!
    18:14:36 [SEVERE] com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Commu
    nications link failure
    Last packet sent to the server was 0 ms ago.
    18:14:36 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance
    0(Native Method)
    18:14:36 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance
    (Unknown Source)
    18:14:36 [SEVERE]       at sun.reflect.DelegatingConstructorAccessorImpl.newInst
    ance(Unknown Source)
    18:14:36 [SEVERE]       at java.lang.reflect.Constructor.newInstance(Unknown Sou
    18:14:36 [SEVERE]       at com.mysql.jdbc.Util.handleNewInstance(
    18:14:36 [SEVERE]       at com.mysql.jdbc.SQLError.createCommunicationsException
    18:14:36 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionI
    18:14:36 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.j
    18:14:36 [SEVERE]       at com.mysql.jdbc.JDBC4Connection.<init>(JDBC4Connection
    18:14:36 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance
    0(Native Method)
    18:14:36 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance
    (Unknown Source)
    18:14:36 [SEVERE]       at sun.reflect.DelegatingConstructorAccessorImpl.newInst
    ance(Unknown Source)
    18:14:36 [SEVERE]       at java.lang.reflect.Constructor.newInstance(Unknown Sou
    18:14:36 [SEVERE]       at com.mysql.jdbc.Util.handleNewInstance(
    18:14:36 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionI
    18:14:36 [SEVERE]       at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegist
    18:14:36 [SEVERE]       at java.sql.DriverManager.getConnection(Unknown Source)
    18:14:36 [SEVERE]       at java.sql.DriverManager.getConnection(Unknown Source)
    18:14:36 [SEVERE]       at com.matejdro.bukkit.jail.InputOutput.createConnection
    18:14:36 [SEVERE]       at com.matejdro.bukkit.jail.InputOutput.getConnection(In
    18:14:36 [SEVERE]       at com.matejdro.bukkit.jail.InputOutput.PrepareDB(InputO
    18:14:36 [SEVERE]       at com.matejdro.bukkit.jail.Jail.onEnable(
    18:14:36 [SEVERE]       at
    18:14:36 [SEVERE]       at
    18:14:36 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.enablePlugin(Si
    18:14:36 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftSe
    18:14:36 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    18:14:36 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServe
    18:14:36 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    18:14:36 [SEVERE]       at net.minecraft.server.MinecraftServer.d(MinecraftServe
    18:14:36 [SEVERE]       at
    18:14:36 [SEVERE]       at
    18:14:36 [SEVERE] Caused by: Connection refused: conn
    18:14:36 [SEVERE]       at Method)
    18:14:36 [SEVERE]       at Source)
    18:14:36 [SEVERE]       at Sou
    18:14:36 [SEVERE]       at Source)
    18:14:36 [SEVERE]       at Source)
    18:14:36 [SEVERE]       at Source)
    18:14:36 [SEVERE]       at Source)
    18:14:36 [SEVERE]       at<init>(Unknown Source)
    18:14:36 [SEVERE]       at<init>(Unknown Source)
    18:14:36 [SEVERE]       at com.mysql.jdbc.StandardSocketFactory.connect(Standard
    18:14:36 [SEVERE]       at com.mysql.jdbc.MysqlIO.<init>(
    18:14:36 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionI
    18:14:36 [SEVERE]       ... 25 more
    18:14:36 [SEVERE] null loading Jail v0.5.3 (Is it up to date?)
            at com.matejdro.bukkit.jail.InputOutput.PrepareDB(
            at com.matejdro.bukkit.jail.Jail.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.d(
    18:14:36 [INFO] Config  [v1.57] Loaded 13 config entries
    18:14:36 [INFO] Updater [v1.57] Update detected for LWC
    18:14:36 [INFO] Updater [v1.57] Latest version: 1.58
    18:14:36 [INFO] LWC     [v1.57] Loaded command: /lwc -admin
    18:14:36 [INFO] LWC     [v1.57] Loaded command: /lwc -create
    18:14:36 [INFO] LWC     [v1.57] Loaded command: /lwc -free
    18:14:36 [INFO] LWC     [v1.57] Loaded command: /lwc -info
    18:14:36 [INFO] LWC     [v1.57] Loaded command: /lwc -p
    18:14:36 [INFO] LWC     [v1.57] Loaded command: /lwc -modify
    18:14:36 [INFO] LWC     [v1.57] Loaded command: /lwc -unlock
    18:14:36 [INFO] LWC     [v1.57] Loaded command: /lwc -owners
    18:14:36 [INFO] LWC     [v1.57] -> PLAYER_QUIT
    18:14:36 [INFO] LWC     [v1.57] -> ENTITY_EXPLODE
    18:14:36 [INFO] LWC     [v1.57] -> BLOCK_INTERACT
    18:14:36 [INFO] LWC     [v1.57] -> BLOCK_DAMAGED
    18:14:36 [INFO] LWC     [v1.57] -> BLOCK_BREAK
    18:14:36 [INFO] LWC     [v1.57] -> BLOCK_PLACED
    18:14:36 [INFO] LWC     [v1.57] -> REDSTONE_CHANGE
    18:14:36 [INFO] LWC     [v1.57] Using Nijikokun's permissions plugin for permiss
    18:14:36 [INFO] Fake Permissions version 2.5.2 is enabled!
    18:14:36 [INFO] LWC     [v1.57] Loading SQLite
    18:14:36 [INFO] PhysDB  [v1.57] Creating physical tables if needed
    18:14:36 [INFO] MemDB   [v1.57] Creating memory tables
    18:14:36 [INFO] SQLite  [v1.57] Using: Native
    18:14:36 [INFO] ScrapBukkit version 0.2.1 is enabled!
    18:14:37 [INFO] [Towny] Database: [Load] flatfile [Save] flatfile
    18:14:37 [INFO] [Towny] Using: Permissions
    18:14:37 [INFO] [Towny] Version: 0.46 - Mod Enabled
    18:14:37 [INFO] WorldEdit 4.0-beta8 enabled.
    18:14:37 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
     for permissions.
    18:14:37 [INFO] Done (0.306s)! For help, type "help" or "?"
    18:14:45 [INFO] 143 recipes
    18:14:45 [INFO] zoolder101 [/] logged in with entity id 137
    starter^ i also tried to enter /lwc, it does not come up here but says "you do not have permission to do that"
  7. Offline


    That error is for Jail.

    "You do not have permission to do that" means you don't have access to lwc.protect -- perhaps there's still something wrong?
  8. Offline


    Sorry to say, but this update broke :( Left my server with unprotected chests for 3 hours, luckily only two people noticed who I trust.

    Auto-update disabled, I think going forward might it be worth waiting a few days once an update is published, before pushing it onto autoupdate clients? Security mods shouldnt break themselves by default and letting people test it before pushing it out live might be worth considering.
  9. Offline


    I did not know of it ahead of time, this time :). Even now, I can't reproduce the problem myself but is fixed (I have the same plugins, same java, same CB build!)
    But yes, that is a good idea :)

    Gladly, there wasn't too many major changes that required a lot of reverts, so 1.59 will be out shortly.
  10. Offline


    i copy pasted, the one you made. Hmm thats weird?
  11. Offline


    You're in the admins group, right?

    LWC 1.59
    • LWC loads sqlite in its own ClassLoader now to prevent access exceptions with other plugins who use SQLite as well
  12. Offline


    ooo, should I install the new one?
  13. Offline


    1.59 mainly affects 1.58, but it won't hurt.
  14. Offline


    tried 1.59? can't find 1.57, got the same error? as before

    2011-03-07 16:49:31 [INFO] LWC    [v1.59]    Loading SQLite
    2011-03-07 16:49:31 [INFO] PhysDB    [v1.59]    file:/C:\Users\Ben\Desktop\Minecraft\BUKKIT\plugins\LWC\lib\sqlite.jar!/
    2011-03-07 16:49:31 [SEVERE] org/sqlite/Conn loading LWC v1.59 (Is it up to date?)
    java.lang.IllegalAccessError: org/sqlite/Conn
        at org.sqlite.JDBC.connect(
        at java.sql.DriverManager.getConnection(Unknown Source)
        at java.sql.DriverManager.getConnection(Unknown Source)
        at com.griefcraft.sql.Database.connect(
        at com.griefcraft.lwc.LWC.load(
        at com.griefcraft.lwc.LWCPlugin.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.d(
    2011-03-07 16:49:31 
  15. Offline


    well i geuss ive tried everything, thanks for the help though I really appreciate it. You helped me more than any other plugin dev. Thanks :)
    --- merged: Mar 8, 2011 12:10 AM ---
  16. Offline


    As of LWC 1.59 I get this error with CB507:

    11:15:57 [INFO] PhysDB	[v1.59]	file://Users/admin/Desktop/McMyAdmin/plugins/LWC/lib/sqlite.jar!/
    11:15:57 [SEVERE] java.lang.ClassNotFoundException: org.sqlite.JDBC
    11:15:57 [SEVERE] 	at$
    The jar and the bindings download fine, although it does so twice for some reason:

    11:14:21 [INFO] Updater	[v1.59]	Need to download 4 file(s)
    11:14:21 [INFO] Updater	[v1.59]	 - Downloading file :
    11:14:26 [INFO] Updater	[v1.59]	  + Download complete
    11:14:26 [INFO] Updater	[v1.59]	 - Downloading file :
    11:14:32 [INFO] Updater	[v1.59]	  + Download complete
    11:14:32 [INFO] Updater	[v1.59]	 - Downloading file :
    11:14:38 [INFO] Updater	[v1.59]	  + Download complete
    11:14:38 [INFO] Updater	[v1.59]	 - Downloading file :
  17. Offline


    I hate permissions so much, I hope someday a more simple method is implemented, I know this isnt the spot but still, Hmod was much easier, I hope this is addressed in the full version of Bukkit. Till than Ill have to do without. Thanks Hidendra, I really do appreciate it I understand you have a lot of questions coming in, and you did do more than I expected. You sir, have my respect.
  18. Offline


    Interesting. are you on IRC?

    Does it not work if you restart?

    Also, sorry for the issues gents. I can't even get this error on a fresh CB. I'll try a VM to see if I can reproduce it on linux (I have a bunch already installed, so should be fairly quick)

    edit: Ok, it happens on linux for me. I'm working on it.
    --- merged: Mar 8, 2011 1:15 AM ---
    Please update to 1.60. If you still have issues, do post asap or find me in the Bukkit IRC (, i use the handle Hidendra). Thank you

    LWC 1.60
    • 1.59 was not compatible with unix like systems

    P.s if there aren't any more major issues because of that, the next update will be delayed for more rigorous testing, as the next featureful version will add quite a bit
  19. Offline


    no IRC

    thanks for all your help...
  20. Offline


    Do you get the same error on 1.60? What OS are you on?
  21. Offline


    same error, Win 7 x 64
  22. Offline


    Ok, could you please modify your file that starts the server temporarily to something like this:
    java -verbose:class -Xms1024M -Xmx1024M -jar CraftBukkit.jar > log.txt
    And then please upload the log.txt in your minecraft directory somewhere (i.e mediafire). Or attach it to your post. It'll be over 100 KB
  23. Offline


    Sorry for the late response to my earlier post. Yes I had just upgraded to LWC 1.58 and it was outputting that error. The server is also running GroupManager and Essentials if that has anything to do with it.

    /lwc -a also gives the internal error message.
  24. Offline


    say it looks like some other plugins are having the same problem too

    Attached Files:

    • log.txt
      File size:
      21.9 KB
  25. Offline


    Using CB 493, LWC 1.60, SQLite

    LWC loads ok, but when someone uses /cprivate or /lwc -c private:

    2011-03-08 01:43:58 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'cpublic' in plugin LWC v1.6
        at org.bukkit.command.PluginCommand.execute(
        at org.bukkit.command.SimpleCommandMap.dispatch(
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
        at net.minecraft.server.NetServerHandler.c(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(SourceFile:230)
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
        at com.griefcraft.lwc.LWC.getLocale(
        at com.griefcraft.lwc.LWC.sendLocale(
        at com.griefcraft.commands.Create.execute(
        at com.griefcraft.lwc.LWCPlugin.onCommand(
        at org.bukkit.command.PluginCommand.execute(
        ... 12 more
  26. Offline


    Are you sure you had the -verbose:class in it? Also, try disabling Jail, does LWC then work?

    Do you have FakePermissions.jar in your plugins folder (For GroupManager)?

    Redownload -- I will push the version up once this other issue is resolved (so as to not go up a version every 5 minutes)
  27. Offline


    CB: 493, GroupManager: 1.0 A2, LWC 1.6
    2011-03-07 20:45:05 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'lwc' in plugin LWC v1.6
        at org.bukkit.command.PluginCommand.execute(
        at org.bukkit.command.SimpleCommandMap.dispatch(
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
        at net.minecraft.server.NetServerHandler.c(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(SourceFile:230)
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
        at com.griefcraft.lwc.LWC.getLocale(
        at com.griefcraft.lwc.LWC.sendLocale(
        at com.griefcraft.commands.Create.execute(
        at com.griefcraft.lwc.LWCPlugin.onCommand(
        at org.bukkit.command.PluginCommand.execute(
        ... 12 more
  28. Offline


    I was having a similar problem with ALL MY PLUGINS that used MySQL or SQLite on my test server. I think the problem was caused by a test build of BigBrother. I downgraded it back to 1.6.3 and the problem went away with all other plugins [I think]. I don't know if the test build was conflicting directly with LWC or another plugin since I didn't feel like testing it too much. Are both of you with errors using BB? Actually, I can see frozenbeen is from the log. Try disabling it and see if the other plugins load without errors.
  29. Offline


    couldnt get the -verbose:class stuff to work with the run file...

    jail taken out of plugins folder and same issue still
  30. Offline


    Redownload. 1.61 with the fix mentioned will be out soon

    I see. as @GameFAQsRolo as mentioned, are you using a test build of bigbrother? try removing it

    Well, that's a slight relief if it's BigBrother causing it :). It may not be, though.

    edit: my test server has LWC / Jail / BB / MyHome (all use sqlite), and it's running fine thus far.. They're all the latest versions. D:
  31. Offline


    Whein i tried to protect my chest a messege appears telling that "There was an internal error occured while attempting to perform this comand"

    Help pls, i need this plugin :) Is so awesom!

Share This Page