[SEC/MECH/FUN] PreciousStones - Block Area Proteciton System [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by phaed, Jan 18, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Well it seems no one short of admin can place protection stones even with the specific permissions nodes. The other commands seem to work but the fields just don't get created for them.

    I've given these permissions to the group in question:

    #^some kind of hack that allegedly sometimes works when the other perm doesn't)

    The only group that this works for is admin, which has no pstone specific nodes, but does have this node:

    superpermbridge.*: true
    #^which is the hack to replicate admin having '*' (the wildcard/everything) with the older permissions plugins.

    It seems the latter is the only thing allowing this plugin to work fully with PermissionsBukkit, but obviously I can't give that node to everyone. I'll look at migrating to Permissions 3 I guess. You don't sound too keen on the new system and I just need to make it all work.
  3. Offline


    Ill look into adding support for it.
  4. Offline


    hey Phaed, I posted an issue in your GitHub, I saw that link before I saw all the support questions here, oops. Either way, it's there. Or I can move it here if you want me to.
  5. Offline


    I just migrated to PermissionsEx (hah, impatience wins :p ). Some other people might like support for the new thing though, especially if it does catch on.

    PS seems to be working good again. On to the next crisis!
  6. Offline


    I am noticing the same thing. im on CB 1000 and PS 5.3.3
  7. Offline


    I'm getting

    2011-07-21 11:50:24 [WARNING] Error at SQL Query: [SQLITE_CONSTRAINT] Abort due to constraint violation (columns x, y, z, world are not unique)

    on the order of hundreds per second on some block placements, but it's hard to replicate. Is there any way to revert to the old database style? My server doesnt have many fields but I need fast responses on stone placement and breakage.
  8. Offline


    same thing im always updating, if its not my smartsave not working then its preciousstones not saving -.-...it dosent auto save anymore
  9. Offline


    yeah i get sql locked stuff too all the time.
  10. Offline


    Odd, you guys are all using SQLite am I correct? What is the latest version that worked for you
  11. Offline


    Sorry i should have been more clear i am only seeing the forester problem. I am not having any other issues as i am using mysql
  12. Offline


    im using ubunut/linix idk wtf im using i hate sql tho
  13. Offline


    I just tried to install this plugin and i get this error:
    [SEVERE] Error occurred while enabling PreciousStones v5.3.3 (Is it up to date?): BLOCK_PISTON_EXTEND
    java.lang.NoSuchFieldError: BLOCK_PISTON_EXTEND
        at net.sacredlabyrinth.Phaed.PreciousStones.PreciousStones.registerEvents(PreciousStones.java:159)
        at net.sacredlabyrinth.Phaed.PreciousStones.PreciousStones.onEnable(PreciousStones.java:125)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:857)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:264)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:151)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:136)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    I have the following plugins installed: ButtonControl, CommandBook, CommandSigns, CraftBookCommon, CraftBookCircuits, CraftBookMechanisms, CraftBookVehicles, HeroChat, InvisibleWalls, MyWarp, NoIce, Permissions, SetRank, SimpleSkylands, VoxelDoop, WorldEdit, WorldGuard, Administrate, PreciousStones.
    I'm running CraftBukkit build 953.
  14. Offline


    5.3.3 is for cb #1000 which has piston events. Go back to 5.3.2.
  15. Offline


    Last time I tried it was a few months ago when it just used a text file, CSV or YAML i think. I stopped getting errors now but I still have my death pumpkins stop working sometimes when the server is a few hours old, but they work just fine on a fresh start.
  16. Offline


    As I told you - I get the same thing on cb1000 with 5.3.3 ....
  17. Offline


    Yours is different yours is a casting error that seems to be a bukkit bug. His is that there is no BLOCK_PISTON_EXTEND event.
  18. Offline


    I'll go back to learning how to read ;) Sorry
  19. Offline


    My server has been getting the same error yours has. Randomly it seems plugins that use these events (PS, BigBrother, PistonChest), begin to throw these errors. Its not something the plugins are doing, it seems to b internal to bukkit. I'm sure it will be patched up on a future build.
  20. Offline


    this is happening to me too and I can't get the plugghin to turn on with this error.
  21. Offline


    Hello there I'm making a server and was wondering if I could use this to were only iron protects itself by making the protetction area 1x1x1 so you'd have to make your entire house out of iron to be safe, cuz I don't want the entire thing mostly, just think it would be cool if a metal house couldn't be destoryed.
    thanks ~jack
  22. Offline


    Yes you don't need to make fields with 1x1x1. Just add iron to the unbreakable-blocks list.
  23. Offline


    I love this plugin. My server can not exist without this.

    I have a problem. I just updated my ubuntu to natty... In doing so, mysql deamon was restarted..

    and.. for some time.. Mysql-bukkit connection was broken...(it is my fault.);;

    but now.. mysql is normally working.. Table has normal data.. but... My PreciousStones which was placed before has lost their functions.

    newly placed PS works... but My server has thousands protecting stones.....

    We should replace all of them..

    Is there any better solution??

  24. Offline


    1. Maybe you upgraded to a new version of PS from a version that used the old table names (ps_fields) rather than the new names (pstone_fields)?
    2. What does your server say when PS starts up on the console? How many fields does it find does it find all the old ones?
    3. Does your config file still has all the fields with the same type ids as before?
    4. If you were running PS without MySQL then it was using SQLite. And that's where all your old pstones now are. You should have this file plugins/PreciousStones/PreciousStones.db. Open it up with http://www.sqlitemanager.org/ and try exporting all your pstones from here and insert them into your MySQL tables.
  25. Offline


    Dear, phaed .So Sooooooooooooorry!!!!!

    Your plugin has no problem.. It was my fault!!!

    It was using sqlite... starting with empty db..

    sorry for bothering you......

    I put the PS 5.3.3. into plugin folder without reading your notice...

    sorry for that... I converted DB and set config.yml. now working perfectly..


    but this makes error.. for me..

    I changed `packed_snitch_list` to something.

    thanks again.

  26. Offline


    Use this:

    INSERT INTO `pstone_fields` (`id`, `x`, `y`, `z`, `world`, `radius`, `height`, `velocity`, `type_id`, `owner`, `name`, `packed_allowed`)
    SELECT `id`, `x`, `y`, `z`, `world`, `radius`, `height`, `velocity`, `type_id`, `owner`, `name`, '' as one
    FROM `ps_fields`
  27. Offline


    In Client console, i get this error when they type



    "Syntax Error"

    Why this happening this? I use the last version in MySQL

    Ever figured out why I was giving the error. To work properly, you must be using Permissions 3.1.6 (http://forums.bukkit.org/threads/admn-dev-permissions-3-1-6-the-plugin-of-tomorrow-935.18430/)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  28. Offline


    Not sure what caused this but it was in the log:

    2011-07-25 14:32:01 [WARNING] Task of 'PreciousStones' generated an exception
            at java.util.HashMap$HashIterator.nextEntry(HashMap.java:810)
            at java.util.HashMap$KeyIterator.next(HashMap.java:845)
            at net.sacredlabyrinth.Phaed.PreciousStones.managers.EntryManager$1.run(EntryManager.java:71)
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:438)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  29. Offline


    Is there something wrong with the Forester block? i place some around but nothing happening i tell me i have set down forester but no tree or anything happen
  30. Hello. We were going to use the Entry Bouncers in our cities, so mayors could literally kick people out. But we wanted everyone to be able to pass through by default. We did this with /ps allow *

    then we tried to kick out an offender with /ps remove <name> but he was still able to travel within. I dont know if its possible, but it would be simply awesome if everyone could somehow be allowed by default, and then we could remove specific persons

    I dont know if you are aware. But the plugin doesent save protections on other worlds than World and World_nether. I am using mysql though, dont know if it works with sqlite. LWC and logblock for example seem to work fine in the other worlds

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  31. When I stop my server by "stop" comand, I see no [PrecisousStone] Saving message... is it normal ?

    Because when I restart the server, fields arent active...

    CB 1000, PS5.3.3
Thread Status:
Not open for further replies.

Share This Page