[SEC/MECH/FUN] PreciousStones - Block Area Proteciton System [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by phaed, Jan 18, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Nope, player_name is a field in the pstone_players table. Delete that table so it can recreate itself.
  3. Offline


    Yeah it seems better now. Thanks.
  4. Offline


    You were probably upgrading from 5.3.1 I imagine. The pstone_players table had a column named "name" in that build, i had to rename it to player_name cause it was conflicting with the "name" column from pstone_fields table when I would do a join. So anyone upgrading from that specific build has to delete the table so it can recreate itself with the correct name.
  5. Offline


    I can't figure this one out. I'm now using the new PermissionsBukkit and I have given "preciousstones.admin.info: true" to my builder group but they just get "Syntax error" when trying to issue "/ps info". It works for me as admin and that node worked previously under GroupManager. So I guess I'm having a permissions issue but I'm not sure if it's the new plugin or something you can adjust. Looks like healing stones aren't working for them either. Same issue, probably.

    Permissions my ranks have that relate to this issue (or may). Each group is inherited by the next:

    builders have:
                preciousstones.admin.info: true
                preciousstones.benefit.*: true
                preciousstones.whitelist.*: true
    mods have:
                preciousstones.admin.*: true
    semiadmin has:
                preciousstones.alert.*: true
                preciousstones.bypass.*: true
    admin has:
                superpermbridge.*: true
    /ps info only works for admin. That last node simulates the old "*" for admin I believe. This new permissions plugin seems to be otherwise working for my new and existing plugins.
  6. Offline


    I have a question about the shocker block... Is it possible to have it stay and keep working after it's used instead of having to replace it manually? I am making a maze and I want the lighting to strike at certain places every time someone triggers them but they disappear. I tried "lightning-replace-block" to replace the block with itself again but the new block doesn't trigger... I guess because it wasn't placed by anyone and has no owner, kinda like it spawned naturally. If this isn't possible now maybe you could make this an option in a future update? This would make the shocker block very useful for me.
  7. Offline


    I can add a flag on next verison
  8. Offline


    That would be great thanks!
  9. Offline



    My server is getting spammed with these on 5.3.3 since I updated:

    2011-07-19 22:58:08 [SEVERE] Could not pass event BLOCK_PISTON_EXTEND to PreciousStones
    java.lang.ClassCastException: org.bukkit.material.MaterialData cannot be cast to org.bukkit.material.PistonBaseMaterial
    Any ideas?
  10. Offline


    Download link broken!
  11. Offline


  12. Offline


    Download link isn't functioning, acts as if website/link is down. I would like try the mod out. I'll check back later.
  13. Offline


    Sorry guys my host has been acting up. They tell us they are doing maintenance on their routers, should not be a prob in the future.

    That is very very very odd. What version of db are you using? This is the only thing that is happening on piston extend:

    public void onBlockPistonExtend(BlockPistonExtendEvent event)
    Blockblocks event.getBlocks();

            for (
    Block block blocks)
                if (
    plugin.settings.isFieldType(block) && plugin.ffm.isField(block))
                if (
    plugin.settings.isUnbreakableType(block) && plugin.um.isUnbreakable(block))
    Hmmmm.... no idea, ill look into it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  14. Offline


    No problem. Thanks for checking on it.
  15. Offline


    Bukkit's POS permissions system does not resolve asterisks or group hierarchies. To bukkit, preciousstone.benefit.* is just a string -- it has no meaning. If you want to give your users permissions, you will have to give them the individual nodes.
  16. Do you recommend any plugin for multiworld support? I am trying to get PS to work in the new Skylands, but it seems random. Sometimes the protections are up, sometimes they arent. Maybe PS doesent know to load them?
  17. Offline


  18. Offline


    Um so you don't recommend the new system then?

    I understand benefit is using the wildcard, but I gave both preciousstones.admin.info and (their workaround) superpermbridge.preciousstones.admin.info to the group in question so they can use "/ps info" and neither permission seems to work. And I'm not getting the normal permissions error 'you don't have permission...', just this mysterious 'Syntax error'. Again, I think all my other plugins are working. I'm just not sure what else I can do (other than switch again to another permissions system that may or may not get dumped due to this new "official" system *stabs self*). Blargh should have stayed on 953.

    EDIT: Doing a recursive string search for "Syntax error" on my plugins directory, the PS .jar comes up as the only result. Does some condition or another cause that error to be thrown?
  19. Offline


    I don't believe PS will load any world ever (not what it does). But if you have existing PS fields in a world and you have another plugin load that world, the PS fields should still be there (as I understand it) as long as the name of the world didn't change.


    I figured it out. I needed to give preciousstones.benefit.ps in addition to the info node. The syntax error was from having one without the other I guess.

    Having to explicitly name all nodes is more of a pain for sure, but I was hoping we were all at least moving toward some standard instead of having so many different systems. Oh well maybe it will get better after some more development.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  20. Offline


    Yea if you read the FAQ thread which is one long complain letter to the bukkit team by every single plugin dev, they tell you they are not adding any group functionality and are relying on external systems to add that in. So you will STILL need to add a permissions plugin. Figure that, what a game changer huh. Meh.

    So what is this bukkit permissions system adding to the table? Nothing but extra work. What is it taking away? Quite a few things. Is it worth it? No.
    GmK likes this.
  21. Offline


    I'm getting all sorts of chunk errors like this one:

    01:44:48 [INFO] Chunk (2, 45) stored at (2, 47)
    01:44:48 [INFO] net.minecraft.server.Chunk
    01:44:48 [SEVERE] java.lang.Throwable
    01:44:48 [SEVERE] at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(ChunkProviderServer.java:124)
    01:44:48 [SEVERE] at net.minecraft.server.World.getChunkAt(World.java:274)
    01:44:48 [SEVERE] at net.minecraft.server.World.getTypeId(World.java:221)
    01:44:48 [SEVERE] at org.bukkit.craftbukkit.CraftWorld.getBlockTypeIdAt(CraftWorld.java:68)
    01:44:48 [SEVERE] at net.sacredlabyrinth.Phaed.PreciousStones.managers.TagManager.isTaggedArea(TagManager.java:109)
    01:44:48 [SEVERE] at net.sacredlabyrinth.Phaed.PreciousStones.listeners.PSPlayerListener.onPlayerMove(PSPlayerListener.java:306)
    01:44:48 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:286)
    01:44:48 [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    01:44:48 [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
    01:44:48 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:164)
    01:44:48 [SEVERE] at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    01:44:48 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    01:44:48 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    01:44:48 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    01:44:48 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    01:44:48 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    01:44:48 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    I'm not sure if it's PreciousStones causing the problem but it gets named in a lot of errors. I also get database errors on the order of hundreds per second sometimes, but I can't seem to force them.
  22. Offline


    Weird - using the 'normal' CB1000, MySQL, Permissions 3.1.6. I'll make a backup and let it rebuild everything by itself, even if the error doesnt indicate a db problem...
  23. Offline


    I also get stuff like this

    06:34:11 [SEVERE] null
    java.sql.SQLException: database is locked
    at org.sqlite.DB.throwex(DB.java:370)
    at org.sqlite.DB.exec(DB.java:76)
    at org.sqlite.Conn.commit(Conn.java:343)
    at net.sacredlabyrinth.Phaed.PreciousStones.data.sqlDatabaseHandler.closeBatch(sqlDatabaseHandler.java:87)
    at net.sacredlabyrinth.Phaed.PreciousStones.data.sqlCore.closeBatch(sqlCore.java:60)
    at net.sacredlabyrinth.Phaed.PreciousStones.managers.StorageManager.processQueue(StorageManager.java:1001)
    at net.sacredlabyrinth.Phaed.PreciousStones.managers.StorageManager$1.run(StorageManager.java:950)
    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    at java.lang.Thread.run(Unknown Source)
  24. Offline


    I'm get this error

    2011-07-20 12:25:11 [INFO] [PreciousStones] version 5.3.3 loaded
    2011-07-20 12:25:11 [INFO] [PreciousStones] MySQL Connection successful
    2011-07-20 12:25:11 [SEVERE] Error occurred while enabling PreciousStones v5.3.3 (Is it up to date?): BLOCK_PISTON_EXTEND
    java.lang.NoSuchFieldError: BLOCK_PISTON_EXTEND
        at net.sacredlabyrinth.Phaed.PreciousStones.PreciousStones.registerEvents(PreciousStones.java:159)
        at net.sacredlabyrinth.Phaed.PreciousStones.PreciousStones.onEnable(PreciousStones.java:125)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:857)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:264)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:151)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:136)
        at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:358)
        at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleCommandMap.java:281)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:290)
        at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:480)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:465)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-07-20 12:25:11 [INFO] [PreciousStones] Payment method: iConomy v5
  25. Offline


    You need to be on CB# 1000 to use the latest PS.
  26. Offline


    Great Plugin! I used it in earlier CB Build.

    I just downloaded it and ran the server with a fresh jar without my old config files. I wanted to start fresh.

    Idk why but when I place a Forester block. It tells me I placed it.... but nothing happens

  27. Offline


    CB# 1000
    PS 5.3.3 / MySQL

    13:38:52 [SEVERE] null
    java.sql.BatchUpdateException: Duplicate entry '65-62-346-mobs' for key 'uq_pstone_unbreakables_1'
    at com.mysql.jdbc.StatementImpl.executeBatch(StatementImpl.java:1065)
    at net.sacredlabyrinth.Phaed.PreciousStones.data.mysqlDatabaseHandler.closeBatch(mysqlDatabaseHandler.java:111)
    at net.sacredlabyrinth.Phaed.PreciousStones.data.mysqlCore.closeBatch(mysqlCore.java:87)
    at net.sacredlabyrinth.Phaed.PreciousStones.managers.StorageManager.processQueue(StorageManager.java:1001)
    at net.sacredlabyrinth.Phaed.PreciousStones.managers.StorageManager$1.run(StorageManager.java:950)
    at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    at java.lang.Thread.run(Thread.java:679)
  28. Offline


    That's fine, that's only a duplicate entry being rejected. Probably broke a block using the superpickaxe and put another one in its place, or something similar.
  29. Offline

    GECLAN Erik

    Is there anyway to to restrict x number of each protection block or total number of protection blocks people can place?
  30. Offline


    forester dosent work anymore, and it tells me that my slq is locked and there arnt dupilicates, try to find a way to fix this
Thread Status:
Not open for further replies.

Share This Page