[SEC/FUN/INFO] Towny v0.68 Fuzze Edition [818]

Discussion in 'Inactive/Unsupported Plugins' started by FuzzeWuzze, Apr 10, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Version: v0.68

    Moderator Edit: Please direct your attention here for an updated version. This thread is now closed due to people spamming random things about how its not working.

    So this has been asked for many times so i decided to finally make this thread.
    This is related to Shade's brilliant Plugin Towny

    Since Shade has been MIA for a while now, and we dont know if hes coming back i've been trying to keep Towny afloat as best i can in hopes he does come back as i dont really have the RL schedule to much of anything other than maintain it to be usable.

    I hope in June once i have more free time if Shade still isnt back :'( to actually do a formal Github Fork and continue the project. So until then, dont bother asking for new features, as time allows the only thing i'll try to do is fix large glaring bugs that effect the mod. This is a very large plugin and Shade has spent a lot of time on it, so even when/if i do fork it will take some time to get fully up to speed on everything. For now i just have a basic understanding of how everything is interacting and enough debug skills to track down most bugs ;)

    How it works/Features
    -See Original Towny Page for Instructions on how to setup and Permissions.

    Read this page to learn what everything in the config does!

    When reporting bugs, please use /townyadmin set debugmode on. Then perform the action and post or send me the log from your server. This will assist me in being able to fix the issue 10 faster, just simply saying "People can do X in my town when they shouldnt be able too" doesnt really help me at all and is impossible to replicate.
    • Permission cache errors
      • You didnt install Permissions properly, it creates a RENAMEME.yml file or something of the like when first started. This must be renamed to match your world name(for most people world.yml). Also you CANNOT have spaces in your world name. Test World is not an acceptable folder name, TestWorld is. Both towny and permissions dont like the Permissions YML file to have spaces.
    • /town top money causes exception
      • Your iConomy database is likely setup to still use sqlite. Ensure that your iConomy config file is setup to use database Type: H2SQL. A lot of people had issues with the sqlite to H2 conversion, if you still experience this error with it set properly your db may be corrupt. Back up your iConomy db and configs, then delete them all and allow iConomy to recreate them and see if it still happens. If it doesnt, your going to have to manually regrant people cash somehow as your iConomy database was corrupt.
    • towny.admin: User is able to use /townyadmin, as well as the ability to build/destroy anywhere. User can also able to make towns or nations when set to admin only.
    • towny.town.new :User is able to create a town (only is use when TOWN_CREATION_ADMIN_ONLY is on)
    • towny.town.claim : User is able to expand his town with /town claim
    • towny.nation.new :User is able to create a nation (only is use when NATION_CREATION_ADMIN_ONLY is on)
    • towny.wild.*: User is able to build/destroy in wild regardless if the config says no.
    • towny.wild.build
    • towny.wild.destroy
    • towny.wild.switch
    • towny.wild.item_use
    • towny.wild.block.[block id] : User is able to edit [block id] in the wild.
    • towny.spawntp :Use /town spawn when allow_town_spawn=false
    • towny.publicspawntp : Use "/town spawn [town]" (teleport to other towns) when allow_town_spawn_travel=false.

    All versions .64 and after will require iConomy 5.0 and higher. When making this initial transition it is HEAVILY advised that you back up your h2 and MySQL database's. I tested as well as i could with various functionality within Towny and it seemed to be working as expected. Also note that a ton of plugins that use iConomy are still broken, so unless they ALL work i wouldnt suggest updating. You've been warned. Dont cry if something bad happens and you dont have a backup of your iConomy database ...
      • Essentials 2.2
      • Permissions 2.7.4(DO NOT USE 3.X!)
      • iConomy 5.01
    • (JAR ONLY) Latest Build(.68) HERE
    • V.61

    • Fix /towny top money from crashing towny
    • Investigate potential issues with build/destroy permissions.

    • /town spawn will not charge players
    • DO NOT GIVE PLAYERS TOWNY.WILD.* permissions. Give players permissions by editing your config file by editing these. If players have wild permissions they can do funny business to get permission to build in other peoples towns.
    • Some people are reporting a lot of [SEVERE] warnings related to Player_Item and Player_Move, i believe these are being triggered by other mods. If you are having this issue please list your other plugins.

    Version .68
    • Compiled for CB818 (Minecraft 1.6.6)
    • Disabled town renaming (finally)
    • Do not use Permissions 3.0.x with Towny yet, there are still some MAJOR issues with the rework they are doing and a ton of people are nerd raging on their thread. I couldnt even get it to create my config or default files they were always blank, and i guess a ton of other people are having the same issues. Still didnt work when following instructions on how to make the file yourself. Because 2.7.4 works perfectly fine with CB818 im not in a rush to upgrade until they figure out their issues. Sorry if this causes plugin conflicts if some require Permissions 3.x but i doubt it will as not many mods are moving to it in its badly broken state. Because Towny is so heavily dependent on a lot of Permissions nodes being read properly i decided to stick with 2.7.4 for now. Ill work on a 3.x permissions build as soon as i feel its functioning properly.
    Version .66
    • Compiled for CB766
    • Players no longer need to /town set spawn, when a player does /town spawn they automatically go back to their town. Need to figure out how to re-implement the essentials teleport timer cooldown they changed their API
    Version .64
    Version .63
    • Really fixed /town spawn!
    Version .62
    • First Official Release by Fuzze!
    • Fixed /town spawn INVESTIGATING
    • Fixed /towny map
    • Verified all permissions are working properly. I ran it on my test server and tested resident build/destroy/switch and outsider build/destroy/switch by using /town set perm and turning them on and off and trying them out. ALL the permissions acted as they should. This should put to rest a lot of bugs people are having with people building. This doesnt mean Towny is using the default_town_build=false config lines properly for new towns, thats next. It does mean if your mayor sets the options manually it works.
    Version .061R6
    • Disabled /towny top money for towns/nations until able to fix bug related to null iConomy accounts, I have a feeling its related to iConomy databases that were SQLite and transitioned to H2 like my own. It *should* work fine for Residents, so far i havent seen null resident returns.
    Version 0.61R5

    • Updated to work with CB670
  2. Offline


  3. Offline


    Great plugin !
    I'm requestion a addition tho, instead of making the town pay rent each day, I want to make a town pay rent per each plot each day !
    So say a town has 5 plots, I want to make it so you pay rent*5 PER DAY....

    Also, I want away to make a freebuild area because I set it for can't build in wild, but I want players just joining to have a freebuild area !
  4. Offline


    Cant you just setup your plot tax? So you ahve a resident and also a plot tax? I think thats what your looking for.
  5. Offline


  6. Offline


    Sounds about it....
    How do I do it ???????
  7. Offline


    yeah like cuboid izone/worldedit setups
  8. Offline


    Hmm.. what's this?
    2011-07-07 22:18:09 [SEVERE] Could not pass event PLAYER_COMMAND_PREPROCESS to Towny
    java.lang.NoSuchMethodError: com.earth2me.essentials.Essentials.getUser(Ljava/lang/Object;)Lcom/earth2me/essentials/User;
        at ca.xshade.bukkit.towny.Towny.checkEssentialsTeleport(Towny.java:447)
        at ca.xshade.bukkit.towny.event.TownyPlayerListener.parseTownCommand(TownyPlayerListener.java:952)
        at ca.xshade.bukkit.towny.event.TownyPlayerListener.onPlayerCommandPreprocess(TownyPlayerListener.java:411)
        at org.bukkit.plugin.java.JavaPluginLoader$5.execute(JavaPluginLoader.java:272)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:321)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:704)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:676)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:669)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:84)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  9. Offline


    Could you share your bukkit build and towny versions please?
  10. Offline


    Hello, I have installed towny on my server and am a Admin in permissions. I CAN use the /towny command but cannot use any other commands associated. When I try to use /t, that is the command to send a message to another player. Any ideas?
  11. Offline


    Use /town instead, you probably have a chat plugin that uses /t (for /tell)
  12. Offline


    Of course. CB = 961
    Towny version = last_run_version=0.68
  13. Offline


    This is the new thread with a build for 954/955. We're releasing a new version tomorrow which has almost all the bugs in Towny fixed. (The current build (0.71) isn't being supported.)
  14. Offline


    I tried /town as well but it also does not work. Neither does /resident or /nation. Really weird..
  15. Offline


    Wait until tomorrow when a new build is out. Also read the post above yours.
  16. Offline


    I got this weird bug when I do /t claim rect 1. It makes a weird place called Null, and it's annoying.
  17. Offline


    This command was fixed in Towny .72 and had the 'rect' part removed. You would type /t claim 1 which actually doesnt do anything, but claim the block you are in. Better to use /t claim 2 or 3 or /t claim auto
  18. Offline


    When I want to join a town I need to type "/accept" but when I type "/accept" nothing happens.Whats the problem? Everyone on the server gets the same problem.
  19. Offline


    I have an issue.
    A member type /t unclaim all
    This unclaimed all the land in the city. Now when we type /t set homeblock we get 'Not registered'. And if we type /t claim it says it needs to connect to claimed area

    Any fix for this without making a new town?
  20. Offline


    This is what you should have started with.

    Bukkit Build:
    Towny Build:
    Questioner Build:
    Pastebin link to your config.yml:

    (Also wrong thread!)
    That's nasty, I'm sure that can get fixed! Until then use a /town delete and start a new town, sorry!

    (Also wrong thread!)
  21. Offline


    I saw you added suport for questioner but it's not really working? Because I invite people to the town, they get an invite but they can't accept. Could you please fix that?
  22. Offline


    You're in the wrong thread, so you're probably using an old version of towny.
  23. Offline


    No the old one don't work anymore? There is a node in settings if you're using questioner.
  24. Offline


    Thanks for the work on this plugin, however we have some big problems with it.

    Whenever we do a server reboot, usually we lose one towns data, have to delete and rebuild it.

    Just now we had people leave Town A to make a new town, say Town B.

    Once they created the town, had members, homeblock, spawn, claimed land.... we rebooted 5 mins after and did /town list.

    It showed their town had 0 members, and had 0/0 blocks. The residents were back as residents in Town A again too.

    Very strange. We host on multiplay and run lwc, essentials, and a couple of others. We have even disabled other addons and just tried with towny, but the problem is still there.

    We tested creating the new town and doing reboots 5 times now, each time the town loses its data.

    Can you help please?
  25. Offline



    This is the wrong thread, it is no longer being maintained. Use the link below!!
    New towny thread
  26. Offline


Thread Status:
Not open for further replies.

Share This Page