[SEC/FUN/INFO] Towny v0.68 Fuzze Edition [818]

Discussion in 'Inactive/Unsupported Plugins' started by FuzzeWuzze, Apr 10, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Version: v0.68

    Moderator Edit: Please direct your attention here for an updated version. This thread is now closed due to people spamming random things about how its not working.

    So this has been asked for many times so i decided to finally make this thread.
    This is related to Shade's brilliant Plugin Towny

    Since Shade has been MIA for a while now, and we dont know if hes coming back i've been trying to keep Towny afloat as best i can in hopes he does come back as i dont really have the RL schedule to much of anything other than maintain it to be usable.

    I hope in June once i have more free time if Shade still isnt back :'( to actually do a formal Github Fork and continue the project. So until then, dont bother asking for new features, as time allows the only thing i'll try to do is fix large glaring bugs that effect the mod. This is a very large plugin and Shade has spent a lot of time on it, so even when/if i do fork it will take some time to get fully up to speed on everything. For now i just have a basic understanding of how everything is interacting and enough debug skills to track down most bugs ;)

    How it works/Features
    -See Original Towny Page for Instructions on how to setup and Permissions.

    Read this page to learn what everything in the config does!

    When reporting bugs, please use /townyadmin set debugmode on. Then perform the action and post or send me the log from your server. This will assist me in being able to fix the issue 10 faster, just simply saying "People can do X in my town when they shouldnt be able too" doesnt really help me at all and is impossible to replicate.
    • Permission cache errors
      • You didnt install Permissions properly, it creates a RENAMEME.yml file or something of the like when first started. This must be renamed to match your world name(for most people world.yml). Also you CANNOT have spaces in your world name. Test World is not an acceptable folder name, TestWorld is. Both towny and permissions dont like the Permissions YML file to have spaces.
    • /town top money causes exception
      • Your iConomy database is likely setup to still use sqlite. Ensure that your iConomy config file is setup to use database Type: H2SQL. A lot of people had issues with the sqlite to H2 conversion, if you still experience this error with it set properly your db may be corrupt. Back up your iConomy db and configs, then delete them all and allow iConomy to recreate them and see if it still happens. If it doesnt, your going to have to manually regrant people cash somehow as your iConomy database was corrupt.
    • towny.admin: User is able to use /townyadmin, as well as the ability to build/destroy anywhere. User can also able to make towns or nations when set to admin only.
    • towny.town.new :User is able to create a town (only is use when TOWN_CREATION_ADMIN_ONLY is on)
    • towny.town.claim : User is able to expand his town with /town claim
    • towny.nation.new :User is able to create a nation (only is use when NATION_CREATION_ADMIN_ONLY is on)
    • towny.wild.*: User is able to build/destroy in wild regardless if the config says no.
    • towny.wild.build
    • towny.wild.destroy
    • towny.wild.switch
    • towny.wild.item_use
    • towny.wild.block.[block id] : User is able to edit [block id] in the wild.
    • towny.spawntp :Use /town spawn when allow_town_spawn=false
    • towny.publicspawntp : Use "/town spawn [town]" (teleport to other towns) when allow_town_spawn_travel=false.

    All versions .64 and after will require iConomy 5.0 and higher. When making this initial transition it is HEAVILY advised that you back up your h2 and MySQL database's. I tested as well as i could with various functionality within Towny and it seemed to be working as expected. Also note that a ton of plugins that use iConomy are still broken, so unless they ALL work i wouldnt suggest updating. You've been warned. Dont cry if something bad happens and you dont have a backup of your iConomy database ...
      • Essentials 2.2
      • Permissions 2.7.4(DO NOT USE 3.X!)
      • iConomy 5.01
    • (JAR ONLY) Latest Build(.68) HERE
    • V.61

    • Fix /towny top money from crashing towny
    • Investigate potential issues with build/destroy permissions.

    • /town spawn will not charge players
    • DO NOT GIVE PLAYERS TOWNY.WILD.* permissions. Give players permissions by editing your config file by editing these. If players have wild permissions they can do funny business to get permission to build in other peoples towns.
    • Some people are reporting a lot of [SEVERE] warnings related to Player_Item and Player_Move, i believe these are being triggered by other mods. If you are having this issue please list your other plugins.

    Version .68
    • Compiled for CB818 (Minecraft 1.6.6)
    • Disabled town renaming (finally)
    • Do not use Permissions 3.0.x with Towny yet, there are still some MAJOR issues with the rework they are doing and a ton of people are nerd raging on their thread. I couldnt even get it to create my config or default files they were always blank, and i guess a ton of other people are having the same issues. Still didnt work when following instructions on how to make the file yourself. Because 2.7.4 works perfectly fine with CB818 im not in a rush to upgrade until they figure out their issues. Sorry if this causes plugin conflicts if some require Permissions 3.x but i doubt it will as not many mods are moving to it in its badly broken state. Because Towny is so heavily dependent on a lot of Permissions nodes being read properly i decided to stick with 2.7.4 for now. Ill work on a 3.x permissions build as soon as i feel its functioning properly.
    Version .66
    • Compiled for CB766
    • Players no longer need to /town set spawn, when a player does /town spawn they automatically go back to their town. Need to figure out how to re-implement the essentials teleport timer cooldown they changed their API
    Version .64
    Version .63
    • Really fixed /town spawn!
    Version .62
    • First Official Release by Fuzze!
    • Fixed /town spawn INVESTIGATING
    • Fixed /towny map
    • Verified all permissions are working properly. I ran it on my test server and tested resident build/destroy/switch and outsider build/destroy/switch by using /town set perm and turning them on and off and trying them out. ALL the permissions acted as they should. This should put to rest a lot of bugs people are having with people building. This doesnt mean Towny is using the default_town_build=false config lines properly for new towns, thats next. It does mean if your mayor sets the options manually it works.
    Version .061R6
    • Disabled /towny top money for towns/nations until able to fix bug related to null iConomy accounts, I have a feeling its related to iConomy databases that were SQLite and transitioned to H2 like my own. It *should* work fine for Residents, so far i havent seen null resident returns.
    Version 0.61R5

    • Updated to work with CB670
  2. Offline


    Oh I know the chunks, but it's not allowing the user to build in the entire 16x16 plot.
    E.g. I'm mayor, only I can build in my plot.
    Another user can purchase a plot, but anything they do in it is blocked, apart from two rows of 16 blocks.

    ----------++ They can only build in the + not the rest of the plot?
  3. Offline


    its exactly 16x16. the + is just a map of what plots are. and are they a resident?
  4. Offline


    that was just an example, and yes, their just a resident.
  5. Offline


    have you tried permissions? and are you running essentials?
  6. Offline


    I'm running permissions 3.1.4 as other permission's simply wont work.
  7. Offline


    hmm pastebin the config file for towny and are your residents in the permissions users.yml file?
  8. Offline


  9. Offline


    i see your problem already. you have to convert the user.yml fil to ver 3 specifications. There's a difference between v2.x and v3.x

    http://pastebin.com/ExTm5Fvm <--- That's how its supposed to look like.

    May I see the groups.yml file please?
  10. Offline



    Ah, thanks. I was using the mcmyadmin built in permissions editing I thought 3.x used the 2.x permissions just converted them.
  11. Offline


    i saw t
    the new permissions did, but it didnt delete the old stuff. on if you ever want to add comments to a yml file, use the # for each line so the program wont read it.

    I see in your permissions for each group the nodes are missing some important stuff. which plugins do they go to? is it essentials?
  12. Offline


    Nope this is a completely fresh install of the server, just Towny, Iconomy, MobBounty 4.04, and permissions.
  13. Offline


    are you planning on using essentials? because those nodes look like essentials nodes.

    and if your going to use mob bounty you need these

    - 'mobbounty.collect'
    - 'mobbounty.commands.mb'
    - 'mobbounty.multipliers.environment'
    - 'mobbounty.multipliers.group'
    - 'mobbounty.multipliers.time'
    - 'mobbounty.multipliers.world'
  14. Offline


    Nopes, I think some of the nodes already in there are some extra features which mcmyadmin provide like server time etc...
    Edit: oh yeah I was concerntrating on getting this working first lol
  15. Offline


    huh, weird. it should put something like mcmyadmin.ping etc.

    and you need this for mob bounty
    - 'mobbounty.collect'
    - 'mobbounty.commands.mb'
    - 'mobbounty.multipliers.environment'
    - 'mobbounty.multipliers.group'
    - 'mobbounty.multipliers.time'
    - 'mobbounty.multipliers.world'

    here's the groups pastebin http://pastebin.com/LtHx9VNH

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  16. Offline


    Yeah, i'm going to try another fresh server, see if I can get it to work on that, hopefully. No one's been on this map yet so saves me some hastle.

    I'll report back if it works or if i'm still a retard :D
    thanks for the help though :)
  17. Offline


    yeah, i've never seen a plugin that puts interact: false/true in the permissions. in fact i dont think that even works. it has to go in the nodes for something like that to work. i think..
  18. Offline


    you should start a new thread for your fork ! thanks for fixing up the plugin :)
  19. Offline


    on my server, I can use all commands, but when i try to, build it says something like: "You aren't allowed to build in the Wild" it says so for everybody, What am i doing wrong? :eek:
  20. Offline


    Could you please make it use MySQL?
  21. Offline


    he has said it is planned for it to be changed over to SQL/SQlite. This should fix most of the nulling dataloss problems i hope.
  22. Offline


    just curious but

    is there any other similiar plugin like towny which can convert towny data to use its own ?
  23. Offline


    Whenever I reboot my server the towns all disappear. I have made sure that saving is enabled, and if I run /ta reload everything runs fine. Any suggestions?
  24. Offline


    when you hit /ta reload it reloads all default settings XD

    I think.. >v>;
  25. Offline


    If I /reload or /ta reload the towns stay. It seems the towns disappear all on their own. I had the town about 2 hours ago...left the house and came back and it's gone. :-\
  26. Offline


    Did you deposit money in the town bank? towns have to pay maintenance taxes, you know...
  27. Offline


    its usually off by default i think
  28. Offline


    I know it didn't used to be. It's like 25 (iconomy money) per real-world day by default. it's probly off if you don't have iconomy.
  29. Offline


    ah, nvm
  30. Offline


    i love you
    i love you too
  31. Offline


    I've built a few unreleased plugins for my server that hooked into Towny so I know the source inside and out. Let me know what's on your todo list and I'll help.

    I've never had a single problem with Towny so I don't know what to fix.
Thread Status:
Not open for further replies.

Share This Page