[SEC/FUN/INFO] Towny v0.68 Fuzze Edition [818]

Discussion in 'Inactive/Unsupported Plugins' started by FuzzeWuzze, Apr 10, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Version: v0.68

    Moderator Edit: Please direct your attention here for an updated version. This thread is now closed due to people spamming random things about how its not working.

    So this has been asked for many times so i decided to finally make this thread.
    This is related to Shade's brilliant Plugin Towny

    Since Shade has been MIA for a while now, and we dont know if hes coming back i've been trying to keep Towny afloat as best i can in hopes he does come back as i dont really have the RL schedule to much of anything other than maintain it to be usable.

    I hope in June once i have more free time if Shade still isnt back :'( to actually do a formal Github Fork and continue the project. So until then, dont bother asking for new features, as time allows the only thing i'll try to do is fix large glaring bugs that effect the mod. This is a very large plugin and Shade has spent a lot of time on it, so even when/if i do fork it will take some time to get fully up to speed on everything. For now i just have a basic understanding of how everything is interacting and enough debug skills to track down most bugs ;)

    How it works/Features
    -See Original Towny Page for Instructions on how to setup and Permissions.

    Read this page to learn what everything in the config does!

    When reporting bugs, please use /townyadmin set debugmode on. Then perform the action and post or send me the log from your server. This will assist me in being able to fix the issue 10 faster, just simply saying "People can do X in my town when they shouldnt be able too" doesnt really help me at all and is impossible to replicate.
    • Permission cache errors
      • You didnt install Permissions properly, it creates a RENAMEME.yml file or something of the like when first started. This must be renamed to match your world name(for most people world.yml). Also you CANNOT have spaces in your world name. Test World is not an acceptable folder name, TestWorld is. Both towny and permissions dont like the Permissions YML file to have spaces.
    • /town top money causes exception
      • Your iConomy database is likely setup to still use sqlite. Ensure that your iConomy config file is setup to use database Type: H2SQL. A lot of people had issues with the sqlite to H2 conversion, if you still experience this error with it set properly your db may be corrupt. Back up your iConomy db and configs, then delete them all and allow iConomy to recreate them and see if it still happens. If it doesnt, your going to have to manually regrant people cash somehow as your iConomy database was corrupt.
    • towny.admin: User is able to use /townyadmin, as well as the ability to build/destroy anywhere. User can also able to make towns or nations when set to admin only.
    • towny.town.new :User is able to create a town (only is use when TOWN_CREATION_ADMIN_ONLY is on)
    • towny.town.claim : User is able to expand his town with /town claim
    • towny.nation.new :User is able to create a nation (only is use when NATION_CREATION_ADMIN_ONLY is on)
    • towny.wild.*: User is able to build/destroy in wild regardless if the config says no.
    • towny.wild.build
    • towny.wild.destroy
    • towny.wild.switch
    • towny.wild.item_use
    • towny.wild.block.[block id] : User is able to edit [block id] in the wild.
    • towny.spawntp :Use /town spawn when allow_town_spawn=false
    • towny.publicspawntp : Use "/town spawn [town]" (teleport to other towns) when allow_town_spawn_travel=false.

    All versions .64 and after will require iConomy 5.0 and higher. When making this initial transition it is HEAVILY advised that you back up your h2 and MySQL database's. I tested as well as i could with various functionality within Towny and it seemed to be working as expected. Also note that a ton of plugins that use iConomy are still broken, so unless they ALL work i wouldnt suggest updating. You've been warned. Dont cry if something bad happens and you dont have a backup of your iConomy database ...
      • Essentials 2.2
      • Permissions 2.7.4(DO NOT USE 3.X!)
      • iConomy 5.01
    • (JAR ONLY) Latest Build(.68) HERE
    • V.61

    • Fix /towny top money from crashing towny
    • Investigate potential issues with build/destroy permissions.

    • /town spawn will not charge players
    • DO NOT GIVE PLAYERS TOWNY.WILD.* permissions. Give players permissions by editing your config file by editing these. If players have wild permissions they can do funny business to get permission to build in other peoples towns.
    • Some people are reporting a lot of [SEVERE] warnings related to Player_Item and Player_Move, i believe these are being triggered by other mods. If you are having this issue please list your other plugins.

    Version .68
    • Compiled for CB818 (Minecraft 1.6.6)
    • Disabled town renaming (finally)
    • Do not use Permissions 3.0.x with Towny yet, there are still some MAJOR issues with the rework they are doing and a ton of people are nerd raging on their thread. I couldnt even get it to create my config or default files they were always blank, and i guess a ton of other people are having the same issues. Still didnt work when following instructions on how to make the file yourself. Because 2.7.4 works perfectly fine with CB818 im not in a rush to upgrade until they figure out their issues. Sorry if this causes plugin conflicts if some require Permissions 3.x but i doubt it will as not many mods are moving to it in its badly broken state. Because Towny is so heavily dependent on a lot of Permissions nodes being read properly i decided to stick with 2.7.4 for now. Ill work on a 3.x permissions build as soon as i feel its functioning properly.
    Version .66
    • Compiled for CB766
    • Players no longer need to /town set spawn, when a player does /town spawn they automatically go back to their town. Need to figure out how to re-implement the essentials teleport timer cooldown they changed their API
    Version .64
    Version .63
    • Really fixed /town spawn!
    Version .62
    • First Official Release by Fuzze!
    • Fixed /town spawn INVESTIGATING
    • Fixed /towny map
    • Verified all permissions are working properly. I ran it on my test server and tested resident build/destroy/switch and outsider build/destroy/switch by using /town set perm and turning them on and off and trying them out. ALL the permissions acted as they should. This should put to rest a lot of bugs people are having with people building. This doesnt mean Towny is using the default_town_build=false config lines properly for new towns, thats next. It does mean if your mayor sets the options manually it works.
    Version .061R6
    • Disabled /towny top money for towns/nations until able to fix bug related to null iConomy accounts, I have a feeling its related to iConomy databases that were SQLite and transitioned to H2 like my own. It *should* work fine for Residents, so far i havent seen null resident returns.
    Version 0.61R5

    • Updated to work with CB670
  2. Offline


    I would try altering it through the config yes, or rolling back to a backup of your config when it was good.
    If you could do the same as above and set it in debug mode when your trying to run these commands that arent doing anything i maybe able to fix it.
  3. Offline


    Ok I will try and alter the config thanks for the help.
  4. Offline


    is there an option to add every player in the server to a city ?
  5. Offline

    Damian Mason

    Are taxes not working for anyone?
  6. Offline


    tonwy protect bug

  7. Offline


    are towny nations bugged?

    and if so, what bugs occur? in a server i play on the owner is wary to make nations because on some forums they state the nations are extremely bugged.
  8. Offline


    taxes not working for me with .67
  9. Offline


    Is it possible to get towns name like prefix? well, my ingame nick is Racha, and if i am in town bukkit I want to it show something like this -Bukkit- Racha, and where can i change that Mayors color? i dont want to it be blue :)

  10. Offline


    Fuzze it is a realy annoying bug on my server! every time some one place a block a message pops up You dont have the permissions to use this! WTF please help me [creeper]
  11. Offline


    @Fuzze, can u add a "/town top deposit" command, which shows a top list of people who have deposited money in the town bank account?
  12. Offline


    Cheers, that fixed it.
  13. Offline


    Im still waiting for a debug log on someone who is experiencing this issue, i cant replicate it on my server or my empty test server i use for testing on my PC.
  14. Offline


    looking forward to the day when Fuzze has the time to actually not to just fix the abandoned project, but branch it and improve it. :)
  15. Offline


    I can see your stress :]

    May I ask how resource dependent is Towny? I'm trying to find a substitute for World Guard, Thanks.
  16. Offline


    My players can destroy glowstone in towns, is it bug?
    Also it would be nice to make special permission groups for citizens/mayors
    Or is there a way to add some additional permissions only for citizens/mayors?
  17. Offline


    To be honest, this sounds like an issue with Permissions. If the group that the players are in has the setting Build: False, they can not build. Set it to true, reload, and should work.
  18. Offline


    Hi I need help it still says the permisson error when i rename the ylm file to my world (New World-) do you know how to fix it?
  19. Offline


    Don't use spaces in world names, not good form. Your original post sounded more like the error you get using Craftbook when you don't grant the cauldron perm to everyone. Did you add craftbook recently?
  20. Offline


    Does any one now how to fix when some one leaves a town to join a new one. they stay in both towns
  21. Offline


    Your world name cant have spaces.
  22. Offline


    Can somone show me an example on how to get this to load and save with MySQL " NOT how to setup Mysql I have this done already"

    I see a couple points on interest in the config to do with loading and saving it points to flatfile I dont want a flat file as it will totaly rape HDD usage I would suspect, I already have MySQL might as well use it for this as well so what settings do I need to change in this to make it use MySQL.

    There is no documention on setting this up for SQL databases that I can find by reading Shades "somewhat outdated" site or here.

    I don't even see any settings in the config that relate to how to change it to use Mysql Sure I could just replace flatfile with Mysql but I want to be sure I am using the correct Spelling before doing that I would also like some basic info about what happens when I do it. Such as if it will add SQL server settings to the config for me setup.

    I also dont see in the config any place to enter the SQL server details currently... Whats with that ?

    I am renevating the server so to speak new map the works and this time around I wanted to make my server more of a community thing with an actual point to building. Saying this the server and towny is FRESH no exsiting TOWNY data is yet created other then the config.
  23. Offline


    I'm having some weird issues on my server, I swear some of my plugins decided to go rouge. So far Towny, BigBrother, and MineCartMania I have been able to filter out by looking through the very large server log I now have.

    Towny .67
    iConomy 5.01
    Show Spoiler

    2011-05-19 14:38:10 [SEVERE] com.iConomy.iConomy cannot be cast to com.iConomy.iConomy loading Towny v0.67 (Is it up to date?)
    java.lang.ClassCastException: com.iConomy.iConomy cannot be cast to com.iConomy.iConomy
    at ca.xshade.bukkit.towny.Towny.checkPlugins(Towny.java:157)
    at ca.xshade.bukkit.towny.Towny.onEnable(Towny.java:116)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:676)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:249)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:131)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:109)
    at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:336)
    at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleCommandMap.java:201)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:278)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:682)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:645)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:639)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  24. Offline


    Hi Fuzze! I Really need help with my Towny. Every time I log on to my server this constantly pops up "could not create permissions cache for (FH Public" and right under that it says "not registered, but already registered when trying to register". I also get the latter messege every time I try to build a town. I've seen you reply to this problem before saying that "The permissions file must not have been setup correctly use the RENAME.yml to fix" but I know this is definetly not the case for my server as I also run Multiverse,Essentials,McMMO,iConomy,and other permission based plugins which all function perfectly. This error is preventing me from making towns and nations.
    Please Reply

    Oh and I'm set up as admin in permissions so nodes shouldn't be the problem

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  25. Offline

    Damian Mason

    What does setting a town public or private do?
  26. Offline


    My players cant build in there own town when they are mayors of it ? Did I miss something. They created a new town out side a nation with /town new [name], they have full mayor permissions commands.

    Yet they cant build or destroy in there own land?

    CB 766

    PluginsAppleTreeBorderGuardChairCraftEssentialsEssentialsGeoIPGroupManagerEssentialsProtectEssentialsSpawnFalseBookBlockFalseBookCoreFalseBookICiChatiConomyLogBlockmcbansMinecartManiaCoreMinecartManiaSignCommandsMinecartManiaStationMobRiderMonsterTamerMy BoatNextStationNoCheatPerformanceTweaksRulesShowcaseSignColoursTownyWarWorldEditPermissionsMinecartManiaAdminControlsMinecartManiaAutomationsMinecartManiaChestControl
    No Server errors or warnings in console.


    Just added a residant and FULL perm on and he cant use doors or build or do anything.
  27. Offline


    As ive said before, your server world cant contain a space, or else it cant find the permissions file. It sounds like your world name is FH Public, so you renamed your Permissions file FH Public.yml right?

    That has to be a single word...

    Towny does not use MySQL or any databases, the flat files it creates are minimal. That said i do have plans to move to H2 databases like iConomy and many other plugins(probably not MySQL because its user base is limited) here in the future...

    I added to the main post

    If you have an issue, especially related to in game permissions of people building/destroying when they shouldnt be able too please submit your debugmode log. Without it there's little chance i can assist because there are too many variables such as other mods that could be causing issues.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  28. Offline


    So you want me to start the plugin on its own and in debug mode ? with just essentials permissions running and send u logs it makes.

    BTW this is fresh map first test of towny. Also When I did /plot forsale it set price to 0 how to Set price for plots that are being sold ?.

    And by SQL userbase u mean not many can get SQL to work, I have Iconomy running with MySQL.

    I'm new to towny so seeing ur online I'm 100% to run some testing for u its just me and whitelisted staff online re building the server testing plugins in a test map.

    Appears to work fine with just Essentials,EssentialsGM,Iconomy,Towny,Ichat

    Now testing agian with plugins with debug mode on.

    FIXED!! Conflict Detected!

    Right so it seems it does not play nice with EssentialsProtect there is you conflict that is probably cuasing all of the BUILD issue reports.

    Sorry I did not get any logs from it but all users confirm it now works with out that one plugin.

    You should be able to detect the issues solo now you know what plugin was the issue to start with :D.

    I'm going to now test towny with the essentials options off in config see if it still plays up.

  29. Offline


    I have 4 towns on my server, but almost every day one of them gets deleted from the map, i then have to stop the server, use the backup to get the townblocks and put them manually in the town file. Here is a list of my plugins but i don't know if any of them could stop towny from working well:
    I don't get errors or anything like that. Did this ever happen to anyone before? Is there a solution?
  30. Offline


    I am having this same problem day in day out.
  31. Offline


    Was .67 just a bug fix? looking at change log and dont see what was changed :3

    EDIT: I am also having a case of homes being removed, I am still on .65 though, when I updated to .66 alot of things broke such as /town spawn
Thread Status:
Not open for further replies.

Share This Page