[SEC/FUN/INFO/CHAT/TP] Towny Advanced v0.88.0.0 - Land and town management [3020+ 1.7.2-R0.3]

Discussion in 'Archived: Plugin Releases' started by ElgarL, Jul 7, 2011.

  1. Plugin: Towny

    New Towny Website!

    Taking Shades' Towny a step farther.

    A versatile, player-controlled land management plugin for use with Bukkit/Tekkit/Spigot/Libigot, offering solutions for pvp, griefing, chat, inflated economies and monsters.

    Features (open)

    Towny includes a wide variety of features to offer instant enhancements to your traditional Minecraft server.
    • Allows players to own and manage land based on a pre-set grid layout.
      • Players join towns and purchase plots of land.
      • Players decide who can build, destroy, use "switchs" and use items on every plot they control.
      • Towns can join together into nations, further structuring a server into teams.
      • Towns grant protection from monsters, pvp, fire, explosions and greifing.
    • Wilderness Rules (Optional)
      • Area between towns is wilderness, with its own build permissions.
      • Limit players' interaction with the wild to just harvest-able blocks, keeping the wild pristine.
      • Roll-back tnt, creeper, wither explosions, dragon damage and endermen block-moving.
      • Block explosions and fire.
    • PVP Enhancements
      • Server with a strong PVP aspect will find Towny's grouping of players to be invaluable.
      • Prevent friendly-fire. (Optional)
      • Nations split players into larger teams.
      • Nations can declare other nations to be allies or enemies, further splitting players into even larger teams.
      • PVP can be turned on/off in wilderness, towns and worlds. (Optional)
    • Teleporting/Warping and Spawning (Optional)
      • Players can spawn to their town upon death.
      • Players can spawn to their town or a town that is within their nation/allied with their nation.
    • Customized modified chat. (Optional)
      • Colours, group prefixes and suffixes, nation, town, towny titles.
      • Channels for general, local, town, nation, moderator, admin and custom channels.
      • Anti-spam feature.
    • Shop plugin support. (Optional)
      • Limit shops to special Shop Plots, enhancing realism.
    • Economy plugin interaction. (Optional)
      • Supports all economy plugins.
      • Charge money for plots, towns, nations.
      • Flexible tax system.
      • Upkeep to remove money from the economy, stopping rampant inflation.
    • All Permissions Plugins supported. (Optional)
      • Perms 2/3, GroupManager, BukkitPermissions, bPermissions, PermissionsEx, etc.
    • Multiworld Support
      • Flexible settings for every world.
      • Enable/disable Towny in as many worlds as you like.

    • No other plugins, but is best with Questioner, so that invitations are given by Towns and Nations to residents and towns.
    • Questioner 0.6
    • Essentials 2.5+ - (Towny /town spawn's obey Essentials teleport cooldown)
    • All permissions plugins are supported and provide greater customization (recomend GroupManager).
    • Economy plugin of your choice.
    (We no longer recommend using PEX at all. It breaks TownyPerms due to the reflection PEX performs.)
    Supported Economy Plugins
    • iConomy 5.01
    • iConomy 4/5 *
    • iConomy 6 *
    • EssentialsEco *
    • BOSEconomy *
    • Craftconomy *
    • * Requires Register.jar 1.8+ (or Vault) in your plugins folder.
    • Any Vault-capable economy plugin that supports false-player accounts. (Do not use register if your economy plugin is supported by vault.)
    Plugins That Support Towny
    Download Towny
    • Release Version: Link
    • Dev Versions/Jenkins: Link (Majorly Different - Visit IRC channel before using.)
    • Install Guide
    Towny Wiki Site

    Suggestions and Issues
    Make a suggestion - Link
    Report an issue - Link
    • Credits: Many thanks to all contributers including, but not limited to: Fuzziewuzzie, Shadeness, LlmDl, SwearWord and dumptruckman.
  2. Offline


    Town add seems to be broken on the last dev version: The mayor gets [Towny] None of those names are valid.
    And console says 14:29:27 [INFO] [Towny] Error could not read msg_not_allowed_join from english.y

    It seems to work using townyadmin... on CB1000
  3. Offline


    I am using Permissions 2.7 + PermissionsPlus.
  4. Ops can goto spawn as they use the bukkit player.teleport. Other players are failing as there was a change in Essentials on how it handled teleports.
    If you are not using essentials be sure to set it to false in the Towny config.
    Also only the Dev version works with the latest Essentials.

    You are not using the correct english.yml

    Um, seems thats a new interface in permissions 3.x that perms 2.x doesn't have.
    I'm actually reluctant to support perms 3 and I'm considering dropping it as a listed/tested plugin.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  5. Offline


    Thanks we're not using Essentials

    I just tried setting below + a restart:
    description: User can use /town spawn when on in config.
    default: false
    description: User can use /town spawn <town> when on in config.
    default: false

    Still no joy.
  6. I'm dropping Towny back to permissions 2.7, GroupManager and Bukkit Superperms support. If it works with permissions 3.x then good for you, but if it breaks, too bad. I'm not supporting permissions 3.x.

    Grab the Dev version and try that. Requires a delete of config and english so it can create new ones.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  7. Offline


    Can work with BOSEconomy ?
  8. Offline


    Ok I deleted the english.yml and let it recreate. Now the error regarding the file is gone, however whoever uses town add gets the "names are not valid" error.
  9. Offline


    Instructions for using the Dev build on the wiki state you need the towny.town.resident perm node to become a resident.
  10. Offline


    Ack. Yeah that was it. Much appreciated.
  11. Offline


    Is there a way to modify how you can claim town plots?

    Originally, I believe you can claim a plot for 25$, up to 16x the number of residence. Now, if I play on a server that only has a few, or even just me, that means I won't be able to make something really big.

    I was want to try and make it so that a plot of land costs 25$ * the number of plots you own; the more you own, the more pricey it gets. You can then get as many plots as you want, independent of how many residences there are.
  12. Offline


    You can do what you want. First you need to set the town_block_ratio to zero in the config. This allows you to use the townBlockLimit part of the townLevel lines. Just set up each townLevel line with a very high townBlockLimit number like 300. A one-man town will then have 300 townblocks available at his disposal.
  13. Offline


    It will still have a set price of how much it is for (such as each block is worth 500$) I did set that up, but it still will cost 500 each, instead of, the first one being 500, the next is 1000, then 1500, etc.

    I tried
    price_claim_townblock: townblocks * 500.0

    I am not sure if that will work

    Later on, if residence do come in, I may reduce the price, such as
    price_claim_townblock: townblocks * 500.0 / numResidence
  14. Offline


    Sorry, there is no way to charge more for each plot that a mayor claims. In the meantime you could make it expensive to run a town by charging a higher upkeep.
  15. Offline


    ah, i guess so. Is there a way to make it so that instead of you upgrading from hamlet to town by the number of residences to the number of plots you own?
    Thanks :)
  16. Offline


    From your changelog, the line:
    - Fixed more typo's (a never ending job).
    Should read "typos."
    (No it doesn't matter, I just found mistyping "typos" superbly ironic. :p)
  17. :D
  18. Offline


    Using 0.73.1 and residents and also people who doesn't have towny.admin permission cant use /town spawn it says that they pay o dollars but they are not teleported. Also at some times i cant seem to add people i type smth like this /town add Lolz and they type /accept but nothing happens. Why is that?
  19. Not enough version details so stabbing in the dark here.
    Your questioner is out of date. Needs version 0.4
    Teleports you need latest Essentials (if using) and Dev version of Towny.
  20. Offline


    Using questioner v0.4 and i don't use essentials at all.
    Can u post a link to the newest dev build?
  21. Offline


    You know what else would make it awesome? A second download with BukkitContrib support, which will display in the top-left corner [where achievements go] what town you're in/not in, Pokémon style. Perhaps music could be played in those areas too!

    Enter town area, town music plays. Exit, wilderness music plays. Enter specific plot, shop music plays, etc.
  22. Offline


    I've upgraded to the latest version of towny but everytime I start the server up it throws this error:

    14:08:28 [SEVERE] Error occurred while enabling Towny v0.73.1 (Is it up to date?
    ): null
    at ca.xshade.bukkit.towny.Towny.SetWorldFlags(Towny.java:159)
    at ca.xshade.bukkit.towny.Towny.load(Towny.java:271)
    at ca.xshade.bukkit.towny.Towny.onEnable(Towny.java:101)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    I've deleted the old properties file, what am I missing?

    Thanks in advance
  23. Offline


    Which version did you upgrade from? You may not have deleted config.yml and english.yml when you upgraded, or if you've upgraded from pre-0.73 you might just have some old corrupted data files.

    Join the IRC if you'd like help fixing your data folder.
  24. Offline


    Sorry this is a stupid question but is there no way one can be a member and participate in several towns?
  25. Offline


    No, but based on who considers your town/nation an ally, you can build in other towns. You can also claim outposts within towns.
    maetthew likes this.
  26. Offline


    I've got a bug.

    In my server, everyone can destroy everywhere, even at other's towns, despite my efforts on preventing this. All other functions of this kind work just well (outsiders cannot build, switch or use), so I don't know what's wrong.
    I'm running craftbukkit build 1000 and recently updated Towny trying to get rid of this.

    I've got about ten other plugins running, but none of them have anything to do with building or destroying.

    A couple of days ago I was running a 1.3 dev build of bukkit and Shade's Towny, and this didn't happen until I upgraded to the latest, any idea?
  27. Offline


    Towny version #:
    Link to pastebin.com'd towny config.yml:
    Link to server startup:
    Link to permissions file:
  28. Offline


  29. Offline


    You should consider updating perms to 2.7.4. Also I don't think the node you gave the guests is needed and might be formatted wrong, replace - ' -*' with - 'foo.bar'. You've also got some funny indentation in your players group, make sure everything is indented the right number of spaces. What you described sounded like everyone had towny.admin in their permissions.
  30. Offline


    Thank you for that information!
  31. Offline


    I didn't notice I had left Permissions outdated... Thanks.
    I don't know what does the foo.bar node stand for, but I did that anyway. Thanks again.
    The number of spaces in my permissions file seemed ok, but I replaced it with the one that came with the example just in case.

    Anyway, my mistake. Updating Permissions to 2.7.4 seems to have solved the problem. Thanks for the help!

Share This Page