[SEC/FUN] Factions 2.0.0 - Guilds, War and user-controlled antigrief [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by MassiveCraft, May 29, 2011.

  1. Offline


    Is there any way to make it so that a faction's land cannot be taken over by a more powerful faction?
  2. Offline


    Have the faction not die and lose enough power were their land can be taken.
  3. Offline


    That makes no sense to me, the way it's worded, and doesn't imply any sort of mechanical/command description at all.
    I meant can I change a setting so that factions simply cannot take over already-claimed chunks?
  4. Offline


    No but then that would defeat the purpose of it. If you don't want people claiming others make the power regeneration really fast...or give each person a ton of power.

    Guess you could make the factions peaceful as well.
  5. Offline


    Any support for HeroChat? any support at all? You guys need to fix the economy part of this... please fix it and dont be mean!!
  6. Offline


    I got a bug, and its annoying. Anyone who has a faction has a "f" infront of their name.
    Im currently using GroupManager & GroupBridge to set my ranks.
  7. Offline


    Want to point out that I've brought the Factions page up-to-date with the current release of Factions. If you see anything missing or wrong feel free to tell me. Link is http://massivecraft.com/plugins/factions
  8. Offline


    I love you!!!!

    Now the economy part works :D Thanks!
  9. Offline

    Teh Kitteh

    So what does the 1.7 Alpha have that 1.6.3 doesn't? (github)
  10. Offline


    yes u can disable faction titles
  11. Offline


    I have not tried it but talk of 1.7 is completely changing the way you take over factions so I expect that is changed in it.
  12. Offline


    How do I set factions so that only certain people can create them? I only set my groups to have factions.kit.halfplayer yet they still can. I've tried even making a Guest rank as default in case factions was just giving the default rank all abilities. Heres my permissions file btw: http://pastebin.com/diqwpkr8
  13. Offline


    Is there anyway to make names of enemies red, like their nameplate.
    Anyway without having the clients download spout
  14. Offline


    I configured Factions 1.6.3 following the format in the default config but whenever I try to use it, Factions settings remain on the default config. Is there something wrong with my edited config?


  15. Offline


    It hasit?

    Clan"mages" haspermissions:
    and other ...

    Anotherclan of"Hunters"has differentpermissions.

    Main idea: is that the plugin for the clans to be able to interact with other plugins as well as a plug for clans in the same way asPermissionsBukkit or PEX, is able to divide the players in Groups => should be able to assign different rights to groups.
    Hopefully, if this sounds like the author, he realizes it ...
    Best wishes
  16. Offline


    I would fix the below. It is not even and you are missing a ,

      "territoryNeutralDenyCommands": [],
      "territoryEnemyDenyCommands": [
  17. can you please upgrade this to 1.1?
  18. Offline


    i'm using it on 1.1 i believe.

    I'm having a problem though .Everything seems to be working but some admin commands.

    for example i'm tryin to unclaim the land of a faction, so i do
    /unclaim FRACTION NAME but it tells me its not a command :|

    anyone know?

    EDIT nvm i got it
    i didnt have to put the faction name, i just used /unclaim
  19. Offline


    hello im new at this so bare with me :p,
    i love this mod but it comes up with errors saying 'is it up to date?' when it is and the main problem is i dont get the chat layout , i just have the normal one, and it doesn't tell me when im in a safe zone ect,
    any help we be much appreciated

    thanks so much
    jem :)

    this is what my server says:

    174 recipes
    27 achievements
    23:22:31 [INFO] Starting minecraft server version 1.1
    23:22:31 [INFO] Loading properties
    23:22:31 [INFO] Starting Minecraft server on *:25565
    23:22:32 [INFO] This server is running Craftbukkit version git-Bukkit-1.0.1-R1-7
    9-g241b6f1-b1772jnks (MC: 1.1) (Implementing API version 1.1-R1-SNAPSHOT)
    23:22:32 [INFO] [Vault][Permission] SuperPermissions loaded as backup permission
    23:22:32 [INFO] [Vault] Enabled Version 1.2.5-b59
    23:22:32 [INFO] Preparing level "world"
    23:22:32 [INFO] Default game type: 0
    23:22:32 [INFO] Preparing start region for level 0 (Seed: 885302717)
    23:22:33 [INFO] Preparing start region for level 1 (Seed: -5228868580781600676)
    23:22:33 [INFO] Preparing spawn area: 32%
    23:22:33 [INFO] Preparing start region for level 2 (Seed: -5228868580781600676)
    23:22:34 [INFO] Preparing spawn area: 89%
    23:22:34 [INFO] AntiXRay version 0.6.10: Permissions not detected. Ops only
    23:22:34 [INFO] AXR: Loading/Scanning Chunks
    23:22:36 [INFO] repack
    23:22:37 [INFO] FATAL ERROR 8
    23:22:37 [INFO] Error: Repack failed - Please contact the author.
    23:22:37 [INFO] AXR: hidden:0 ores in 0 chunks
    23:22:37 [INFO] AntiXRay 0.6.10 enabled.
    23:22:37 [INFO] [CFBanner] CFBanner has been enabled!
    23:22:37 [INFO] [CFBanner] Permissions not detected. Going to Bukkit Permissions
    23:22:37 [INFO] [CFBanner] 1.9.3 loaded!
    23:22:37 [INFO] [GreatLoot] version 2.1.13 has been enabled!
    23:22:37 [INFO] [GreatLoot] is starting disabled! Type /lootsenable in-game to e
    23:22:37 [INFO] [GreatLoot] You must configure the server first! Change the conf
    ig.yml file in your '[server]/plugins/GreatLoot' directory accordingly and resta
    rt to enable this plugin!
    23:22:37 [INFO] [MobDisguise] by desmin88 version 1.65 enabled.
    23:22:37 [INFO] NSCommand 0.2 enabled.
    23:22:37 [INFO] You can create plugins\RealTeleporter/en.lang.txt to change text
    23:22:37 [INFO] [RealTeleporter] version [0.31] ([tickleman]) loaded
    23:22:37 [INFO] [RealTeleporter] load plugins\RealTeleporter/teleporters.txt
    23:22:37 [INFO] SkillManager - Enabled
    23:22:38 [INFO] [Skillz] Hooked into Vault, just in case :)
    23:22:38 [INFO] [Skillz] - V5.4 Enabled!
    23:22:38 [WARNING] [qQuests] Economy Not Found! All Economic Interactions Have B
    een Disabled!
    23:22:38 [INFO] [Skillz] Now listening on port 3357!
    23:22:38 [INFO] [qQuests] Version 0.1.0 by Quaz3l: Enabled
    23:22:38 [INFO] [Factions v1.6.3] === ENABLE START ===
    23:22:38 [INFO] [Factions v1.6.3] No permission plugin detected. Defaulting to n
    ative bukkit permissions.
    23:22:38 [INFO] [Factions v1.6.3] Loading board from disk
    23:22:38 [SEVERE] Error occurred while enabling Factions v1.6.3 (Is it up to dat
    e?): null
    at com.massivecraft.factions.integration.Econ.doSetup(Econ.java:44)
    at com.massivecraft.factions.P.onEnable(P.java:98)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:230)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:190)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:173
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:356)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:343)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:175)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:407)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
    23:22:38 [INFO] [SimpleChestLock 0.13.1] Enabled!
    23:22:38 [INFO] Server permissions file permissions.yml is empty, ignoring it
    23:22:38 [INFO] Done (6.110s)! For help, type "help" or "?"
  20. Offline


    some reason guest can create a faction :| and they have ZERO permissions. Gotta figure out how to remove that.
  21. Offline

    Garrett Buse

    You should add a feature in which wolves owned by a member of a faction will attack, members of enemy factions on sight.
  22. Offline


    not sure if this is a factions problem, but
    my faction cannot edit anything on two chunks of land
    used to work, now it doesnt
    even faction admin cant break it,
    op can.
  23. yes ur right im using it on 1.1 also
  24. Offline


    im having a problem. in the settings i put
    safeZoneDenyBuild": flase,
    "safeZoneDenyUseage": false,

    but still people cant build in safezones. I rebooted the server twice, and it hasnt helped.
    anyone know how to resolve this? thanks
  25. Offline

    Nick Hooper


    Currently is there a way to extend a players maximum power depending on (#) amount of time? It would be awesome to have a players maximum power increase by (#) for every (#) minute/hour/day's of total playtime they have. Possibly by using another plugin as a resource (Example: Playtime) if needed you can count the playtime and add additional maximum power.

    For an example, you get 1 additional maximum power point every 24 hours of total playtime you have. "Player" has 48 hours of total playtime on a server. Player's (maxpower) = (maxpower) + (playtime/24hours) making it so that he has 2 additional maximum power.
  26. Offline


    If a player dies and he doesn't choose to respawn, he will still gain power. Any way to avoid this ?
  27. Offline


    JSON code ignores spacing problems.
  28. Offline


    Still missing the ,
  29. Offline


    I put the , in. Still doesn't work.
  30. Offline


    Next time I suggest making a new config that works then comparing the two...I took the liberty to compare it to mine and while testing your config it didn't work. After editing it and fixing the . and ] (error in console made me look at it) I got this and it works.

      "territoryNeutralDenyCommands": [
    Marine likes this.

Share This Page