[SEC/FUN] Factions 2.0.0 - Guilds, War and user-controlled antigrief [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by MassiveCraft, May 29, 2011.

  1. Offline


    When i using 1.6.9

    20:34:42 [SEVERE] Could not pass event BlockPlaceEvent to Factions
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:332)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:477)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:462)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockPlaceEvent(CraftEventFactory.java:99)
    at net.minecraft.server.ItemBlock.interactWith(ItemBlock.java:76)
    at net.minecraft.server.ItemStack.placeItem(ItemStack.java:84)
    at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:347)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:649)
    at net.minecraft.serverhook.NetServerHandlerProxy.a(NetServerHandlerProxy.java:94)
    at net.minecraft.server.Packet15Place.handle(SourceFile:58)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:281)
    at net.minecraft.server.NetServerHandler.d(NetServerHandler.java:109)
    at net.minecraft.server.ServerConnection.b(SourceFile:35)
    at net.minecraft.server.DedicatedServerConnection.b(SourceFile:30)
    at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:583)
    at net.minecraft.server.DedicatedServer.q(DedicatedServer.java:212)
    at net.minecraft.server.MinecraftServer.p(MinecraftServer.java:476)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:408)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:539)
    Caused by: java.lang.NullPointerException
    at com.massivecraft.factions.Faction.playerHasOwnershipRights(Faction.java:672)
    at com.massivecraft.factions.listeners.FactionsBlockListener.playerCanBuildDestroyBlock(FactionsBlockListener.java:229)
    at com.massivecraft.factions.listeners.FactionsBlockListener.onBlockPlace(FactionsBlockListener.java:47)
    at sun.reflect.GeneratedMethodAccessor155.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:601)
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:330)
    ... 19 more
  2. Offline


    [SEVERE] Could not pass event AsyncPlayerChatEvent to Factions

    This is one the supposed updated 1.6.9 (latest build) but as it seems, i'm still getting errors and still no tags in chat with the updated EssentialsChat. It's not game breaking but is a cause for concern when you have 20+ people flagging errors every time they chat.
  3. Offline


    Get the very latest version (2.9 prerelease) here: http://ess.ementalo.com/
  4. Offline


    For Some Reason, The Plugin Does Not Work AT ALL For Me. No /f help , /f . No Commands Work Whatsoever. Also, all my safezone,warzone has been unclaimed? PLEASE HELP D:
  5. Offline


    What does it show you in your server.log/console on server startup and when you type /f help?
  6. Offline


    Does anyone have a configuration to make it work with HeroChat?
    I have tried anything possible but everytime i change something in the config.json file either HeroChat prefixes/colors disappear OR the HeroChat prefixes/colors work but the faction tag disappears.

    I would be very thankful if someone could give me their configuration for HeroChat compatiblity

    Thanks in Advance
  7. Offline


    Im trying to claim safezone but its claiming more then it should and i cant see the wildernis line sometimes or the safezone. its acting really weird. (the new version)
  8. Offline


    Seriously... All the faction leaders are no leaders anymore? Why?
  9. Offline


    Wrong up/downgrading... This is a irc chat log snippet on how to downgrade faction from 1.7 to 1.6:
    [20:08] <JWhy> back up your players.json and conf.json now
    [20:08] <JWhy> delete conf.json (keep backup somewhere else)
    [20:08] <JWhy> Open players.json with nPP and use Find+Replace
    [20:10] <JWhy> Replace 'LEADER' by 'ADMIN', replace 'OFFICER' by 'MODERATOR'
    [20:10] <JWhy> then save this file and start up with 1.6.9 factions
    [20:10] <JWhy> backup is important
  10. Offline


    Brettflan or JWhy could you maybe give answer on this questions?
  11. Offline


  12. Offline


    Yes... i have read about that but... the problem is everyone has a Member role now in my json file -.-
  13. Offline


    Alright thanks.

    Hope brett got a answer on the other questions though.
  14. Offline


    I think he looks a_lot more often on bukkitdev than on these forums...

    Yep that means it's too late^^
    No seriously... it could have been avoided with these instructions (i did it wrong too)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  15. Offline


  16. Offline


    ofcourse it could have been avoided but why change the plugin in a way that this happens to begin with...
  17. Offline


    The latest faction update broke a lot of chat plugins. It's frustrating because I can't show prefixes in chat any more so I'm forced to use 1.6.7. Please fix this.
  18. Offline


    People with chat plugin issues, you should read through Brett's comments on the Factions GitHub issues. It explains how chat has changed. With 1.6.9, you might need to add [FACTION] in your title prefix for public chat. Take some time to read up on the changes and how chat has changed. Also, you might need dev versions of your chat plugins like EssentialsChat, etc.

    Brett or anyone else that might know, is there a way either in the config or in the source to make it where if an enemy or neutral faction member is in a Wildnerness chunk, another enemy or neutral faction member can't claim that chunk either through /f claim, /f autoclaim, or /f claim radius?

    For example, Warriors and Rebels are enemy factions. KewlDood is in Warriors and LeetKiller is in Rebels. KewlDood is in a wilderness chunk and suddenly LeetKiller drops in on him. How do I make it so they can't claim that chunk for their faction?

    This is needed because, on our server, players have to build cannons in Wilderness. TNT is turned off in Wilderness so that the charge doesn't blow up the cannon (we have water protection off) but the payload fires into faction territory and breaks walls. Currently, enemy or neutral faction members can claim the chunk where the opposing players are and the cannon and stop a raid.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  19. Offline


    I actually had that down as a feature to implement before I stopped actively developing the plugin beyond basic maintenance. It's certainly possible in source.
  20. Offline


    My permissionsEX prefix goes away when I install the factions plugin and when I remove it from my plugins directory and reboot my server they come back so something with the factions plugin removes my prefix. Does anyone know about this?
  21. Offline


    "claimedLandsMax": 0, this is a per faction or per player setting?
  22. Offline


    Very nice plugin man good job but im having a big problem!

    I user PermissionsEx and i got chatmanger and its enabled everything was working fine all the prefixes were fine then once i installed factions my prefix went and evereyones name colour went.

    Im pretty sure it has something to do with chatmanager!

    Chatmanager Config:

    enable: true
    message-format: <%prefix%player%suffix> %message
    global-message-format: <%prefix%player%suffix> &e%message
    ranged-mode: false
    chat-range: 100.0
  23. Offline


    Why did you remove /f owner??? please re-add it!
  24. Offline


    I am running a very neat MineZ type of server with a massive city setup. Using Factions to disable damage to the world basically turning "wildernessDenyBuild": true, on my basic issue is people can not explore buildings and sewers because they can not place torches or open iron doors. I basically need an addition to factions or a plugin that links with Factions over riding the "wildernessDenyBuild": true for certain blocks ie: Torches and Levers but after a while removes those torches or levers if not placed in a faction claimed area. I should basically have a config that looks something like
    - world_name
    - torch
    - lever
    Blocks Not Protected if not in claimed area:
    - torch
    - lever
  25. Offline


    Type /f help to have a look at the new commands
  26. Offline


    I hate how people can ally with you, then trick you in to letting them see your base, then they make you an enemy and kill you and take your stuff. That isn't very antigrief.
  27. Offline


    Thats Why I do not except people as Allies unless they are in our teamspeak
  28. Offline


    The chat function is messed up now since 1.3.1. Please make factions compatible with herochat.
  29. Offline


    Has anyone successfully been able to use Factions 1.6.9 with HeroChat 5.6.2?
    For example, the faction name doesn't get converted AND chat happens outside of HeroChat unless you specify the channel with a shortcut.
  30. Offline


    I've tried everything you can imagine with all versions of herochat and factions. There is NO way at the moment. Do not waste your time on it. It's either Herochat or Factions unless the guys @ factions update the compatibility.

Share This Page