[SEC/FIX/MECH] Locker v1.6.0 - Lock your blocks [1.3.2-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 23, 2011.

  1. Offline


    Locker - Lock your blocks
    Version: 1.6.0 - Download
    Source: Github

    Tired of getting your stuff snatched by other players?
    Tired of hiding your chests to prevent that?
    Then this plugin if for you.
    There is simply no way to view a locked chest if it is locked (If the player isnt allowed to).
    The player isnt even able to place a chest beside a locked chest (If the player isnt owner) to make it a doublechest.
    If a player unlocks a block with a password, it will be unlocked for that player until he logs out.

    Locker is exremely fail-proof. If you locked a block it will be safe. No exceptions.
    It keeps track of every locked block, making it impossible to have an invalid locked block in the database.
    If you suspect that any blocks are invalid, against all odds, there is "/locker validate".
    A player cannot destroy the block under a door if he/she doesnt own the door.
    A player cannot place a chest beside a locked chest if he/she doesnt own the chest.
    An explosion cannot destroy a locked block.
    A block is unlocked if it gets destroyed by its owner.
    A chest is locked if its placed beside another locked chest that the player owns.
    A door cannot be opened by redstone and a dispenser cannot be dispensed by redstone(if its not the owner placing it).
    A door cannot be locked on gravel or sand.

    Remember that a door and a doublechest count as two blocks!


    Show Spoiler

    Replace # with & !



    Traya1991, KuroSnow and kahlilnc like this.
  2. Offline


    Use the built-in permissions if you dont have the plugin Permissions.
    OPs can do anything and normal players use the permissions.

    Maybe, it depends on the performance of the database.
    I built this plugin to lock blocks and not regions, but I might add it anyway. :)
  3. Offline


    you do that, think a lot of people whould appreciate it :)
  4. Offline


  5. hi my players sometimes get the message unable to lock air even though they're hitting the chest ... any idea on that? oO I have to restart the server every time :(

    this is really urgent. people trying to lock/unlock their chests get the message "unable to lock/unlock air" and their chests are _not protected_ while this error occurs until the server is restarted. i dont get any error. it happens randomly. at least my players tell me that it is like that - they can access each others' chests when this error occurs. it's really strange im trying LWC right now if it has the same problem.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  6. Offline


    I think its a problem in your build of bukkit. Try updating it.

    Sure. :)
  7. Offline


    Could you put it where wit ha permission, you could add a lock to ANY block?
  8. Offline


    Yeah, its coming! :)
    Right now Im working on DefaultCommands, so this plugin will not be updated for at least a day.
  9. Offline

    Tim Yong

    Hello. Is it possible to prevent players from making an infinite amount of password type protections? In the configuration file I set the protections per player to 4 and gave them the appropriate permissions. They indeed can only have 4 protections, but are able to place an infinite amount of password type protections.
  10. Offline


    Thanks, Im fixing that in the next update! :D
  11. Offline


    As an admin running a server is there a way to limit what blocks players can lock. Such as if I don't want them to be able to lock dirt blocks they place.

    With that will you end up supporting cobblestone and regular stone?
  12. Offline


    Ill add a config file for allowed blocks to lock.

    - 64
    - 54
    - 46

    And permissions nodes for the sets off blocks:
  13. Offline


    Sounds great.
  14. Offline


    Can't wait for the config file. I need to lock some webs and glass :D
    still waiting on the cuboid area locking btw ;D
  15. Offline


    1 request: Can you make it so you can lock cakes?
  16. Offline


    Awesome idea!
    The next update is going to be huge! :D
  17. Offline

    Kevin Meister

    Hey, cool plugin so far, but i have an issue. When i edit the settings in Locker.yml it just won't use them, but write back the default settings into the file after each /reload. I even recompiled your class files because i got so frustrated ^^ Didn't help. I know there is an ingame edit, which actually works, but how can I do spaces there? I changed a text message to see if it works and now i can't change it back because it won't read in spaces.
  18. Offline


    Hmm, guess I didnt think of that.
    It writes the config on exit, so you must edit the preferences in-game or when the server is shutdown. :)
  19. Offline

    Kevin Meister

    Thanks, should have come to this idea before.:rolleyes:
  20. Offline


    What's the code to allow people to open other peoples locked doors?
  21. Offline


    To open: locker.view.other
    To unlock: locker.unlock.other
  22. Offline


    Hmm... Doesn't seem to be working for me with CB740. Moderators on my server can open others locked doors even with out - 'locker.view.other', and can still do it even with - '-locker.view.other'
  23. Offline


    Make sure op_permissions is set to false in confg. :)
  24. Offline


    Nice work, this looks great.

    Any ETA on the update that will allow all blocks to be lockable?
  25. Offline


    Im working on DefaultCommands right now, but I might get the time to update Locker this week. :)
  26. Offline


    I just have a couple of questions, just so make sure I'm understanding everything:

    1) So you can only lock blocks that you placed yourself? Because it wouldn't be too fun if there were a prankster who went around locking everyone's unlocked chests, doors, etc. xD

    2) Also, when you lock a block, you can either lock with a password, or restrict access so only the specified people can open it, and everybody else simply can't?
  27. Offline


    Other players cant lock your blocks, if theyre locked.

    The password will override the allowed list, so everyone is allowed to unlock it, if they have the password.
  28. Offline


    Feature request please. I'd like to be able to lock monster spawners (Would go nicely with CreatureBox)
  29. Offline


    Yesterday it was working, I started the server up today, and it wasn't working.
    It just is giving this error now:
    2011-05-15 20:12:39 [INFO] Starting minecraft server version Beta 1.5_02
    2011-05-15 20:12:39 [INFO] Loading properties
    2011-05-15 20:12:39 [INFO] Starting Minecraft server on *:25565
    2011-05-15 20:12:39 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-05-15 20:12:39 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2011-05-15 20:12:39 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    2011-05-15 20:12:39 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-729-g5ee3f0f-b766jnks (MC: 1.5_02)
    2011-05-15 20:12:39 [INFO] Preparing level "world"
    2011-05-15 20:12:39 [INFO] Preparing start region
    2011-05-15 20:12:40 [INFO] Preparing spawn area: 73%
    2011-05-15 20:12:41 [INFO] DataSourcePool [Locker] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    2011-05-15 20:12:43 [SEVERE] FATAL: DataSourcePool [Locker] is down!!!
    2011-05-15 20:12:43 [INFO] Reseting DataSourcePool [Locker] min:2 max:20 free:0 busy:0 waiting:0 highWaterMark:0 waitCount:0 hitCount:0
    2011-05-15 20:12:43 [INFO] Busy Connections:
    2011-05-15 20:12:43 [SEVERE] Could not load 'plugins\Locker.jar' in folder 'plugins':
    com.avaje.ebeaninternal.server.lib.sql.DataSourceException: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
    The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.<init>(DataSourcePool.java:210)
        at com.avaje.ebeaninternal.server.lib.sql.DataSourceManager.getDataSource(DataSourceManager.java:210)
        at com.avaje.ebeaninternal.server.lib.sql.DataSourceGlobalManager.getDataSource(DataSourceGlobalManager.java:63)
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.getDataSourceFromConfig(DefaultServerFactory.java:427)
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.setDataSource(DefaultServerFactory.java:388)
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.createServer(DefaultServerFactory.java:168)
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.createServer(DefaultServerFactory.java:64)
        at com.avaje.ebean.EbeanServerFactory.create(EbeanServerFactory.java:78)
        at org.bukkit.plugin.java.JavaPlugin.initialize(JavaPlugin.java:175)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:166)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:191)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:115)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:100)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:218)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:205)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:145)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:260)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
    The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)
        at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:1116)
        at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:343)
        at com.mysql.jdbc.ConnectionImpl.coreConnect(ConnectionImpl.java:2334)
        at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(ConnectionImpl.java:2371)
        at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2163)
        at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:794)
        at com.mysql.jdbc.JDBC4Connection.<init>(JDBC4Connection.java:47)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)
        at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:378)
        at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:305)
        at java.sql.DriverManager.getConnection(Unknown Source)
        at java.sql.DriverManager.getConnection(Unknown Source)
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.createUnpooledConnection(DataSourcePool.java:401)
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.createConnectionForQueue(DataSourcePool.java:607)
        at com.avaje.ebeaninternal.server.lib.sql.PooledConnectionQueue.ensureMinimumConnections(PooledConnectionQueue.java:205)
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.initialise(DataSourcePool.java:248)
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.<init>(DataSourcePool.java:208)
        ... 17 more
    Caused by: java.net.ConnectException: Connection refused: connect
        at java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.net.PlainSocketImpl.doConnect(Unknown Source)
        at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
        at java.net.PlainSocketImpl.connect(Unknown Source)
        at java.net.SocksSocketImpl.connect(Unknown Source)
        at java.net.Socket.connect(Unknown Source)
        at java.net.Socket.connect(Unknown Source)
        at java.net.Socket.<init>(Unknown Source)
        at java.net.Socket.<init>(Unknown Source)
        at com.mysql.jdbc.StandardSocketFactory.connect(StandardSocketFactory.java:254)
        at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:292)
        ... 36 more
    2011-05-15 20:12:43 [INFO] [HeroicDeath] enabled.
    2011-05-15 20:12:43 [SEVERE] [mcMMO] Permissions isn't loaded, there are no restrictions.
    2011-05-15 20:12:43 [INFO] mcMMO version 1.0.07 is enabled!
    2011-05-15 20:12:43 [INFO] road version 0.1 is enabled!
    2011-05-15 20:12:43 [INFO] Stargate-DHD v.0.2.1 is enabled.
    2011-05-15 20:12:43 [INFO] WorldEdit 4.4 enabled.
    2011-05-15 20:12:43 [INFO] WorldEdit: No known permissions plugin detected. Using configuration file for permissions.
    2011-05-15 20:12:43 [INFO] WorldGuard: No known permissions plugin detected. Using configuration file for permissions.
    2011-05-15 20:12:43 [INFO] WorldGuard: (world) Single session is enforced.
    2011-05-15 20:12:43 [INFO] WorldGuard: (world) TNT ignition is PERMITTED.
    2011-05-15 20:12:43 [INFO] WorldGuard: (world) Lighters are PERMITTED.
    2011-05-15 20:12:43 [INFO] WorldGuard: (world) Lava fire is blocked.
    2011-05-15 20:12:43 [INFO] WorldGuard: (world) Fire spread is UNRESTRICTED.
    2011-05-15 20:12:43 [INFO] WorldGuard: Loaded configuration for world 'world"
    2011-05-15 20:12:43 [INFO] WorldGuard: 1 regions loaded for 'world'
    2011-05-15 20:12:43 [INFO] WorldGuard 5.0-alpha10 enabled.
    2011-05-15 20:12:43 [INFO] Done (0.409s)! For help, type "help" or "?"
    I tried reinstalling the plugin, it doesn't write all the files. Not the ebean.properties (If that is involved with it), and it doesn't write the files into the folder.

    Also, a feature request, to lock signs, since I noticed that is missing. But also, if you can help me get it fixed, it would be much appreciated.
  30. Offline


    Hmm, never seen that before. Do you run any other plugin that use the built-in bukkit persistance?
  31. Offline


    Well, I use HeroicDeath, Locker (Not working atm), MagicCarpet, mcMMO, road, Stargate, WorldEdit, and WorldGuard. I used to also have a plugin called LockChest that would lock chests, and would allow you to picklock them with certain tools. To make Locker and LockChest both work, I made it so that LockChest's /lockchest command was the only one to lock chests, not Locker. I woke up the next morning and it wasn't really working, but it was working when I fixed it to do that. I did install a plugin for modifying blocks and a plugin called SimpleAdmin as well, SimpleAdmin did use ebean, and the plugin to modify blocks used the built-in bukkit persistance, I believe. Ever since I got both SimpleAdmin and that, it hasn't really been working.

    I also tried reinstalling the plugin, and uninstalling other plugins that were similar. When I added the .jar it didn't extract all the files that it should.

    Any chance I could get all the files like the folder, any other files, and the .jar zipped up or added to a .rar and test that out?

Share This Page