Inactive [SEC] EpicZones v0.37 - Polygon Based Area Protection - Now with Economy Support! [1.3.1-R2.0]

Discussion in 'Inactive/Unsupported Plugins' started by jblaske, Feb 2, 2011.

  1. Offline


    • Polygonal and Circular area creation. (Not just cuboids!)
    • In-game zone creation.
    • Provide a Circular border to your map.
    • Hierarchical Permissions with Child and Parent Zones.
    • Display Entering and Exiting messages in chat.
    • Enhanced /who
    • Advanced control of zone based regeneration
    • Many zone specific controls for things like Fire, Explosions and Mob spawning control
  2. Offline



    When destroying sign's in no destroy zone, the text gets deleted
  3. Offline


    Is it only for me that the allow permissions not working? I have grant my child group access to build in my zone but it's not working.
  4. Offline


    Hey, I´ve got a problem with this plugin.
    I get no feedback in the chat when I write a command (e.g. /zone)
    Craftbukkit is on Version 677
    and permissions is also up to date.
    Hope you can help me.
    Plugin is loaded (/plugins)
  5. Offline


    Okey I found that you must add ".allow" to get the permission working. This should be wrote in the explains, thanks.
  6. Offline


    Could you add an option to add a ceiling/floor to zones? I am building a city and want residents to not be able to build above a certain height.
  7. Offline


    This option has existed from the very first version of EpicZones. Reading the OP is a great idea.
  8. Hi, I'm having a bit of a problem using EpicZones together with HeroChat.

    What I'm trying to do is have the local proximity chat as the default fallback chat for everyone who joins the server. Then I want to create a custom zone surrounding a town, so that when you walk into the town, you join a town-wide channel instead of the proximity channel and is able to speak to anyone within the town.

    Making the first two steps happen is very easy and works perfectly. Where I encounter problems though is when I try to leave the town. I obviously want the chat to leave the town-channel and fall back to the local proximity channel, sadly, it doesn't seem to fully work.

    Upon leaving the town-zone I can do a /ch list and see that I am no longer in the channel, but as soon as I type something it ends up in the town-channel anyway, even though I'm not even in the zone.

    Is this a known issue?
  9. Offline

    Pontus Lantz

    As Sidola says. Me and him have tried to make this happen for several hours now and would give you a peice of my soul to get this fixed <3
  10. Offline


    @Sidola @Pontus Lantz

    I'll be checking this out this evening. Hopefully I can make a release.
  11. Offline

    Pontus Lantz

    Starting to carve some soul
  12. Offline


    Ok, sorry, I read the OP but didn't see it. I was in a rush though... Back to the OP! XD
  13. Offline


    Hey my problem still exists and I want to ask, if anybody can help me. The server loads the plugin (/plugins - command) and there is the mapboarder but I dont get any Textmessage when i'm typing /zone etc.
    Hope you can help me.
  14. Offline

    Pontus Lantz

    Do you have Permissions or GroupManager installed? And if so have you written the correct one down in the config.yml?
  15. Offline


    Yep Permission is installed and i think as an Admin you dont need the permission.command ( you have '*')
  16. Offline

    Pontus Lantz

    No in the config.yml for EpicZones there is a setting for wich permission system to use. Default is GroupManager.
    Change it to Permissions.
  17. Offline


    Thx problem solved. :D
  18. Offline


    I using the Permission plugin and
    dont works for me.
  19. Offline


    More information is required, please open up a support ticket.
  20. Offline


    I have the roughly same problem as nicke937.

    My problem is though i have managed to get kind of sort out permissions but people still get an error message when trying to build within the zone, I really enjoy your plugin and its functionality (stoping mobs pvp regen ect) it is very handy, i am just not quite able to sort out the permissions and config so i can giver certain people access to build ina certain area (i dont want to give a whole group the permissions)

    I Would love some form of video or walk through tutorial on permissions :) i feel that would help your plugin out greatly (just reading over past comments ive noticed im not the only one)
  21. Offline


    Hi! I'm relatively new with Java, so forgive me if this is a stupid question, but how would I go about making another plugin find out which zone a player is in? Is there some sort of getZone(player) method that returns the name of the zone as a string? Or anything else that could accomplish the same task?

    Thanks for your help!
  22. Offline


    Is this still working in CraftBukkit #689 (1.5_01 client) or above?
  23. Offline


    Is there a way to disable mobs globally, but enable them in a certain zone?
  24. Offline


    Update for 1.5 patch please.
  25. Offline


    Version 0.20 is finally here!
    • Version 0.20
      • Zone based permissions
      • New Zone Format
      • Enhanced Regen
      • Refined Ownership
      • Bug Fixes
      • Code Cleanup
    The biggest change in this version is that your Permissions system is no longer in charge of zone permissions.

    **This means you will need to re-do all of your permission**

    Zone file format has also changed, to make zone configurations easier to read and manipulate.

    If you currently use EpicZones, and have a zones.txt file, then when you run version 0.20 your zones.txt will be converted into the new format, and will be renamed to zones.txt.old (so you won't lose anything, don't worry)

    I have not been able to test every possible scenario of permissions, so please test them and report back if there are any issues.

    The other major change, is that a Permissions system is no longer required. And EpicZones will auto detect your permissions system, rather than force you to define what you want to use. Permissions system is now only used for actual permissions, and finding the groups a player is in.

    I will be updating the OP with all of this information soon, I just don't have time to do it tonight.

    Thanks everybody for your support, if i haven't gotten to your issue or feature request in this version, I should in the next.
  26. Offline


    Things that I need on my server...

    "Hierarchical Permissions with Child and Parent Zones." iZone apparently can't do that yet. I stand corrected.

    "Possible Permission Flags:

    You, sir, win the cake. [cake] Thank you. Testing now...

    EDIT: [Bug Report] When using /zone draw on a previously existing zone with points, it says that the points will be deleted and asks for confirmation. After drawing the new points and using /zone save, the new points are simply added after the old points in the .yml file (old points aren't deleted). CB733

    Waiting for the OP to be updated, as I'm not quite sure how to use some of the new v0.20 features (e.g. "permissions: {}" in /Zones/*.yml).
  27. Offline


    Same here, I am totally confused about the permissions now!

    I tried a few things but they didnt work. This is all that stands between me and a 1.5 server!!

    jblaske keep up the great work!
  28. Offline


    I'm on my phone at the moment, so I can't post a proper post.

    But to get started with permissions use the following command when editing a zone.
    /zone perm <user/group> <entry/build/destroy> <allow/deny>

    /zone perm jblaske build allow
    /zone perm default entry deny

    Hope that helps for now.
  29. Offline


    Nice one thanks I will give it a go

    No joy, as a member of the guests group (in group manager) I am getting the you do not have permissions to build/destroy message:

    Here is my zone file:

    ceiling: 128
    childzones: []
    entertext: '*** Entering Build Zone You May Now Build :) ***'
    exittext: '*** Leaving Build Zone you can not Build Here! ***'
    explode: false
    fire: false
    fireburnsmobs: false
    floor: 0
    mobs: []
    name: public1
    owners: []
        destroy: allow
        build: allow
    points: '-32:-78 -32:1000 -1000:1000 -1000:-78 '
    pvp: false
    radius: 0
      amount: 0
      bedbonus: 0
      delay: 0
      interval: 500
      maxregen: 20
      mindegen: 0
      restdelay: 0
    sanctuary: false
    type: POLY
    world: world
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  30. Offline


    Some ideas to try: Make sure the group name is the same case as the name in the group manager config. if that's the case, try it with your name instead of the group.

    If neither of those work, let me know.

    Thanks for the update, I'll get that checked out as soon as I can. Workaround until it's fixed would be to manually remove the old points from the yml and issue a /ezreload.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  31. Offline


    Ok mixed news, I have already tried with the group name guests and Guests (it is Guests in group manager) still doenst work

    It seems to work fine with the username :)

Share This Page