Inactive [SEC] CreeperHeal v4.13 - Repair Creeper damage, the natural way! [1.2.5]

Discussion in 'Inactive/Unsupported Plugins' started by Nitnelave, Jun 21, 2011.

  1. Offline



    The project in now on BukkitDev! Go there to find all the news, downloads, error reporting, and everything else!
  2. Offline


    had an idea though, since the explosions overwhelm the server, is it possible to have the plugin make a file that tells it exactly what it destroyed so it if it does glitch, the blocks will still come back instead of some of them? I have a feeling the plugin only stays in memory and doesn't write anywhere when everything is happening. I could be wrong mate, just an idea id throw out there.

    Oh no worries mate, ill do what I can to keep testing your plugin and will let you know what we find. Everyone over here seems to enjoy your plugin quite a bit. There hoping you can fix glitch of blocks not reappearing cause of too many explosions if possible. Server runs Core i7 16gigs of ram, Windows 2008 R2 SP1 etc etc.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  3. Offline


    Well, the server would be overwhelmed trying to write to the files... it wouldn't solve the issue. I don't think I can do anything about that. No one sane would try and explode 64 tnt on a real server, and still expect the terrain to look fine :p
  4. Offline


    lol. Actually on a "real server" there has been many cases of that and they were fine mate ;-) they just didn't care about regenerating was all. Also when you have 32 gigs of memory, no wonder they didn't care lol.
  5. Offline


    Very nice plugin, looking forward v 3.0 our players likes it ;)
  6. burn damage not 100% repaired :(
  7. Offline


    Anything more precise? were there blocks above it? Redstone, rails, doors, or something like that? or just a whole bunch of things burned down, and some didn't regenerate?

    Coming tonight (probably).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  8. For example a easy wood cube 5x5 or some trees and a burn it down
    than many blocks missing
  9. Offline


    I'll have a look at it, if I have time. But that may not be until next week-end. Bear with the bug until then...
  10. Offline


    Can you give the forceheal command to moderators using permissions 3 but not the rest? Would you need to add a permissions node in your plugin or am I just doing something wrong? :)
  11. Offline


    I could, but that would make me add a permission node. I'll see if I do.
  12. Offline


    just did a clean install of this plug in and i found this in the server log

    2011-08-05 18:07:19 [WARNING] [CreeperHeal] Wrong value for replacement method field. Defaulting to block-per-block.
    2011-08-05 18:07:19 [INFO] [CreeperHeal] version 3.0 by nitnelave is enabled

    yes i deleted the .jar and the folder then put in the new .jar
  13. Offline


    I won't be able to update any time sooner than wednesday. But don't worry about that warning. You can try and manually change the setting to block-per-block
  14. Offline


    no problem it seems to be working just thought the log looked odd and keep up the good work
  15. Offline


    Did you just add new permission nodes? Wow you really listen to your users :) Thanks a bundle!
    I noticed a bug, unless I understand the option incorrectly.

    When I have the setting on that gives you a drop if you place a block in a destroyed block's spot and it tries to heal it it will give me blocks for every block destroyed even if I haven't put something in their places.
    Essentially duplicating everything that has exploded.

    I turned off the option for now.
    As I read it it's supposed to only give drops for destroyed blocks you already fixed/put something else in not for every block it destroyed regardless, duplicating them all. Correct?

    Thanks again for adding the permission nodes, hope I helped a little bit with reporting the bug.

    Here's how my config was set up when I got the duplications
    It was with the build I downloaded yesterday right before I asked about adding more nodes.

    Creepers: true
    TNT: true
    replace-ghast-fireballs: true
    replace-magic-explosions: false
    interval: 60
    block-per-block: true
    block-interval: 20
    replace-burnt-blocks: true
    burn-interval: 45
    replace-natural-only: false
    natural-blocks-whitelist: 1, 2, 3, 9, 11, 12, 13, 14, 15, 16, 17, 18, 21, 24, 31, 32, 37, 38, 39, 40, 48, 49, 56, 73, 79, 81, 82, 86, 87, 88, 89
    natural-blocks-blacklist: 0
    refresh-frequency: 20
    drop-replaced-blocks: true
    teleport-on-suffocate: true
    teleport-on-suffocate-block-per-block: true
    replace-tnt: false
    log-level: 1
    drop-not-replaced: false
    drop-chance: 100      
  16. Offline

    Clancy Dawson

    Here is an idea for a possible future update:
    As a alternative option to restoring the damage by replacing the blocks, you could have it so that WorldEdit's smoothing tool automatically smooths the area around an explosion. So there will still be a small effect from the explosion, but it will fit into the surrounding scenery. Personally, I'd prefer this, to completely regenerating the damage.
  17. Offline


    There shouldn't be any duplicating, though I didn't have time to test extensively... You have to delete your config, you're still on simple world options, not multiworld.

    I'll see if WE has a good API for that, but that may not happen
  18. Offline


    Need webhosting? I will host anything for Free and its 100% Static. Daily Backups :)
  19. sticky pistons don't recovery !
  20. Offline


    Here is a good severe error for you mate. Hope this helps. This is from your new versions 3.0

    Could not pass event ENTITY_EXPLODE to CreeperHeal
    at com.nitnelave.CreeperHeal.CreeperListener.onEntityExplode(
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at net.minecraft.server.Explosion.a(
    at net.minecraft.server.World.createExplosion(
    at net.minecraft.server.WorldServer.createExplosion(
    at net.minecraft.server.EntityCreeper.a(
    at net.minecraft.server.EntityCreature.c_(
    at net.minecraft.server.EntityLiving.v(
    at net.minecraft.server.EntityMonster.v(
    at net.minecraft.server.EntityLiving.m_(
    at net.minecraft.server.EntityMonster.m_(
    at net.minecraft.server.EntityCreeper.m_(
    at net.minecraft.server.World.entityJoinedWorld(
    at net.minecraft.server.WorldServer.entityJoinedWorld(
    at net.minecraft.server.World.playerJoinedWorld(
    at net.minecraft.server.World.cleanUp(
    at net.minecraft.server.MinecraftServer.h(

    Another one for you:

    [SEVERE] Could not load 'plugins\CreeperHeal.jar' in folder 'plugins': error in opening zip file
    at Method)
    at<init>(Unknown Source)
    at<init>(Unknown Source)
    at java.util.jar.JarFile.<init>(Unknown Source)
    at java.util.jar.JarFile.<init>(Unknown Source)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(
    at net.minecraft.server.MinecraftServer.init(

    those errors occur and nothing is regenerated, I used 1 creeper, nothing regenerated. I used 1 tnt block, still nothing. Let me know what you think mate. Cheers

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  21. Offline


    Hi there i just updated from 2.0.1 (i think) to 3.0 and as someone before me has said, suddenly any of the creeperheal commands say i dont have permission

    i dont use permissions, i only use the ops.txt

    and there is only two people in that file

    i did erase my config and redo it but still get the same message :S

    i hope it can be fixed

    as for being OP my other plugins/commands work fine
  22. Offline


    yeah well, it's a very nice plugin and i love it, it's just that when a creeper blows up a tower of diamond blocks i set out, it restores them afte x second + they duplicate them and let me pick up the same amount....
    this is being abused on my server... anything you can do about it ???
  23. Offline


    wait-before-heal keeps getting reset back to 0
  24. Offline


    Got this plugin loaded up on my server and I love having my cities repaired after a creeper invasion.

    However, I'm seeing some odd behavior where only every 3rd creeper or TNT actually "explodes".
  25. Offline


    Sorry everyone, but I'm on holidays, and I had one evening to compile, debug, test and upload my code for the new release, so it is not bug-free (but I did my best). I'll be back in the end of the week to try and fix my mess, but then I'll be off again. And starting from September, I won't be able to update anymore, so if anyone would like to take over the plugin, I'd be willing to help.

    What do you mean? I'll run another test, but they did last time I checked, and nothing should have changed... Do they just disappear? or do they drop on the ground instead of being placed? or is it just that when they should be extended they are not? This last thing is only dependent of the redstone, so I can't do anything about it.

    I think you saved the .jar as a zip file, or something... It shouldn't try and open it as a zip file. If you type /plugins, CreeperHeal shouldn't appear on the list. For the first error, I'll try to see if I can do anything. Did you notice any relation to an actual event?

    Try and set the plugin's permissions in the permissions.yml file at the root of the server. I'll try and find a way to fix that, but I didn't spend much time testing for permissions, and I think the new bukkit permisisons screwed up the op system, so I'll check.

    Could you post your config so I can have a look? I might have to review the drop system. I did it in quite a hurry but I thought it worked...

    try /ch interval x

    Are you getting anything in the log? Are you sure it's to do with my plugin? It shouldn't cancel explosions (unless there's a bug).
  26. Offline


  27. Offline


    That's not a config from 3.0. Try and delete it, a new one will be generated with multiworld settings
  28. Offline


    I did try to /ch interval x and ingame it said it was set but in the config file nothing changed. so I tried the fire interval and that one did change.
  29. Offline


    Getting nothing unfortunately... Although, after a few server restarts and some "burn in" time, all is normal :)
  30. Offline


    Setting whitelist or blacklist gets reset back to false each time even if all values under the restrict-list are valid.

    Also how do I add the different kinds of wool and logs, adding 17:1, 17:2 causes an invalid entry error.

  31. Offline


    Did you delete the config? it has to reflect some multiworld settings. Do you have any error on the log?
    Ok... No idea what might have caused this.
    Are you sure you have the latest config? With multi-world settings? Try and modify it when the server is down, it may save the current settings to the file on shutdown.
    And it is not possible (currently) to have data values in the restrict-list. Do you really need it?

Share This Page