Inactive [SEC] BigBrother 1.11.0 - Catch griffers red-handed [1060]

Discussion in 'Inactive/Unsupported Plugins' started by N3X15, Apr 13, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Important Crap

    I'm done, but BB isn't.
    I've got 10 developers on the contributors' list who supposedly want to help, but I haven't heard a word from them since the day I added them. BigBrother's so full of bugs now that I don't know where to start, and I simply don't have the time or patience to work on it anymore. If you want something that works, pick up LogBlock. I'm fucking done. I updated it to "run" on 1060, but that's as far as I'm taking this. If you still want to help, email me at [email protected] and give me a rundown of your experience in coding plugins so I know you'll do something.​
    UPDATE: 3 developers have been added to the repo, but I'm waiting for them to get familiarized and start committing before I declare this crisis over. I appreciate the support and help that has been thrown this way. If you'd still like to help, but don't know how to code, there are many other ways to contribute. See the Contributors section for more info.​

    Version: 1.11.0
    Original Author: tkelly910

    • Development Team
      • N3X15
      • Mafio
      • FalconGaming
    • Quality Assurance (QA) Team (Testing, ONLY ON LATEST RB*!)
      • N3X15
      • Mineral
      • All of the poor bastards on the minecraft server + other dev servers
      • *NOTE: Unless EvilSeph or other bukkit devs indicate an RB is imminent, e.g. within the next week.
    • Bug Triage (Sorting through bugs, marking duplicates, closing, prioritizing)
      • N3X15
    • Documentation (Wiki, FAQ, other stuff people will read)
      • N3X15

    BigBrother is a powerful plugin that enables you to investigate roll back griefing via a large and all-knowing database. You have a choice between using immensely powerful commands to search an area for changes, or you can whack a block with a stick or place a log to see changes within a single block.

    • /bb log - Gives you the BigBrother Multipurpose Tool, or a simple log. Hit something with it to see changes in that spot, and place it if the block you're check is non-solid, like water, lava or air.
    • /bb done - Removes the log from your inventory, and gives you back any items it replaced.
    • Want to check an entire area? Use /bb here to list who changed what!
    • Need to roll back EvilGuy and DoucheBug's edits? Use /bb rollback EvilGuy DoucheBug!
      • Have to roll back edits up to 5 minutes ago? Simple! /bb rollback t:5m
      • Need to only roll back within a certain radius? /bb rollback r:<radius-in-blocks>
      • Roll back specific actions with /bb rollback a:10,BLOCK_PLACE
    • If you screw up, /bb undo
    • (NEW) /bb history "Suspicious Guy" to see that player's recent history! (add pg:# to go to page #)
    • Mow your lawn with /bb mowlawn!
    See the full list of commands and Permissions nodes here.


    [​IMG](Yes, stationary_* and regular blocks got reversed, this is fixed.)​

    Need Help?

    • What version of CraftBukkit and BigBrother? If you don't know, type /version and /bb version.
    • What database engine are you using? Look at the value for database.type in BigBrother.yml. I use MySQL on my server and test on H2.
    • Do you get any errors? If so, please link to a pastebin with your server.log
    • What steps do I have to take to reproduce this behavior?
    • What other plugins are you using?
    Known Issues
    • Everything listed here
    • ItemCraft is not supported due to it sending unexpected NULLs via Block.getType(). Can be fixed by adding a new enum value for unknown blocks.
    • Bugs everywhere, stopped counting.
    Coming Soon
    • /bb history - Gets the history of a player
    • Fixed /bb update
    • Updated API
    • Externally accessible API
    • Custom Action IDs (for WorldEdit support, etc.)
    More Information

    IRC: Support/Chatter/Developer Jive @ #bigbrother (Moved so my build notification bot has an easier time notifying multiple channels)

    BigBrother 1.11.0 Changelog
    • Centralize and update bystander checks.
    • Fix parsing errors in DeltaChest
    • Clarify /bb log
    • Fix sign lines being too far down
    • Add command censoring (for people worried about xAuth and the like)
    • Fix pagination capping
    • Fix an error in DeltaChest reading
    • Add ?autoReconnect=true to the MySQL DSN
    • Remove all H2 support
    • Removed /bb stick from /bb help since it is now obsolete
    • Fixed it so commands that work won't say commands not recognized after they already work
    • Fixed the issue of when you had the /bb log if you broke something it would not record the break even if you were watched
    • Now if the user tries to find the history of an invalid user it won't throw null errors.
    • Yell at the users if they don't follow the setup procedure
    • Should fix most of the errors dealing with the log and watch/unwatch problems
    • Update README
    1.10.0+ (open)

    BigBrother 1.10.1 Changelog
    • Fix a rollback SQL syntax error
    • Fix explosion logging
    • Clarify database trimming message in log
    • Fix /bb history
    • Continue rolling back incorrectly-logged BlockBurns, if the data field is unparsable, default to 0.
    • Fix Heartbeat logging
    • Fix SuperPerms support.
    BigBrother 1.10.0 Changelog

    New Features:
    • Brand new plugin API! (Wiki)
    • Database change. There is now a converter, but you might still lose data!
    • Compact chest changes: (+Added)(=Replaced)(-Removed)
    • Heartbeat Action: Logs users online and the current time, both to keep your database connection open, and for monitoring of your server's uptime!
    • Piston Actions!
    • Bukkit Superperms support!
    • RB 1000 support!
    • /bb history!
    • Formatting fix for rollbacks
    • A buttload of NPE fixes

    • [BB-81] Rollback doesn't work because of empty data-values
    • [BB-78/BB-69] onPickupItem/onDropItem NPEs
    • Memory leak fix (Thanks to Wootalyzer!)
    BigBrother 1.9.1:

    • Use BlockSpreadEvent for tracking fires (later told by EvilSeph that there's no current way to track fire in Bukkit)
    • Display a "Permission Denied" to users trying to use commands with insufficient priviliges instead of silently failing.
    • Add /bb mowlawn.
    • Fix stupid mixup between String.format usage on C# and Java in DeltaChest
    • Automatically update plugin.yml via Maven (internal crap)
    BigBrother 1.9

    • Support for 928+
    • NEW: Lava/Water/Fire flow logging (AND ACTUALLY TESTED, FOR ONCE!)
    • NEW: a: directive for rollbacks, for specifying comma-delimited action IDs to track
    • Lots and lots of bugfixes.
    • Marginally better H2 support
    • More automated tests
    • Standardized QA tests (ongoing)
  2. Offline


    Well yeah, I downloaded that. Then when I replace my old BigBrother.jar with that one, it still didn't recognise the commands ingame.
  3. grr... a messed up config from the default settings? :( i guess i need to find out a way to uninstall mysql, and then re-install it...
    is there any way to manually test a connection? (so far i've done phpmyadmin [works], basic php connection scripts [works--doesn't require port], and basic connection with command line, which didn't require ports)...

    i'm thinking its a problem with the port connections... but i'm pretty new with server stuff like that
  4. Offline


    Hey guys, I am on all the most recent versions of the software, and am receiving this error.
    2011-04-19 22:04:27 [SEVERE] [BBROTHER] Possible cause of previous SQLException:
    org.h2.jdbc.JdbcSQLException: Value too long for column "DATA VARCHAR(500) DEFAULT '' NOT NULL SELECTIVITY 2": "'7b303a343a2b36343a303a303b313a31353a2b31373a303a303b323a333a2b36343a303a303b333a31333a2b31343a303a303b383a3237323a2b313a303a363... (728)"; SQL statement:
    INSERT INTO bbdata (date, player, action, world, x, y, z, type, data, rbacked) VALUES (?,?,?,?,?,?,?,?,?,0) [90005-153]
        at org.h2.message.DbException.getJdbcSQLException(
        at org.h2.message.DbException.get(
        at org.h2.table.Column.validateConvertUpdateSequence(
        at org.h2.table.Table.validateConvertUpdateSequence(
        at org.h2.command.dml.Insert.insertRows(
        at org.h2.command.dml.Insert.update(
        at org.h2.command.CommandContainer.update(
        at org.h2.command.Command.executeUpdate(
        at org.h2.jdbc.JdbcPreparedStatement.executeUpdateInternal(
        at org.h2.jdbc.JdbcPreparedStatement.executeBatch(
        at me.taylorkelly.bigbrother.datasource.DataBlockSender.sendBlocksSQL(
        at me.taylorkelly.bigbrother.datasource.DataBlockSender.access$000(
        at me.taylorkelly.bigbrother.datasource.DataBlockSender$
        at Source)
    2011-04-19 22:04:27 [WARNING] [BBROTHER] SQL send failed. Keeping data for later send.
    Not sure what is creating the error.
    I also get this one every time on startup.
    2011-04-18 00:23:20 [INFO] [BBROTHER] ------------------------------------
    2011-04-18 00:23:20 [INFO] [BBROTHER] Hello, and thank you for using the TESTING version of BigBrother!
    2011-04-18 00:23:20 [INFO] [BBROTHER] Please note that, since this is far from complete, there will be many bugs.
    2011-04-18 00:23:20 [INFO] [BBROTHER] Please stay tuned in #bigbrother for updates and build notifications.
    2011-04-18 00:23:20 [INFO] [BBROTHER] ------------------------------------
    2011-04-18 00:23:20 [INFO] [BBROTHER] Building `bbdata` table...
    2011-04-18 00:23:20 [INFO] [BBROTHER] BBData H2 Driver r1 loaded!
    2011-04-18 00:23:20 [SEVERE] [BBROTHER] Create World Table SQL Exception
    org.h2.jdbc.JdbcSQLException: Table "BBWORLDS" already exists; SQL statement:
    CREATE TABLE `bbworlds` (`id` INTEGER PRIMARY KEY,`name` varchar(50) NOT NULL DEFAULT 'world'); [42101-153]
        at org.h2.message.DbException.getJdbcSQLException(
        at org.h2.message.DbException.get(
        at org.h2.message.DbException.get(
        at org.h2.command.ddl.CreateTable.update(
        at org.h2.command.CommandContainer.update(
        at org.h2.command.Command.executeUpdate(
        at org.h2.jdbc.JdbcStatement.executeUpdateInternal(
        at org.h2.jdbc.JdbcStatement.executeUpdate(
        at me.taylorkelly.bigbrother.WorldManager.createWorldTable(
        at me.taylorkelly.bigbrother.WorldManager.<init>(
        at me.taylorkelly.bigbrother.BigBrother.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.d(
    2011-04-18 00:23:21 [INFO] [BBROTHER] Building `bbusers` table...
    2011-04-18 00:23:21 [INFO] [BBROTHER] Permissions enabled using: Permissions v2.5.5
    2011-04-18 00:23:21 [WARNING] [BBROTHER] 'Help' isn't detected. No /help support
    2011-04-18 00:23:21 [INFO] [BBROTHER] BigBrother 1.8-SNAPSHOT enabled
    Config file:
  5. does bigbrother require Mysql?
  6. Offline


    DOOR_OPEN still doesn't work for me. Well, sometimes it works, for some players, sometimes it doesn't...
    Nothing in the log, the event is just not logged properly.
    It's like that since the #326 if I remember correctly, maybe #332.

            lava-flow: false
            leaf-decay: true
            drop-item: false
            ip-player: true
            disconnect: true
            login: true
            pickup-item: false
            teleport: true
            tnt: true
            creeper: true
            misc: true
            commands: true
            chat: true
            chest-changes: true
            block-place: true
            block-break: true
            flint-logging: true
            door-open: true
            lever-switch: true
            button-press: true
  7. Offline


    [Edit] This is a reply to Whysopro on Page 6.. didn't saw page 7 xD But maybe this information is usefull somehow.

    If you're just about to install the plugin from scratch decide what storage format you can use or want use. I recommend using mysql if you can. See Downloading and Installing Mysql and then follow the Configuration Steps for Mysql.

    If you allready using this plugin and you want to upgrade from an older version shutdown your server instance. Make a full backup from your existing Mysql Database with mysqldump "mysqldump --opt -uUSERNAME -p yourdatabasename > backup-backupname_timecode.sql" (if you use Mysql) and Folder plugins/Bigbrother and BigBrother.jar. Download the latest Jar File and replace the file located in your plugins Folder. Starup the server again and see if its starting up correctly via console or via server.log

    If you have trouble see Troubleshooting + FAQ
  8. Offline


    Hey guys, I'm currently in the midst of finals. I'll get back to you after the shitstorm is over (later today).

    If you find bugs, report them on the bug tracker, please.
  9. Offline


    it is not required but recommended because if you dont you will have a huge amount of io access that can cause lags. Furthermore using a file and storing a huge amount of data isnt effective as well.

    That doesnt make any sense! netstat -tap (i prefer netstat -tulpen) will show you protocol, local, state, pid/program name. In this case mysql is listening on port mysql (service name) with PID 28537 program name mysqld.

    The PID is the Process ID not Port ID or something else. In addition you should always use at least netstat -nat as it will not translate port numbers or ip adresses to service names/dns like mysql (which is port 3306)

    This is also not correct. PHP function myslq_connect or PDO or mysqli requires a port! every connection does. But you dont have to specify it IF you have a default mysql server installation. it will then fallback to its default port 3306.

    Although the command line client mysql will open a connection with default port 3306 (service name mysql) if you dont specify the port.

    I think your configuration is messed up. As far i know you cant do anything wrong if you did install the mysql server through apt-get or aptitude and did finished the installation. As you said phpmyadmin is working. What username do u use? Did you grant database access to your created username? Is your minecraft server running on the same machine or remote?

    I would delete the whole database and user and restart mysql. Then do the following:

    - stop your minecraft server
    - Login to phpmyadmin as root with password
    - go to Rights
    - click on new user
    - click under "Database for User" the third (the one saying username\_%)
    - choose a username like minecraft and fill out password or generate one.
    - click OK
    - this user now has full rights to all database named usernamechosen_* (in this case minecraft_*)
    - create a database usernamechosen_bb (this case minecraft_bb)
    - restart mysql if you want
    - configure BB as stated on WIKI (username, password, connectiontype mysql)
    - start the minecraft server and see what happens
  10. Offline


    if i use bb rollback i have to wait very long until its rollbacked, is this normal?

    and sometimes it says rollbacked but nothing happened
  11. Offline


    @KevGraf94: what is "very long"? 5/10/20/40 seconds or an hour? .. It depends: if you use a non-dedicated server i.e running on your local machine and your machine is not that fast it will take time because of the IO (no mysql running). If you have a crappy hard drive this will decrease performance too. RAM is also a reason. If you use mysql and you're running it on a dedicated server make shure this machine has 2 GB RAM at minimum and uses a processor that runs at least 2,1 GHz or one step below. A Pentium 4 or an AMD Athlon >= 1,8 GHz should be okay for a dedicated machine.

    If nothing happend there should be something in your server.log that indicates a timeout shortly after or before the message.
  12. Ok... i followed the procedures (created new user/databaes, etc etc), and started again, and i got this error when starting again:

    [SEVERE] [BBROTHER] Error getting a connection. Make sure your database settings are correct!
    com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
    Last packet sent to the server was 0 ms ago.
    Caused by: Connection timed out

    Then, just out of curiosity i did the netstat as you said, and i got this::
    root@mc1:~# sudo netstat -tulpen | grep mysql
    tcp        0      0*               LISTEN      0          3286669769  15777/mysqld
  13. Offline


    @stargateanubis14: *headtodesk* sry to blame you and thanks that you did a complete redo of this ... It just appeared in my mind ....

    i think you use a startup script for minecraft like "su - username -c ...." with java options.... add this to your startup command after the java call "" (without quotation marks)

    if those are encapsulated in quotation marks you maybe want to escape the equal sign like\=true

    This should do it. Its using the ipv6 stack instead of ipv4 ....
  14. sorry for double post (it wouldnt' let me edit the post)...

    for some reason, when i removed the mysql connector jar from teh minecraft server directory, it didn't re-download, or even notice it was missing...
    not sure if that has anything to do with it, but it seems strange to me

    aaah... well, i'm using MCMyAdmin... so they start up the server... i'll have to get into their chat to see if they can help me get the server launching properly :)

    But even if it was an ipv4/ipv6 issue, why would it not let me connect to localhost, but let me connect to any other external databases? :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  15. Offline


    Naha now i know why u are using ubuntu instead of debian :p

    Thats an easy one =) if you type in the IP Adress directly it knows that this is an ipv4 format. Furthermore if you use localhost it is actually a hostname not a domainname.

    See your /etc/resolv.conf you'll notice that there are more than one localhost. One pointing to your ipv4 adress and one pointing to the ipv6 address. I wonder how you can connect to the server if ipv4 is not working correctly.

    Try to use the IP instead of localhost maybe that will do it.

    Is MCMyAdmin a wrapper or something that prevents access to not defined ports? I could imagine that it is a virtual machine that only allows access to configured ports. ie. the minecraft default port (configured in the config file?)

    Try the IP thing first ... and let me know if that helps.
  16. Offline


    Did you remove this line from /etc/mysql/my.cnf :
    # Don't listen on a TCP/IP port at all. This can be a security enhancement,
    # if all processes that need to connect to mysqld run on the same host.
    # All interaction with mysqld must be made via Unix sockets or named pipes.
    # Note that using this option without enabling named pipes on Windows
    # (via the "enable-named-pipe" option) will render mysqld useless!
    skip-networking must be commented out (or removed) for mysqld to accept tcp connections, even from localhost. All the bukkit plugins that use the mysql connector use tcp to connect to mysqld.
  17. @lycano
    yeah...i have already tested , localhost, as well as the server's 2 different IP's (as well as the domain name that i have pointing there).

    My my.cnf file doesn't have that line in the file. Instead it has this:
    user        = mysql
    socket        = /var/run/mysqld/mysqld.sock
    port        = 3306
    basedir        = /usr
    datadir        = /var/lib/mysql
    tmpdir        = /tmp
    # Instead of skip-networking the default is now to listen only on
    # localhost which is more compatible and is not less secure.
    bind-address        =
    All of that is default settings (not edited by me).

    EDIT:: commenting out skip-external-locking doesn't change anything connection-wise...
  18. Offline


    I think I have a problem and im not sure how to fix it. Can somone help me?

    2011-04-20 14:53:34 [INFO] Starting minecraft server version Beta 1.4
    2011-04-20 14:53:34 [INFO] Loading properties
    2011-04-20 14:53:34 [INFO] Starting Minecraft server on *:25565
    2011-04-20 14:53:34 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-659-gc210f22-b684jnks (MC: 1.4)
    2011-04-20 14:53:34 [INFO] Preparing level "world"
    2011-04-20 14:53:34 [INFO] Preparing start region
    2011-04-20 14:53:34 [INFO] 144 recipes
    2011-04-20 14:53:35 [INFO] Preparing spawn area: 32%
    2011-04-20 14:53:36 [INFO] LWC    Loading shared objects
    2011-04-20 14:53:36 [INFO] LWC    Native library: plugins/LWC/lib/native/Windows/x86/sqlitejdbc.dll
    2011-04-20 14:53:36 [INFO] [BBROTHER] ------------------------------------
    2011-04-20 14:53:36 [INFO] [BBROTHER] Hello, and thank you for using the TESTING version of BigBrother!
    2011-04-20 14:53:36 [INFO] [BBROTHER] Please note that, since this is far from complete, there will be many bugs.
    2011-04-20 14:53:36 [INFO] [BBROTHER] Please stay tuned in #bigbrother for updates and build notifications.
    2011-04-20 14:53:36 [INFO] [BBROTHER] ------------------------------------
    2011-04-20 14:53:38 [WARNING] [BBROTHER] Table bbdata uses the MySQL storage engine InnoDB.
    2011-04-20 14:53:38 [INFO] [BBROTHER] For optimal performance, we suggest changing to MyISAM via the following SQL statement:
    2011-04-20 14:53:38 [INFO] [BBROTHER]   ALTER TABLE bbdata ENGINE = MyISAM;
    2011-04-20 14:53:38 [INFO] [BBROTHER] Please note that, on many tables, this could take a very long time.
    2011-04-20 14:53:38 [INFO] [BBROTHER] BBData MySQL Driver r1 loaded!
    2011-04-20 14:53:39 [INFO] [BBROTHER] Updating tables for 1.7.2
    2011-04-20 14:53:39 [INFO] [BBROTHER] Importing users into new table! If this breaks, DROP your tables and restart.
    2011-04-20 14:53:39 [INFO] [BBROTHER]  * Stage 1/4: Rename the old player column to PlayerName
    2011-04-20 14:53:39 [SEVERE] [BBROTHER] Could not executeUpdate for importRecords(mysql) - Rename old player column:
    com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'player' in 'bbdata'
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at com.mysql.jdbc.Util.handleNewInstance(
        at com.mysql.jdbc.Util.getInstance(
        at com.mysql.jdbc.SQLError.createSQLException(
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(
        at com.mysql.jdbc.MysqlIO.sendCommand(
        at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
        at com.mysql.jdbc.ConnectionImpl.execSQL(
        at com.mysql.jdbc.PreparedStatement.executeInternal(
        at com.mysql.jdbc.PreparedStatement.executeUpdate(
        at com.mysql.jdbc.PreparedStatement.executeUpdate(
        at com.mysql.jdbc.PreparedStatement.executeUpdate(
        at me.taylorkelly.bigbrother.tablemgrs.DBTable.executeUpdate(
        at me.taylorkelly.bigbrother.tablemgrs.DBTable.executeUpdate(
        at me.taylorkelly.bigbrother.tablemgrs.BBUsersMySQL.importRecords(
        at me.taylorkelly.bigbrother.fixes.Fix5.apply(
        at me.taylorkelly.bigbrother.BigBrother.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.d(
  19. MCMA is a server manager ... Basically, McMyAdmin is a web interface and administration utility for the minecraft server. I was using it because it was giving me easy web-access to the console for when i'm unable to access the command line when away, and easy backups/scheduler/auto-saving, etc etc. (as well as a permissions management system that is built in, to be configurable with some of the bukkit permissions plugins)... its not 100% vital to myserver's operation, but it makes things 500% easier.

    while looking closer at what it does, it appears that it does use a virtual machine (i think)... i'll try to see if the creator has any further info.
  20. Offline


    @stargateanubis14: ill look forward to hear more from you.
  21. Ok... i just ran the server withotu mcma (basic startup of server), and i got the exact same issue... so its not a problem with mcma.
  22. Offline


    drop-item: true
    pickup-item: true
    Server start....
    Player Join
    Player Item Drop -> Error
    Player Item Get -> Error
  23. Offline


    I tried to activate pickup-item and drop-item events capture, but :

    2011-04-21 09:42:21 [SEVERE] Could not pass event PLAYER_PICKUP_ITEM to BigBrother
        at me.taylorkelly.bigbrother.datablock.PickupItem.<init>(
        at me.taylorkelly.bigbrother.listeners.BBPlayerListener.onPlayerPickupItem(
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.EntityItem.b(
    My version :
    2011-04-21 09:42:30 [INFO] [BBROTHER] BigBrother 1.8-SNAPSHOT enabled
    Thanks a lot.
  24. Offline


    @stargateanubis14: thats odd .... currently i dont have any issues with BigBrother. I removed all tables to force BB for recreation and nothing unusual happened. Maybe i have another snapshot of v1.8? Hmm well, i have work to do in the evening i could take a look at it again. Or maybe we can discuss this on I could logmein via ssh if you want and take a look at your log files in /var/log or your config.

    To debug this you can try to install tcpdump and listen on port 3306 on interface lo maybe youll see what happens.

    use "tcpdump -i lo -n port 3306" and look at the output. i would do that in a seperate ssh session via screen or login.
    if you have wireshark and you like to view it there then use
    "tcpdump -i interface -s 65535 -w youroutputfile.dump" before starting minecraft server and do your stuff .. if it is throwing an error. try to produce the error by reloading the server via reload twice a time. Then you have tree logs that you can diff against.

    This file can also be opened with wireshark to apply filters. Maybe that will bring up some usefull informations. Currently i dont know why its loosing connection as it recieved a packet 0ms before. I dont like Ubuntu because of its Apparmor and upstart stuff and i could easily say kick ubuntu and install debian but i wont xD

    Another thought: Ubuntu is using the latest mysql server. maybe the mysql client has another version or ubuntu has changed the mysql recieved package limit ... i did saw this happen to other packets ... ubuntu changes stuff and simply dont inform anyone about those "improvements". Well, sry for this offtopic stuff .. but there are too many possibilities =)
  25. Offline


    Anyone know if there's a php-script or similar to parse the tables into a readable/browsable format? Would be very useful for investigating outside of using in-game commands.

    If not, I might try making one. However, can someone explain to me what the "date" column in 'bbdata' is supposed to represent? It's not a date in any format I know of. (Actually looks like a counter in seconds, counting from an arbitrary large number.)
  26. If I'm not mistaken, that's UNIX time. Number of seconds since 1st Jan 1970
  27. Offline


    Ah, looks like it, yes. Thank you.
  28. Offline


    This Plugin looks like it does what you need and some.
    It says it is Compatible with all rollback plugins such as LogBlock, BigBrother but I have not tried it out yet but i plan to.
  29. Offline


  30. Offline


    @Perling: im not speaking for the author but i think he will do the same as announced on the news page "Stay on MC1.4 for a while and use the recommended build" which is currently #684. There are too many changes in MC1.5 anyone who wants to support "not recommended builds" have to create a branch for each of his plugins... i think that isnt efficient and it would consume much of anyones time. As long as there is no recommended build i think noone will update the plugins only to support the experimental branch.

    Do like the others. Stay on recommended build #684 (MC1.4) and be patient. MC1.5 is currently bugged like hell so i wouldn't care ...
  31. Offline


    Hmm, interesting, although it seems to be aimed as more of a replacement of BigBrother than a tool for it as it does it's own logging and have plans for /-commands, etc. Don't know if the "Compatible with all rollback plugins" means that it can actually display the data from BigBrother or simply doesn't break the plugins. Considering "Integration with BigBrother" is one of the planned features I would guess on the latter.

    Either way I will give this a try and see if I can't use some of the source for something simpler.
Thread Status:
Not open for further replies.

Share This Page