Discussion in 'Bukkit Help' started by JN_KING, Apr 23, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Ok so this is how it all went down. after watching about a bizzilon videos on how to set up a run.bat file on a 32bit machine none of it helped. I have tried to rename the Reccomend build to craftbukkit.jar but it still does nothing. So after 2hours of being pissed of i came here looking for a soloution. So if you could please help me out with is bug. Thanks!
  2. Offline


    type this into a notepad document:

    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre6\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit.jar

    and save this document as run.bat now place this file into the folder of your server. And then change the jar file of your build in your server folder to craftbukkit.jar
    now run the run.bat file and report what happens on here, error messages etc.

    P.S. what operating system are you using?
  3. Offline


    download bukkit gui from here

    download craftbukkit from here

    follow this 3 steps

    but if u really need/want to stay with bat files

    here are 4 different bat files

    1st u rename your craftbukkit.1.1.1.jar file to craftbukkit.jar

    than u put all of them in your bukkit folder and 1 of them will work for sure
  4. Offline


    My operating system is Windows xp

    Error message: Could not find specified file craftbukkit.jar
    so i go to my jar and rename it craftbukkit.jar nothing happens =(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  5. Offline


    Ok lol i so messed up i was naming the craftbukkit jar craftbukkit.jar but than it would save the name as craftbukkit.jar.jar epic fail right? so i just named that file craftbukkit and it worked! And i thank all of u who tried to help me!
  6. Offline


    Since your issue in the Bukkit Help forums is resolved, please change the prefix of your topic title to Solved by going to Thread Tools then 'Edit Thread'
  7. Offline


    I think I am having a similar problem. I dont actually have the run.bat file in the server folder. I have done what you said, and in the cmd, it says: The system cannot find the path specified.

    PS. I am using Windows 7
  8. Offline


    Thanks it helped.
  9. Offline


    im using 64bit and it give me this error the system cannot find the path specified
  10. Offline


    this thread is over 2 years old, but to fix your problem:

    I'm assuming you have java 7 installed on your machine so where it says

    change jre6 to jre7

    EDIT: What operating system are you on?
  11. Offline


    Well if you are using that batch file, no wonder. Part of it are for Linux, other parts for Windows.
    If your batch file is not sitting with the .jar it won't work because it cannot change to the folder with the craftbukkit.jar

    If you made the following folder:


    And put "craftbukkit.jar" in that folder, this is what a good-working batch file would look like for a Java JRE 1.7 installation:

    CD /D C:\Craftbukkit
    "%ProgramFiles%\Java\jre7\bin\java.exe" -XX:MaxPermSize=128M -Xmx1024M -Xms1024M -jar craftbukkit.jar -nogui
    If your server folder is elsewhere, simply update the path to the correction location where you see:
    CD /D <>
    But make sure your path is not inside "Program Files" due to UAC Security issues and that your path does not contain special characters such as an apostrophe which would make java a bit upset.

Thread Status:
Not open for further replies.

Share This Page