[RPG/WGEN/ECON/FUN] RpgEssentials Beta 1.4.5 dev [1.5.2-R0.2] [Spout]

Discussion in 'Archived: Plugin Releases' started by Duckdoom5, Feb 8, 2012.


What should be added next?

  1. Grow able corps/bushes

    12 vote(s)
  2. Global banking system

    48 vote(s)
  3. Death chest with timer

    20 vote(s)
  4. Oven for smelting of custom ores

    19 vote(s)
  5. Party system with HUD

    88 vote(s)
  6. Showcases with item inside

    16 vote(s)
  7. NPCs with questing system

    187 vote(s)
  8. Leaderboard

    17 vote(s)
  1. Offline


    Thanx :D.

    In 1.3 I focusing on expanding and fixing current features. 1.3 will contain custom stores for example.
  2. Offline


    Ooo that'll be interesting to see quite a few of us are looking forward to using the checkin/checkouts once the server starts up. Speaking of expanding and fixing I have a question, does that include expanding on the leveling system? Like the Smithing skill doesn't have a set of unlockables.
  3. Offline


    Awesome Plugin ! Is there any problems while enabling RpgEssentials + iskin/citizens/jobs ?
  4. Offline


    Umm im having a problem all the new ores and items are showing up as flint, the store works but is invisible what do i do??
  5. Offline


    it does include expanding/fixing leveling, although it doesn't add smithing unlockables YET. I'm not sure if I will add it this release, but it will be added soon.

    nope, not anymore. the npc command is changed into /rnpc ...

    1. update you spout + spoutcraft to dev versions. how? check the FAQ page on the dev bukkit page.

    2. delete your items.yml and your blocks.yml

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  6. Offline


    Thanks for the response. Looking forward to it ^_^.

    Recently there has been a small query about RPG-E from someone on our forums. While back you had a to-do-list on this page but it's gone and the list on the Dev page doesn't say anything about a class system. I was wondering if there was still going to be one?
  7. Offline


    I am having problems getting your custom map generator working i've done what is said on the Generator link but every time i edit the bukkit.yml it reverts back when loading a new world Please if you could help me we really want to see the new ore in our world.

    Edit: Ok so my roommate was able to fix it i'm just know good at this stuff
    but there is something he told me Is there something wrong with the items made by the special ore he tried using an adamantine Pickaxe but it wouldn't brake the blocks
  8. Offline


    Yeah, there will be.

    the custom tools don't work because of spout limits, only the sword works

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  9. Offline


    Ok thank you This is a great plugin by the way keep up the good work
  10. Offline


    I have custom blocks from another plugin but they now appear as flint. How to fix it ?
  11. Offline


    I think: update your spout plugin and spoutcraft to dev versions
  12. Offline


    Hey guys, im really loving your plugin and i was wondering about some modifiable parts:
    Am I able to change the droprate and values of coins?
    Also, is it possible to change the exp values needed per level?
  13. Offline


    You will be able to change this in the future.

    Yes, this is possible, in the leveling.yml change the "exponent" value
  14. Offline


    Thanks! whats the calculation in terms of the exponent?
  15. Offline


    xptolvl += (int) Math.floor( Math.floor( ( Math.pow(2.0, (currentlevel/exponent)) * (currentlevel + 300) ) ) / 4 )

    = (2.0^(currentlevel/exponent)) * (currentlevel + 300) round down, /4, round down
  16. Offline


    Thanks, sorry one more thing, could you add a "max level" option in the config? thanks again
  17. Offline


    Hi there, great Plugin!

    We've got only one problem: When I press "l", the bg renders and the level menu shows up. When i close the level menu and try to open it up once again, nothing happens. The PC isn't a problem, because a friend has a high-end computer and he has the same problem, too. Our Server runs the latest dev build of spoutcraft and also the latest RPGEssentials Version.

    Edit: Just found out that it only works correctly when i close the menu with the esc - button on my keyboard. But if i close it with the close - button in the menu, i can't open it up once again.

    Edit2: The combat level seems not to increase. It's always on 3.

    Edit3: Could you maybe explain how to make customshops? I saw something about that in the changelog :D

  18. Offline


    Sure, I will add that

    I know about that bug, I will try to fix it.
    Edit: It will be fixed in 1.3

    2: It only does when you lvl up in def, range or atk

    3: sorry it doesn't work yet

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  19. Offline


    Greetings another problem has arisen with RPG-E on our server. When setting up capes we've came across a problem that may be caused by an incompatability issue between RPG Essentials and Spout Essentials. So we were wondering if there was actually any compatabiltiy issues between the two plugins.

    In addition we played around with things and got rid of Spout Essentials, but even then when the cape is successfully changed. It won't show.
  20. Offline


  21. Offline


    Uh I don't exactly get what your getting at in your response Duckdoom >.<' did you want me to add the link to SpoutEssentials or the specific cape?

    Though there's been a bit of a change, I asked the same thing in their DevPage but it appears they may be inactive so we're deciding to ditch that and just go with RPG-E. So now the our query is:

    We can change the capes and it'll successfully to it, but they won't show up.

    Additionally, could you give a link to a cape that you know has worked in the past?
  22. Offline


    what version of spout does this pluggin play well with? i updated spout and now it wont load


    thnx in advance :)
  23. Offline


    please post the link you use for the cape. It is probably a wrong link.

    ex. link: http://dl.lynxdragon.com/rpgessentials/capes/Banker.png

    (For dropbox: remove "?dl" at the end of the link)

    it seems like they removed that method, so I will edit that in 1.3, for now you should use a lower version

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  24. Offline


    The link we are trying to use is http://i.imgur.com/Np6UI.png which RPG-E confirms as to have worked however it won't show up ingame.

    Also we tried to see if the link you provided would work and it just results in an error.
  25. Offline


    You sure that is a direct link? Becuase you have to use a direct link.

    Please show me the error

    I will make the links more secure in 1.3 that way it won't tell you its set unless its actually set

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  26. Offline


    I really need help with getting the plugin on my server when i download it it wont lad on to my server..... PLZ help
  27. Offline


    Did you have spout plugin?
  28. Offline


    nvr mind i got it
  29. Offline


    Any quick fixes coming for Spout build 1244? Nothing from the plugin seems to work on that build. Not sure if it's something I did wrong, or the plugin needing a fix.
  30. Offline


    If you can help me test on the new build then there could be a new release today!

Share This Page