Inactive [RPG] The MineQuest v0.61 - RPG System with Customizable Quests, Classes, and NPCs [1000]

Discussion in 'Inactive/Unsupported Plugins' started by jmonk, Mar 14, 2011.

  1. Offline


    MineQuest - RPG System with Customizable Quests and Classes
    Version: 0.62-test
    MineQuest started out as a plugin to add some RPG-like progression to Minecraft. It had 8 (By default, now completely customizable) character classes (4 Combat, 4 Resource - also by default) and you gained experience by doing tasks related to the class (e.g. Warriors fight with a Sword, or WarMages cast WarMage Spells). All combat classes gained health when they went up in levels, and all classes gained related abilities at certain levels.

    An example of a custom class configuration is now available:

    Now MineQuest has grown to be a much bigger project than gaining abilities and extra health. It includes mobs that get harder over time based on a level adjustment (determined by active players in the server). It has built in economy(iConomy Supported)/town systems that are available if people so desire. Most likely the coolest thing so far is the quest system.

    Good Places to start in game are /minequest, /cubonomy (economy), and /quest (questing specific). Also poking around the help pages (Linked as more information below) gives some details about more advanced commands as well.

    MineQuest is equipped with a system that is being developed so that minecraft can have real instanced dungeons where a select party can teleport into a world that has traps, harder monsters, and special loot. When complete players are brought back to their original locations.

    These quests are completely customizable as they only load from a text file. MineQuest will search the bukkit directory for the appropriate .quest file when the quest is started. This means that anyone running a server could write a quest. Not just plugin developers!

    The spell system is nothing special, and I'm sure that others exist out there, but what really makes MineQuest unique is the complete package, dungeons and everything.

    MySQL or SQLite

    Suspected Conflicts:
    Towny, Essentials Spawn, World Guard, mcMMO,
    Other plugins that modify damage/health

    This is a video of the first real dungeon created, the first time through

    MineQuest 0.40 Trailer -


    Whats new in 0.60?


    Please read the following FAQ before posting your question. It will help you out by getting the answer faster and help us out by having a smaller volume of questions.
    There are some forums on the MineQuest site found below.
    If you cannot solve your issues in the MQ Forums and from the FAQ and the bug does not already exist please post it on the bug tracker.

    More Info:
    Information about MineQuest and its features

    Version 0.61:
    *NPC Fix Item Properties (Blacksmith Capabilities)
    *Fixed Ranged Ability Bindings
    *Other NPC Property changes
    *Bug Fixes
    Version 0.60:
    *Idle Quest System
    *Main World Scripting
    *Reputation System
    Version 0.53:
    *Fixed Instancing System
    *Fixed NPC Respawning Issue
    *Updated to b860
    *Fixed money naming
    *A couple hidden features

    Full Changelog:

    If you love MineQuest then help keep the project alive:
  2. Offline


    Eyh guyz, i just discovered and it looks great ! But before testing it, i got some questions. I'm looking into the site but i cant find any answers.
    -> i see that the plugin is compatible with Iconomy. is it compatible with Essential Eco?
    -> Since the 0.40, you added the NPC trade sign. Are the players allowed to add their own trade sign? Like Essentials?

    Thx for your answers !
  3. Offline


    It does not use essentials economy. It has its own economy you can use, or you can use iconomy.

    And in my experience, Essentials causes problems with MineQuest
  4. Offline


    I added the new line and saw no change. I even leveled up and saw no increase past 20 health :(
  5. Offline


    Kelvorn, you can't have the asterisk. The previous advice was incorrect, but the problem remains the same. That asterisk denotes ALL permissions. So if you have a permission that denies access to something (like this plugin has) than as an admin with the * you will have it too. Take a look at my sample permissions.
            default: false
                prefix: '&4'
                suffix: ''
                build: true
                - Moderator
                - 'iConomy.*'
                - 'permissions.*'
                - 'MineQuest.Quester'
                - 'MineQuest.Abilities'
                - 'MineQuest.Mayor'
                - 'MineQuest.Command.Quester'
                - 'MineQuest.Command.Town'
                - 'MineQuest.Command.Merc'
                - 'worldguard.region.*'
                - 'logblock.*'
    Note that you can't use MineQuest.* because that will also include the normal health permission.
  6. Offline


    As much as its going to be a pain in the butt to add all those permission codes, it WORKED!!!! Thank you, the days of fearing my lvl 4 warmage players of one shotting me is over :D
  7. Offline


    Ive tried searching around and i was wondering if theres a way to actually turn off the supermobs, one of the things ive got on my rpg map is a sort of temple which players have to do certain challenges in order to get through, one being where they do have to fight mobs while trying to find 2 buttons to open the door to proceed to the next level but with supermobs enabled, when a "super" spider spawns and uses the trap ability it actually causes a hole to appear and makes a sort of shortcut through to the next level which defeats the purpose of the challenge.
  8. Offline


    A quick method is to set the Super flag in your quest file to False. Looking for another solution now though give me a moment :)

    Yeah, when you call:

    Event:id:EntitySpawnerNoMove:delay ms:loc x:loc y:loc z:type:super
    Just make sure the last word in the entry is false and super's should not spawn.
  9. Offline


    Erg :/
  10. Offline


    Okay I bet you guys have heard this before but I cannot heal my character from eating. I have disabled both the health and mana system and I still cannot heal my character from eating something like cooked ham. I can heal by using the heal spell however.... I have taken essentials and essentials spawn out of my plugins folder and I still cannot heal...
    Here are my plugins:
    All I want is the abilities and the questing system to work. I dont need the health system because of AdvancementStandalone (I have also taken that plugin out but I still cannot heal using pork or any other substance.) Please Help! Thanks in advance. I am also running the 953 bukkit with the devs build of 0.60 on the forums if that helps. Thanks again.
  11. Offline


    I haven't upgraded to 1.7 yet on my server, but in my experience with this plugin, I've noticed two conflicting plugins in your list. Worldguard definitely causes some issues, it doesn't seem to be the same for everybody, however it does have some control over the health system, which causes conflicts with minequest. Also, I see that you're also using Advancementstandalone... while it's a cool plugin, trying to use minequest with it is sure to cause some conflicts. MineQuest is kind of designed to be an all encompassing plugin, and jmonk & team adds requested features fairly often. They will not divvy the plugin up into seperate plugins for certain features, as I've seen this question asked and shot down multiple times.

    So the best thing to do is to take a look at what the plugins affect, then compare to what other plugins you are using affect, and remove any plugins that kind of do the same thing. (Where most plugin conflicts come from)

    I will post my list of plugins so that you can see what I have running with minimal bugs, though I am using cb860 with minequest .53, so there may be other bugs in the dev version.

    Now on my server, there is a bug where if you stand absolutely still, a skeletons arrows behave a little funny. They will appear to bounce off you, and no visible damage is taken. If you use /health however you will see that each arrow is indeed dealing damage. Once you move the damage is dealt all at once and if you were reduced below 0 it will kill you. This bug seems to be fairly isolated to my server and a couple others I've seen report it on this thread. We believe the culprit is worldguard, or possibly a configuration setting.. (never heard back from Ltan regarding this).

    In regards to your food issue, I believe it's probably from minequest and advancementstandalone being used together which is most likely causing this bug.. since both plugins have a health system, they are both watching for use of food items, and the trigger is being sent to the wrong plugin. This is just a guess as I'm in no way an experienced java developer or have anything to do with the writing of either plugin, this is pure server admin experience talking.
  12. Offline


    Thanks so much for the fast reply but in my previous message I thought I said that I have tried taking AdvancementStandalone out of the plugins folder but I was still not able to heal with food. I also tried to take World Guard out earlier and I still wasn't able to heal by eating.... Maybe it is a bug in just Minequest 0.60? Or maybe I screwed the config up. Heres what the general.prop looks like at the moment:
    #Tue Jul 05 21:19:44 MST 2011

    I'm going to try MineQuest 0.53 and see if it has the same issue as the dev 0.60 so I'll probably edit that in somewhere once I test it. Thanks again for the reply to my previous question.
  13. Offline


    I actually looked at this and it looks like it is a problem of the combination of mq_health_system being false and trying to eat food. Something I have overlooked for quite a while evidently, good catch. Can you try out another dev build and let me know if it solves the problem?
  14. Offline


    Sure anything for this plugin! Ill try it right away! :D

    Thank you so much Jmonk. Works perfectly! Can't wait until the official 0.60 MineQuest! Well thanks for fixing this for me. My members on my server will be pleased with being able to heal again. :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  15. Offline


    You can. I do it. The asterisk denotes all permissions, but you can revoke specific permissions from the * by putting a minus in front of the name, i.e. - '-MineQuest.NormalHealth'.

    The minus inside the quotes (in addition to the one in front) is very important, it changes it from granting the privilege to revoking it. It also might have to come after the * in the file, not sure about that.

    Also, no idea what Permissions version added that, I'm using the latest (3.1.something). Older versions may or may not support it.
    Makraiz likes this.
  16. Offline


    when will 0.60 be released?
  17. Offline


    Aww crap... It seems that what I said before about it being fixed was false.... When I tested the devs MineQuest.jar you gave me I forgot to delete the 0.53 MineQuest.jar.... So it loaded the 0.53 .jar instead of the 0.60 .jar..... Sorry for giving you misleading information.
    Here is what my comp says when I try that file all by itself:

    16:21:13 [INFO] [Minecart Mania] MinecartManiaStation version 1.2.5 is enabled!
    16:21:13 [SEVERE] Error occurred while enabling MineQuest v0.6 (Is it up to date
    ?): org/monk/MineQuest/Ability/MineQuestVersion
    java.lang.NoClassDefFoundError: org/monk/MineQuest/Ability/MineQuestVersion
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(Unknown Source)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at Source)
    at Source)
    at$000(Unknown Source)
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at org.monksanctum.MineQuest.Ability.Ability.getVersion(
    at org.monksanctum.MineQuest.MineQuest.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.ClassNotFoundException: org.monk.MineQuest.Ability.MineQues
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 25 more
    16:21:13 [INFO]

    Sorry jmonk for not paying any attention to my plugins folder.... I hope you can fix this easily and it wasn't a big setback.
  18. Offline


    I suspect the issue you are seeing is related to your abilities.jar. Normally in updated versions of MineQuest it will auto download the file, however with the dev versions it will not. Try downloading the abilities.jar from the dev section info page on and put it in MineQuest/. Should fix the error you are seeing.

    Just a heads up, the newest dev should be working with 1.7.2 at this point.
  19. Offline


    Sorry if this is getting anoying... Yes the new abilities fixed that error.... But now I cannot heal with food again. On the positive side of things skeletons arrows actauly hit me now and cause damage but sadly I cannot heal with food when I try to turn the minequest health system off in the Also I don't know what causes this but for some reason creepers don't do player damage. I got rid of WorldGuard and they do block damage but not physical character damage. Im assuming its another weird bug in the devs minequest. Hopefully its nothing hard to fix. Well thanks for putting up with my nonsense jmonk GL on 0.60 MineQuest! I still can't wait! :D
    Makraiz likes this.
  20. Offline


    Ah!! I was completely unaware of this, I will test it with my Permissions.. I think I'm using 3.1.4

    It sure seems like the minequest community is growing ^_^ I'm very happy to see this. jmonk and team your plugin rocks. Please don't ever let this become inactive only a few months to go before the official release of minecraft and we can stop worrying about all these server breaking patches.

    I've been so excited about the .60 release that I check this thread more often than I actually play minecraft.
  21. Offline


    im putting this in now cant wait, looks like mcmmo will be getting replaced
  22. Offline


    your avatar is a kitty :)
    looks cool ill try it.
  23. Offline


    I agree, Minequest is the best thing that has happen to my players and I. And with the help of Ltan, I will be able to post many of the quests I am making for my players so everyone can add them if they see fit.
  24. Offline


    MetalMan27: sorry I missed you in the irc channel. I was watching TV and not paying attention.

    I wouldn't worry about the creeper damage, that sounds like bonus! :D

    I will go and try the no heal issue on my server now :)



    MetalMan27, I was able to reproduce the no heal with food bug using the latest MQ0.60 and CraftBukkit 1.7.2. I am only running MineQuest at the moment so I am pretty sure the issue is something there unfortunately.

  25. Offline


    Ohh so thats what that is. Thats sick! So if I needed help in coding quests you guys would be there? Sweet. Well I hope you guys solve both of the issues. Sadly no creeper damage to players isnt a bonus for my server since I sorta need creepers to damage objects and players in some of the multi world quests I am expecting to make :/ but it will probably be fixed easily.... Eventualy. Hopefully. Well thanks for the reply Ltan!
  26. Offline


    It's mentioned briefly in the Permissions wiki page on writing settings, one short paragraph hidden in a wall of text, easy to miss. :) Should certainly work in 3.1.4 though.

    That would be great if you could! I'm sure I'm not the only one who would grab them as quickly as possible. :)
  27. Offline


    Is this plugin 953 compatible?
  28. Offline


    It does work with CB0953, however there are a few bugs that are being worked on at the moment.

  29. i need to put it off becouse it lagged the server and crashed it but it was a pleasure to use it in the short frame the server didnt crashed but it is much to resource hungry. I hope you look into making it less resource hungry and I will give this a try again once it reached 1.0.
    Thanks anyway, keep it up jmonk.
    Great plugin!
  30. Offline


    By comparison to some other plugins it is a little resource hungry, but it does A LOT more than any other plugin I've ever used. However.. it is running pretty good on my server. I run it on a dual core amd x2, with only 4gb ram.. of which only 3gb is dedicated to bukkit. I also run a script which reboots bukkit every 6 hours or 4 hours when it gets a bit closer to midnight at which point the script runs a complete back up. You may want to look at optimizing your server to run java/bukkit a little more efficiently.
  31. Strange i host on a AMD quad with 16gb ram, however it always started lagging out after a while.
    With mcmmo i have no such problems. Yeah i know it has awesome features and more than any other RPG plugin becouse i used it 3 months.

Share This Page