Inactive [RPG] The MineQuest v0.61 - RPG System with Customizable Quests, Classes, and NPCs [1000]

Discussion in 'Inactive/Unsupported Plugins' started by jmonk, Mar 14, 2011.

  1. Offline


    MineQuest - RPG System with Customizable Quests and Classes
    Version: 0.62-test
    MineQuest started out as a plugin to add some RPG-like progression to Minecraft. It had 8 (By default, now completely customizable) character classes (4 Combat, 4 Resource - also by default) and you gained experience by doing tasks related to the class (e.g. Warriors fight with a Sword, or WarMages cast WarMage Spells). All combat classes gained health when they went up in levels, and all classes gained related abilities at certain levels.

    An example of a custom class configuration is now available:

    Now MineQuest has grown to be a much bigger project than gaining abilities and extra health. It includes mobs that get harder over time based on a level adjustment (determined by active players in the server). It has built in economy(iConomy Supported)/town systems that are available if people so desire. Most likely the coolest thing so far is the quest system.

    Good Places to start in game are /minequest, /cubonomy (economy), and /quest (questing specific). Also poking around the help pages (Linked as more information below) gives some details about more advanced commands as well.

    MineQuest is equipped with a system that is being developed so that minecraft can have real instanced dungeons where a select party can teleport into a world that has traps, harder monsters, and special loot. When complete players are brought back to their original locations.

    These quests are completely customizable as they only load from a text file. MineQuest will search the bukkit directory for the appropriate .quest file when the quest is started. This means that anyone running a server could write a quest. Not just plugin developers!

    The spell system is nothing special, and I'm sure that others exist out there, but what really makes MineQuest unique is the complete package, dungeons and everything.

    MySQL or SQLite

    Suspected Conflicts:
    Towny, Essentials Spawn, World Guard, mcMMO,
    Other plugins that modify damage/health

    This is a video of the first real dungeon created, the first time through

    MineQuest 0.40 Trailer -


    Whats new in 0.60?


    Please read the following FAQ before posting your question. It will help you out by getting the answer faster and help us out by having a smaller volume of questions.
    There are some forums on the MineQuest site found below.
    If you cannot solve your issues in the MQ Forums and from the FAQ and the bug does not already exist please post it on the bug tracker.

    More Info:
    Information about MineQuest and its features

    Version 0.61:
    *NPC Fix Item Properties (Blacksmith Capabilities)
    *Fixed Ranged Ability Bindings
    *Other NPC Property changes
    *Bug Fixes
    Version 0.60:
    *Idle Quest System
    *Main World Scripting
    *Reputation System
    Version 0.53:
    *Fixed Instancing System
    *Fixed NPC Respawning Issue
    *Updated to b860
    *Fixed money naming
    *A couple hidden features

    Full Changelog:

    If you love MineQuest then help keep the project alive:
  2. Offline


    Well I put the and dungeon.tar files inside the plugins folder.
    Also in the plugins folder: combat_classes, resource_classes, and MineQuest-0.53.

    I made the map the dungeon.tar map...

    In the MineQuest folder I have a bunch of files produced by the abilities.jar file.

    I don't know what to do! When i typed /quest_start dungeon
    it says "you have no quest named dungeon".

    Please help! If any more info is needed ill give you as much as i can.


  3. Offline


    *Warning, slight off topic rant*

    I am sorry to do this, but I feel I must. This above line goes against all internet/forum etiquette. Making something large and red and yelling, as that is what caps means in case you didn't know, most often gets you an ignore by the people that you are asking for help. I am not the typical person though which is why I am posting this warning about it first.

    *End of rant*

    Ok, there a few problems with what you have stated that you are doing that might make the quests unavailable.

    Back in this post I posted a link to a youtube video that I did which tells you where to put what for the quest files to be found.

    Also, as of build MQ0.40 the quests were handed out by NPC's instead of just called by the /start_quest [questname]. You will need to setup the NPC property to hand out the quest when the NPC is hit by a player. This will then give you the quest and you will be able to use the start_quest command.

    Let me know if this fixes the quests not being available.

  4. Offline


    I am very sorry that I did that. I am new to the forums.
    *End of Apology*

    Thank you so much! The video worked! :)
  5. Offline


    No need to apologize :D As I said, I am not the typical forum [creeper]! That is why I gave the warning :D Welcome to the forums, and glad things worked out!
  6. Offline


    i really like this plugin alot, its near enough perfect sept for one issue, it conflicts with another plugin that i rather need :/
    performance tweaks with both installed i get errors reguarding chunks saved to minequest and npcs get randomly killed off :confused:

    ill not be the guy to say "make it work" or any of that lot but i will ask that if you just happen to find out how to make them go together it would be wonderful :)

    course that said it might be a fault on the part of the perfomance tewak plugin i honestly dont know
  7. Offline


    I really don't wanna be a total noob, but I have absolutely O experience with SQL. Can someone walk me through? thanks in advance.... :/
  8. Offline


    Walk you through what qore? How to setup MySQL, how to use MySQL, how to use phpmyadmin { a web based admin tool for MySQL }, how to use SQLite... I am at a loss for what you are in need of.

    I suggest you start here for sql :

    Or here for SQLite:

    For the record, you *do Not* need to use MYSql, something that has been stated through out this thread. I will also leave it to you to go back through the thread and find the SQLite editor that I have posted, simply because I am running late for an appointment and need to go now. :)
  9. Offline


    is it only me who cant take damage from skeleton archers and pvp damage is weird ?
  10. Offline


    does your pvp only do damage every other hit? or something strange like that?
  11. Offline


    On my server this bug only occurs if you stand absolutely still while the skeleton shoots at you. When you move the health updates and you die. He has stated in the past it behaves a little differently on his server, but I'm pretty sure the bug is related to some conflict between worldguard and minequest.
  12. Offline


    This happens to me occasionally, but I don't have worldguard... Oh well. I found Ltan's post with the SQlite... thing. I can't remember. But it worked like a charm :). Thanks Ltan, you make me wonder sometimes... how does he do all this.

    PS: I laughed at those links you gave me. :p

    Edit: But after I quit out after playing the first time for a while, every time I start the server now, it doesn't initialize/run MineQuest... do I need to delete the database to get it to run again? I'm open for flaming if this problem has already been solved earlier.
  13. Offline


    What are the errors in the console when trying to load minequest?

    Also, if you do want to use MySQL I found that this link has a good tutorial of installation/setup.
    I found that switching to MySQL had a performance boost with MineQuest
  14. Offline


    Running a CommandBook+WorldEdit+Permissions+Minequest as debug

    I cant hit another players correctly, some items heal them like wood spade an wood sword, and some, does damage like spells: Health is becoming negative (says the log) but it doesnt change at the users bar (im using MQ health system, but it doesnt get better later)
    Thus, the skeletons cant deal damage. The minequest health system is way buggy, why not remove it jmonk and make it a defence system where you absorb % of damage instead of having more life ? I stopped using MQ since this bug, cause i cant solve it, im really waiting to be fixed so i can use it, best plugin evah !
  15. Offline


    I was wondering if anyone could direct me on how to allow low level players the ability to use stone and Iron Pickaxes. I have looked at but couldn't find anything that I recognized as the answer.
  16. Offline


    You would have to go into the and modify the line that says:
    Changing the values to 0's will allow level 0 miners to use the different pick axes. These numbers have to be in the same order to correspond with the item ids in the
    Edit: This information was available on here for future reference.
  17. Offline


    Thank you so much found it right away :D
  18. Offline


    I am enjoying this plugin, was easy to setup and cant wait to get started on making some quests, my only problem is this, are there any actual admin commands? like to add experience to ourselves or would we need to level it up like a normal player? I have searched around but cannot find the answer i was looking for.
  19. Offline


    Not that I'm aware of. If you're good with sql tables you can go in and modify the values in the tables but that's the only way I know of to do that. Also, Ltan has a cheat sheet of commands somewhere earlier in the thread.

    Edit: Ah! Found it.
  20. Offline


    Is there a way that an Admin can remove a mayor from town? We were testing things out and now he is unable to move ownership back
  21. Offline


    I don't think so, you should have used /adduser to give build priviliges.
    It's easy enough to delete the town and make it again though.
    You should be able to use the command sheet of Ltan's that I posted earlier today.

    So after a couple days of testing minecraft .53, I have noticed my server is a lot more stable.
    The null messages have completely disappeared. So far I still have these bugs:

    Skeleton arrow issue - Standing completely still allows the skeleton to damage you into negative health. Movement will kill you if you allow yourself to go into negatives.
    Npc walk_message issue - Npc's appear to stop speaking after the server has been up for a length of time. They no longer disappear, but I wonder if there is still a memory related issue happening here.

    I haven't tested too much else yet. MineQuest is playing nicely with the following plugins:

    Edit: jmonk or ltan you are welcome to come experience the skeleton bugs for yourself on my server, send me a pm and I'll get you the connection info.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  22. Offline


    Thank you once again, for some reason he didn't have the Permissions to give it back, but once I gave him all of them he was able to. Lesson learned
  23. Offline


    Curse you Bukkit! I apologize to everyone that I have fallen short on replying to the posts. Bukkit has decided NOT to let me know when a post has been made.

    @Makraiz, Thanks for picking up my slack! :)

    The walk messages disappearing... Are these on none quest giving NPC's, or quest giving ones, and are these quests that you have finished already?

    I have the same phenomenon, except it is only with NPC's that have given me a quest and I have completed it.

    Concerning the kill on move issue. That is most likely WorldGuard. I had the random health issue a long time ago, mine was mcMMO, and WG. I dropped both and I have never been plagued again. Mind you that I am not 100% that your issue is absolutely WG though.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  24. Offline


    Good job im familiar with SQL then, im sure i could write a file to do that for me then and as for the command sheet, that will come in very useful too so thank you!
  25. Offline


    On the walk-message npc's, they are spawned with the spawn_npc command, however I have not given them any quests as of yet. I actually mainly use them to give the starting town a little bit of character. Since the town is under WG with pvp disabled, you can't actually hit them to get the hit_message. When the server first boots, they all give their walk_messages fine with no issues. I haven't been able to figure out what causes them to stop talking eventually, I've had it happen in 20 minutes, and I've had it happen in the course of several hours. I do intend on putting in quests eventually, however if the npc's aren't functioning correctly I'm afraid they won't be able to give out the quests.

    As far as the skeleton issue goes, I was originally under the impression that it was a wg conflict too, but qore mentioned yesterday that he has the bug and doesn't have that plugin, though his isn't consistent, while mine is. I'm starting to think it may have something to do with the deflect arrows skill, or some configuration we've set on our servers that isn't set on yours.

    I'd be happy to send you a copy of my config files if you'd like to check out that angle.
  26. Offline


    Go for it Makraiz. Zip them all up and send them to me: [email protected]
  27. Offline


    Alright it should be in your mail. If you reply to my email address just know that I don't really check that one very regularly, though I probably should lol. If you encounter the skeleton bug with these settings, I wouldn't know where to begin checking it, because I pretty much spent about 12 hours customizing this plugin to my liking when .52 came out :p
  28. Offline


    I have given my players Permissions for:
    - 'MineQuest.Abilities'
    - 'MineQuest.Mayor'
    - 'MineQuest.Command.Quester'
    - ''

    But they still are not able to /buyprop unless I give them '*' . So can anyone possibly point me in there direction of the correct Permission?
  29. Offline


    Well, I am not sure if this is just a typo in this forum, but the last one should be MineQuest.Command.Town. I believe Permissions is case sensitive.
  30. Offline


    that was what was wrong thank you. As I am sure you could tell I am just getting into this so I am still a noobCake. Thank you for your patience.
  31. Offline


    No worries Kelvorn! Welcome aboard!

Share This Page