Inactive [RPG/MECH] mcMMO v1.3.04 - RPG Addiction Redefined! Multi-Lingual! [1.2.4]

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Jan 8, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    mcMMO - The RPG Lovers Plugin


    Quick Links
    Latest Version: 1.3.3 (INFO, DL)

    We have moved to using our own JIRA install for tracking issues and have mostly
    completed the website. Both can be found in the links below. Most all support
    and bug tracking should now be done through the following link:

    Please use the mcMMO forums located at the mcMMO BukkitDev

    Dev Team
  2. update ur plugin and then it will
  3. Here is what comes up when trying to use Super Breaker. Using the latest mcMMO and the recommended 1.2.4 build.

    2012-03-30 11:04:43 [SEVERE] Could not pass event BlockDamageEvent to mcMMO
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockDamageEvent(
    at net.minecraft.server.ItemInWorldManager.dig(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet14BlockDig.handle(SourceFile:43)
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(
    at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.NoSuchMethodError: org.bukkit.event.block.BlockBreakEvent.<init>(Lorg/bukkit/block/Block;Lorg/bukkit/entity/Player;Ljava/util/List;)V
    at sun.reflect.GeneratedMethodAccessor33.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    ... 12 more
  4. Offline


    when you say latest... do you mean 1.3.04? if not, you should upgrade to that version. I don't see this on my server when using Super Breaker from 1.3.04 and CB 1.2.4-R1
  5. Apparently I was using 1.3.3. Was unaware that 1.3.4 had come out. Thanks for the heads up, that fixed it.
  6. Offline


    ah, ok.

    Perhaps update the Main Post --GJ-- or TheYeti please?
  7. Offline


    I would if I had the access to do so...
  8. Offline


    Im not dealing with that bug tracker again... It wont bother sending me a password reset. And I find it pretty crazy that a plugin has a better bug tracker than the game itself. So far its you guys and herochat that I have to go digging into the original post for some obscure link to a bugtracker website.

    Why dont you just use github issues like everyone else? Anyway here is the most rediculous error ever. about 500 lines of the same thing after every error.
  9. Offline


    We don't use Github because it's fairly limiting - posting attachments and other backend stuff is a real pain. Besides, you can post anon to the tracker if you don't wanna bother making an account. That said, not sure on an immediate cause for your bug, will look into it.
  10. Offline


    hi guys, is there any way to reduce or turn off the drop chances in mining

    since enchanting also gives more drops, players get like 4-6 diamonds per ore...
  11. Offline


    Yeah, you can give them the negative permission node -mcmmo.ability.mining.doubledrop
  12. Offline


    thnx :)


    why arent these permissions listed?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  13. Offline


    They're in the plugin.yml file. We do need to get them updated elsewhere though.
  14. Offline


    does this also stop the superbreaker ability from double/triple drops?

    i really need to reduce the diamond drops..
  15. Offline


    How do i clear the database?
  16. Offline


    Yes, it should.

    You want to wipe the entire database?
  17. Offline


  18. Offline


    I'll see what I can dig up for you.
  19. Offline


    Thank you so much, I didn't think to look in the plugin.yml.

    I LOVE mcMMO keep up the good work!
    --GJ-- likes this.
  20. Offline


    Hi, I seem to be getting the player's power level above my users' heads, is there any way I can disable this, as it's quite confusing for differentiating between different players, thanks.
  21. Offline


    That's not us - what other plugins are you running?
  22. Offline


    The only plugins that I can think of that could be causing this are Essentials, Mob Disguise and Spout. But it's definitely linked to mcMMO, the power level corresponds to the number on top of their head.
  23. Offline


    What build of mcMMO are you running? It may be an old one where the party HUD is still working.
  24. Offline


    603 latest dev build.
  25. Offline


    I want to know where is the database of player skills. After that i upgraded the plugin players had a reset i dont know why, can you help me?
  26. Offline


    <Snip, error was caused by human fault>
  27. Offline


    I have a problem i repair the enchant pickaxe and i lost my enchants . What command is it? please :(
    Sorry for all mistakes in my message - I don't speak English very good.
  28. Offline


    anyone use the dev builds for mcMMO? Just wondering how stable they normally are.

    Having issue with drop rates and I see that's fixed in the current DEV builds...
  29. Offline


    The dev builds are incredibly stable - it's generally assorted optimizations & bug-fixes that we don't feel warrant a new version yet.
    Cyberin likes this.
  30. Offline


    awesome, to the Dev builds I go, thanks :D
  31. Offline


    I'm getting this error
    [WARNING] Plugin mcMMO v1.3.04-b576 tried to register permission '' but it's already registered
    java.lang.IllegalArgumentException: The permission is already defined!
        at org.bukkit.plugin.SimplePluginManager.addPermission(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.t(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
Thread Status:
Not open for further replies.

Share This Page