[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Hey, I have a problem on my server. I installed mcMMO using clanforge but whenever anyone tries to use ANY command the errror message of "An internal error occurred..." shows up in red. If anybody knows whats going on i will be very thankful. I think it will probably have something to do with clanforge and so does my Admin.

    Edit: When i disable MySQL the only command we can use is /mcmmo . All other commands sitll get the error. Also, when I enter a command in the console it ends up showing this:
    Error executing: [mcMMO command] (Unhandled exception executing command 'mcc' in plugin mcMMO v1.0.49)
  3. Offline


    Make sure you didn't screw up anything in the config.yml. That yml s*** is sensitive.
  4. Offline


    Quick question about the MySQL database option.

    I am using it so I can also use the Webstats but I find when ever the server writes data to the MySQL server the server jitters a bit (if you are mining and your mining skill increases you will see one or two blocks come back)

    Is this caused by how the plugin uses MySQL or would it be caused by the MySQL server itself? Anyone else have this issue?

    I never had this happen when I used the Flat File option
  5. Offline


    Thought i should mention this, in the current build i have a total power level is about 250, and all of my cooldowns are 30 - 15 minutes or more, and i don't know why, its running on my server so i thought i might mention that :D
  6. Offline


    Installing bukkitcontrib didnt fix it.
  7. Offline


    Hey, first I wanna say, your Plug is wonderful :)

    but weve got some bad changes since we´ve got installed it with some othe Plugins together to get tzhe Server more RPG like.
    For permissions we use Permissions plus and the 1.15 version of Permissions (could that be the mistake? or is ther just any trouble with permission 1.16?)

    We´ve got installed XLevel too, is it maiby impossible to use your skillsystem with another together?

    To find the errorsource we´ve deletet already some plugins, but this little info would make it easier :-p

    The problem iss, the server crashes after a while and says read timed out...

    Maybe you´ve got an idea.. .thanks a lot :)
  8. Offline


    I'm not getting special sounds or popup messages.

    BukkitContrib Client Mod
    CB 1000

    BukkitContrib Settings:
    ForceSinglePlayerClientKickMessage: This server requires the BukkitContrib SP mod! http://bit.ly/bukkitcontrib
    ForceSinglePlayerClient: false
    AuthenticateTicks: 200
    AutoUpdate: true
  9. Offline


    Yea i must have screwed something up, I removed the config file and reset the server to generate a new one, and it works fine. However, when i try to change the options, its reverting back to theold settings when i put the server back online. For instance, what I'm trying to do in the config, is disable myspawn and hpregeneration. I simply set those values to false. Unfortunately, every time i save, then relaunch the server, it sets those settings back to default. If i open the config file back up, i notice it now says true for both values again. (Note, the server IS offline while im editing the files.)

    Thanks to everyone trying to help me so far!
  10. Offline


    What text editor are you using? I use Notepad++ and it works fine. It might not work with wordpad or normal notepad.
  11. bug!

    Our players are reporting that Green Thumb is not using Seeds in some cases...seems a bit random.
  12. Offline


    I've been using notepad, but i'll give notepad++ a try and get back to you.

    Tried with notepad++. Still didn't reverted back when i booted the server back up.
    (Btw, Notepad++ is amazing! Why haven't i used this before!?)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  13. Offline


    Only advice I got left is to try to make the config file read-only.
  14. Offline


    Deleting the config fixed the issue.
  15. Offline


    I am getting this error:
    2011-07-26 17:01:10 [SEVERE] Could not pass event PLAYER_QUIT to mcMMO
            at com.gmail.nossr50.Database.GetInt(Database.java:170)
            at com.gmail.nossr50.datatypes.PlayerProfile.loadMySQL(PlayerProfile.jav                                                                           a:124)
            at com.gmail.nossr50.datatypes.PlayerProfile.<init>(PlayerProfile.java:1                                                                           03)
            at com.gmail.nossr50.Users.getProfile(Users.java:103)
            at com.gmail.nossr50.Users.removeUser(Users.java:88)
            at com.gmail.nossr50.listeners.mcPlayerListener.onPlayerQuit(mcPlayerLis                                                                           tener.java:91)
            at org.bukkit.plugin.java.JavaPluginLoader$2.execute(JavaPluginLoader.ja                                                                           va:251)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav                                                                           a:58)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j                                                                           ava:332)
            at net.minecraft.server.ServerConfigurationManager.disconnect(ServerConf                                                                           igurationManager.java:146)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:608)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:231)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  16. Offline


    I figured out the problem, it was actually an issue with chown with the web server.
    Thanks for all the help nonetheless.
  17. Offline



    *cough* pvp balance.... *cough*

    Id also like to see anychanges you put to the prioritiy list I came up with.. Wondering if your even using it.. etc etc.. I wanna be able to help more but you gotta talk to me :p
  18. Offline


    hey do you get herbalism for breaking the crops, or just recieving them? I really want to make a auto cactus farm, but i dont know if i get herbalism or not
  19. Offline


    Making a Prayer Skill, hopefully, if nossr50 likes it, it will be added. I think it is very good in my opinion, but it isnt done yet. going to try to finish it tonight
  20. Offline


    when will we able to repair shears ?
  21. Offline


    I'm not sure what's going on, but I'm PermissionsBukkit and SuperPermsBridge. Somehow all users are able to access all commands related to mcMMO. This includes /mcgod and /mmoedit. I need some help figuring out what's going on.

    I've resorted to completely deleting my superpermbridge.mcmmo.blah.blah from my permissionsbukkit config.yml, but that didn't even work. I've disabled any commands that can cause damage in the mcMMO config for now.
  22. Offline


    i make korean language for mcmmo
    how can give to you?
  23. Offline


    @wpdudgh891 upload to one of the many free file sharing sites (ie: dropbox, megashare, rapidshare, etc), then give him the link.
  24. Offline


    nice work =) its good when users contribute <3
  25. Offline


    @fffizzz Thank you, I'm bringing more after modification.
  26. Offline


    Are there any know conflicts between this plugin and essentials? I installed essentials last night and now people are going up levels for mcmmo really fast. It seems that the leveling system is no longer working correctly. The two things I have noted so far causing this are that the total experience required to level up is sticking at what it should be for level 1 rather then lvl 40 so on so. The second was that for myself I had more experience total then that required to level so my char was unable to level but I think this is caused by the first symptom.
  27. Offline



    Modify end

    But not perfect.

    If you use this

    You have to Korean mode


    ※ Guide - Installation (it makes two files, ignore) - DOS window and enter: 1 - Yes (set recovery point) - end

    Ah, the server also have to patch the Korean mode

    Links: http://dl.dropbox.com/u/35930505/craftbukkit-0.0.1-SNAPSHOT.jar

    (I was using craftbukkit. Build 1000)

    Korean mode maker : Sions

    - Google Translator -


    + vampire plugin
  28. Offline


  29. Offline


    looks like something isn't working right initially connecting to your sql DB, try moving the "name:" above the "user:" section and see if that changes anything? so:
        Enabled: true
             Name: server725
                Name: server725
                Password: z+cODGpbqB2t
            TablePrefix: mcmmo_
            Port: 3306
            Address: localhost
    don't think that should matter entirely though, so idk what's wrong if that's not it.
  30. Offline


    I don't think that worked out
  31. Offline


    hmm... idk then. it was more of a guess than anything. your error now is a syntax error, so it may have been right the other way around. that and I have no clue about mysql so I stay away from it for the time being
  32. Offline


    Prayer KICKS ASS
    2/3 done with it right now, going to post it when i am done then give it to nossr50 on if it will be added to mcMMO. Still have some special effects to add and then the final ability
Thread Status:
Not open for further replies.

Share This Page