[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Thanks for the compliments :)
    I've been getting reports of this lately, its still being looked into.
  3. Offline



    I'll contact the server host about getting this fixed. Thank you!
  4. Offline


    How do I stop /invite from interfering with mcmyadmin /invite?
  5. Offline


    Does this work with #1000 and not sure if you saw my comment that /invite for party does not seem to work.

    Also noticed sorcery in the abilities :D
  6. Offline



    Server host:

    I'm not complaining about the chat bug when mySQL drops connection...I just want to alert the appropriate party so they know. :)

    Thanks again for the great plugin.
  7. Offline


    Haven't noticed any issues on 1000.

    Please add a switch in the config to disable the Chimaera Wing..

    Maybe even for all future items and spells.. ty great plugin!

    Edit: oops sorry! Not sure how I missed that..
  8. Offline


    from the OP:
    [diamond]Version 1.0.35[diamond]
    Big thanks to Pandarr, NuclearW, mooman, and DiskMaster for contributing to this update!
    • Added a Toggle for Chimaera Wing in config.yml
    it's the first item :D
  9. Offline


    Quick issue; players seem to be getting double drops from blocks they place themselves on my server. I think this didn't used to happen prior to some point, is this a setting I've missed somewhere or a bug, or is it working as intended? Thanks!
  10. Offline


    You want to make sure that the MYSQL database is running on the same server/equipment as your minecraft server, otherwise you will experience those issues as well as lag everytime mcmmo writes to the database.

    I've been running mcmmo using MYSQL for a long time, never had any trouble with it

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
    MikeThePickle likes this.
  11. Offline


    @nossr50 mcMMO is no longer generating logs every 40 seconds when printing reports is set to true.
  12. Offline



    "Removed performance debugging"

    Although it looks like the node wasn't taken out of the default generated config.yml
  13. Offline


    I need the debug info, using with flatfile is fine but MySQL is making blocks come back and causing lag like a mother****er.

  14. Offline



    Is your mysql server local?
  15. Offline


    One of my users has reported that this conflict between MobArena and mcMMO is non-existent with MobArena v0.93.x :)
  16. Offline


    Hello everyone,

    Since the update to onCommand, renaming commands does not currently work (not for me, at least). This is because it's not caught as a /command send. Renaming your commands will render them useless. Just FYI :D

    You can, however, edit the plugin.yml file if you wish to rename an ability (you'd also have to have it as the command in config.yml)
  17. Offline


    Hi - this is working great bar one little issue: /MCGOD does nothing. I've enabled it in the config file and given the permission node appropriately, but when I type /mcgod (even as owner) it says unknown command.

    Any suggestions?
  18. Offline


    External, like most people's.
  19. Offline


    You can activate super breaker on grass now ;O
  20. The Taming issue with MobArena is indeed fixed.

    @wahrheit: I strongly doubt most people use external mysql databases, really can't expect performance with network overhead...

    My users are reporting Tree feller is still bugged. If anything, it destroys 1 or 2 logs, it never seems to explode. TNT works fine, is there something special that needs to be enable to actually make the tree explosions work properly, or is this a known bug?
  21. Offline


    is anyone else getting double drops from ore from placed blocks? had to disable mining abilities due to this.
  22. Offline


    Version 1.0.36
    • mcMMO now properly supports Bukkit/PEX/Permissions for Permissions
    • Config.yml will no longer generate Performance Debugging nodes
    • Registered permission nodes to plugin.yml
    • Some more changes to Permissions code
    • Fixed bug where Super Breaker activated where it shouldn't
    • Fixed bug with enabling/disabling mcgod in config.yml
    • Fixed bug with Excavation not kicking in until 1 level higher

    And a few pieces of advice...

    You should only be using MySQL when its on the same network as the machine hosting your server, any delays in communication between your minecraft server and MySQL will result in horrendous performance. MySQL has the potential to outperform flat file but only in the right environment.

    Command Renaming
    If you rename your commands in config.yml you will have to crack open mcMMO.jar with 7zip/winrar and find the commands you have renamed and rename them in there as well or they won't work at all. This is due to a recent change in how mcMMO handles commands.

    Permissions 3.1.6
    Do not use this with mcMMO, it still performs poorly from what I've heard. I sent the author a PM but he has yet to get back to me, hopefully he will be able to help me figure out why there is so much lag with the newest version of Permissions. In the mean time you could use PEX or Bukkit's built in permissions system.
  23. Offline


    From our server host...

    Additionally, no other plugins disconnect or have mySQL problems, such as iConomy, LogBlock, Stats, and MyHome.
  24. Offline


    Still not getting the nodes to work with PEX not sure what it is, everything else works fine.
    http://pastebin.com/6YY4EyCv PEX permission part of it atleast.
    I try'ed to remove the nodes from all other worlds expect main world but mcmmo still doesn't
  25. Offline


    Go to /plugins/mcMMO/ and delete config.yml and generate a new one. Don't modify it and load your server up again, see if commands work.

    I'm not confident about how I have MySQL implemented in mcMMO at the moment, so it could very well be my fault that this is happening, I'd suggest you use FlatFile since you are having issues.
  26. Offline


    Please can you make item block? So if you are lower than lvl 5 of mining (for example) you can't use the stone pick,
    and it was a nice idea if you can make it toggleable. I am using your addon and other one in same time only for this!
    please, thanks[workbench]

    (sorry for bad english :p)
    (Wow! 165 pages of comment!)
  27. Offline


    Is there any plan to implement wolf regen, like players have regen based on Power Level? I'm quite sick of carrying around tons of unstackable pork products. Thanks, this and PreciousStones are my 2 favorite plugins, and a must for any PvP server in my opinion.
  28. Offline


    So i have have a question, how do i setup mySQL, I have a database all ready and set up, I enter in the information into the config file and every time I reload/start the server mcMMO doesn't load and throws and error.

    Show Spoiler
    2011-07-18 18:07:32 [INFO] [mcMMO] Permissions version 3.1.6 found, using Permissions.
    2011-07-18 18:07:32 [INFO] Loading Config File...
    2011-07-18 18:07:32 [INFO] [mcMMO] Permissions version 3.1.6 found, using Permissions.
    2011-07-18 18:07:35 [INFO] SQLException: Communications link failure
    The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    2011-07-18 18:07:35 [INFO] SQLState: 08S01
    2011-07-18 18:07:35 [INFO] VendorError: 0
    2011-07-18 18:07:35 [SEVERE] Error occurred while enabling mcMMO v1.0.36 (Is it up to date?): null
        at com.gmail.nossr50.Database.Write(Database.java:135)
        at com.gmail.nossr50.Database.createStructure(Database.java:45)
        at com.gmail.nossr50.mcMMO.onEnable(mcMMO.java:111)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
        at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:380)
        at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleCommandMap.java:281)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:312)
        at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:480)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:465)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    All I did here is enable mySQL, didn't change anything, but no matter what I do it gives me the same error.

    OMG!!! I FIGURED IT OUT!!! only took me for ever!!! If any one else cant get mySQL to work MAKE SURE your database can use external hosts, I use domain.com and just had to tik the box for external host and you use that as the ip address.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  29. Offline


    I have tested this many times and healing with bread while having high herbalism does not increase the breads heal amount.

    Parties also still seem to be broken.
  30. Offline


    heyho @nossr50

    I've updated to your newest v1.0.36. #1000
    Now I can't use my custom commands, nothing happens, or "unkown console command"
    (Yes I removed all old files and let mcmmo generate new ones)

            Name: skills
            Enabled: true
    /skills -> "unknown console command", Nothing in the ServerConsole
    /stats -> Nothing in Chat or the ServerConsole

    I use Groupmanager (mcmmo detects permissions 2.7.2 in the serverconsole).
    Edit: Default commands work!

    Because I did no backup, could anyone upload 1.0.35 please?
  31. Offline


    so is nobody else getting double drops from placed ores? can someone check so I know whether or not to look for a plugin conflict?
Thread Status:
Not open for further replies.

Share This Page