[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    [diamond]Version 1.0.35[diamond]
    Big thanks to Pandarr, NuclearW, mooman, and DiskMaster for contributing to this update!
    • Added a Toggle for Chimaera Wing in config.yml
    • Added customization of what item is used for Chimaera Wing in config.yml
    • Fixed bug with randomly receiving Taming XP
    • mcmmo.users file moved into /plugins/mcMMO/FlatFileStuff/
    • Leaderboard files now moved into /plugins/mcMMO/FlatFileStuff/Leaderboards
    • Locale files now have the prefix locale_ instead of messages_
    • Locale files are now located inside com/gmail/nossr50/locale/ instead of com/gmail/nossr50/
    • Updated the code that handles permissions (this may mean 3.1.6 will finally play well!)
    • Some more source code organization
    • Fixed warnings for compiler
    • Removed dependencies on CraftBukkit
    • Registered commands to OnCommand
    • Removed performance debugging
    • Removed some useless settings from the config file
    You will need to move your mcmmo.users file from plugins/mcMMO/ into plugins/mcMMO/FlatFileStuff/

    Locale Changes
    Locale files have had their prefixes changed to locale_ instead of messages_ and they have been moved into com/gmail/nossr50/locale/

    Permissions code updated...
    You should be able to use 3.1.6 with mcMMO now, and PEX as well. I might be wrong about 3.1.6 as I haven't tested it for lag yet!

    Config file changes
    Update your Items node tree to look like this if you want to configure Chimaera Wing stuff, alternatively generate a new config file.

            Enabled: true
            Feather_Cost: 10
            Item_ID: 288
  3. Offline


  4. Offline



    I am assuming you misplaced a bracket or something, lol. Or do I need to redo my config file?
  5. Offline


    you did a misstake there in your mainpost plugins/mcMMO/FlatFileStuff
  6. Offline


    Mine Runs On MySQL......... This was after a /reload, A restart fixed it. I more posted as a joke rather than a serious problem, hence no log file with errors.
  7. Offline


    Whats the problem?
  8. Offline


    Trolololo. It fixed itself after a full restart, This was after a /reload.
  9. Offline


  10. Can you please add RSO/CoalOre to the blocks you set to dmg =5? Or is there a specific reason not to? In our server you can craft Coal Ore blocks, and currently I have Coal Ore XP set to 0, as it can be abused now.

    Also did you see what I posted about pumpkins before?
  11. Offline


    since i run (the inactive, but still working and much loved) achievement+stats plugin on my server, i always had to change the mcMMO command "stats" to "skills".
    because that stats-command is already "taken" by the a+s plugin.

    until version 1.0.34 this worked very well.
    but with 1.0.35 not anymore.
    as soon as i configure it with the standard "stats", the command works again and overrides the one from the achievement-plugin.

    maybe this here is damaged and won't let me change it to my needs:
            Name: stats
            Enabled: true

    i use b953 and a bunch of several plugins.

    just tried it with changing "mcrefresh" to "mcr": it tells me "unknown command" when i type mcr and displays no visual response when typing mcrefresh.
  12. Offline


    Ah this might be from the change to how mcMMO handles commands in 1.0.35, I'll see if I can't fix this asap.
  13. Offline


    Also /mcgod does nothing now. Not even a unknown command message.
  14. Offline


    does the username you are using for access the database also have permissions to create? Pretty typical cause for this issue with almost all sql based plugins.
  15. Offline


    plugin still give error "read time out" with 3.1.6 PErmissions
  16. Offline


    This file is the traduction for latin spanish for the last version of the plugin (except the part of wizard, loafer me xD)

    Attached Files:

  17. Offline


    Permissions still dont work with PEX, no errors in console and no "unknown" command in game. Done full restart after update.
  18. Offline


    i have problem with mcMMo

    skill reset to 0
    1. I use name "player1" for play then i log out
    2. next time i use player name "PLAYER1" to play , skill "player1" is reset to 0

    Do you understand it and can fix this bug
    Because some bad player use to annoyance other player

    i use offline server​
  19. Offline


    PEX is working fine for me. I dropped in the .jar did /reload and it worked fine. The only problem was the formatting of the /stats output and that was fixed on a full restart. Im running Bukkit 996 if that makes any difference.
  20. Offline


    Im on 953 could be it

    996 doesn't seam like a stable build to me quote from github:
    #996 (16-Jul-2011 01:56:41)

    1. "Don't use weak/soft references for keys, attempt to lessen memory impact further"
  21. Offline


    Yea I have been off of 953 for awhile, that might be it. #974 was good #987 was good and #996 is actually DEALLOCATING memory!! which is awesome and a first for me.
  22. Offline


    I moved the users flatfile but stats are still 0 and couldnt get them back.
    Edit: Fixed after removing and replacing the file several times.
  23. Offline


    All our stats are still around but the party commands don't work for non-ops.
  24. Offline


    Idea - add "swimming" as another skill - the better you are at it, the longer you can breath underwater. Improve by breathing underwater. Maybe take depth underwater into account as an "only improve below xyz" - ie, make it so it's not *really* simple and safe to train it ;-)
  25. Offline


    So despite updating my libraries and changing the code Permissions 3.1.6 is still lagging with mcMMO?
  26. Offline


    /mcgod is still not doing anything for me, but i just tested party commands and everything else i could think of and it was all fine (with admin as well as default user permissions). using permissions 3.1.6 and flatfile. the stats all carried through the update/changes in folder structure and no problems at all have been experienced so far other than /mcgod not working. i will continue to test and report any abnormalities if i experience them.

    thanks for this plugin and all these updates =)

    edit- we posted at the same time, but i am not experiencing any lag at all on flatfile/permissions 3.1.6 (i have never experienced any lag from mcmmo though and have been using permissions 3.1.6 the whole time).
  27. Offline


    Just updated to 1.0.35 and updated to permissions 3.1.6 and timeout's after 25 min.
  28. Offline


    Aww :(

    This is quite strange... I'm able to use /mcgod on my own server fine. I even modified the code of /mcgod for this update and its still acting odd.

    I've sent a PM to the Permissions author in hopes to resolve these Read Time Out errors

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  29. Offline


    YES. The problem is still here.... :(:(:(:(:(:(:( Going to switch permissions back to 3.1.5

    Ty. Let me know if you need any data.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  30. Offline


    Yup I switched to Permissions for the first time and got Read time out about 20 mins in.
  31. Offline


    Seems to work perfectly on 953

    I would make it so there is no Acrobatic skill gains if someone falls to their death though.. If thats even possible..

    I have a server of lemmings now trying to boost their scores.. lol
Thread Status:
Not open for further replies.

Share This Page