[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    UseMySQL=false when I got this error
  3. Offline


    i'm also getting some
    2011-05-25 02:59:34 [SEVERE] Could not pass event BLOCK_BREAK to mcMMO
        at org.bukkit.craftbukkit.entity.CraftPlayer.sendRawMessage(CraftPlayer.java:84)
        at org.bukkit.craftbukkit.entity.CraftPlayer.sendMessage(CraftPlayer.java:88)
        at com.gmail.nossr50.skills.Skills.XpCheck(Skills.java:428)
        at com.gmail.nossr50.datatypes.PlayerProfile.addXP(PlayerProfile.java:961)
        at com.gmail.nossr50.datatypes.PlayerProfile.addHerbalismXP(PlayerProfile.java:990)
        at com.gmail.nossr50.skills.Herbalism.herbalismProcCheck(Herbalism.java:127)
        at com.gmail.nossr50.mcBlockListener.onBlockBreak(mcBlockListener.java:177)
        at org.bukkit.plugin.java.JavaPluginLoader$34.execute(JavaPluginLoader.java:475)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
        at net.minecraft.server.ItemInWorldManager.d(ItemInWorldManager.java:156)
        at net.minecraft.server.ItemInWorldManager.dig(ItemInWorldManager.java:99)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:443)
        at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:377)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:292)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  4. Offline


    Alright, I managed to drag myself over to a computer with internet to look at the mess I made with 1.0.08

    I'll work on fixing the posted bug reports asap, expect a fix out today

    Normally I test my patches to mcMMO with the users on my own server, shame I can't do that anymore without the internet :(

    I'll do my best one man testing for the upcoming 1.0.09 patch

    I'll take a look at my code to see if I forgot to cleanup any lists or objects for MySQL since many people report high memory usage, I won't be able to do very much testing on it however.
  5. Offline


    Does anyone have a link to the old version so that we can use it for now until the new version has been fixed?
  6. Offline


    me too . .
  7. Offline


    I am alos getting block break errors:
  8. Offline


    Version 1.0.09
    • Fixed the NPE that occurs when players gain experience ([sheep]Sorry!)
    • Fixed bug where /myspawn & /clearmyspawn would work if MySpawn was disabled in the properties file
    • Changed strings containing "MMO" to read "mcMMO"
    • Removed a lot of unused or unnecessary variables from the PlayerProfiles in mcMMO, this should lower the memory footprint
    • Added getXpToLevel() for modders
    Alright, here you go guys. The patch 1.0.08 should've been. I looked over the code involved with MySQL and couldn't find any reason it would be using more memory than the flat file version. Could those with memory issues download this build and report back if its unusually high in MySQL compared to flat file?

    It's about four or more weeks until I move into a place where I can get internet, sorry for these slowpoke updates!

    Source Code Download for 1.0.09
  9. Offline


    Keep up the good work! We love mcMMO!
  10. Offline


    Alright, latest source code changes are now on github. I pushed them even though it didn't recognize me :p.
  11. Offline



    hey, fix please /myspawn BUG where player can teleport to bed with a disconnect.
  12. Offline


    McMMO shows up ingame. However, the /stats doesnt work and people aren't leveling. I have MySQL set to true and it IS configured correctly but its not creating the table in the database.
    Craftbukkit, herochat , myhome, uQuest, autohelp, heroicdeath, mywarp, Vampire, bigbrother, iChat nocheat vStopFire
    blastcontrol iConomy permissions WorldEdit
    commandbook jail pickpocket WorldGuard
    craftbook LWC secretdoors
    dispnamechanger MagicCarpet signshop
    dynmap MagicSpells spyeradmin
    factions MuddersMilk spyerfun
    2011-05-25 17:03:25 [SEVERE] Could not pass event PLAYER_LOGIN to mcMMO
    at com.gmail.nossr50.Database.GetInt(Database.java:170)
    at com.gmail.nossr50.datatypes.PlayerProfile.loadMySQL(PlayerProfile.java:74)
    at com.gmail.nossr50.datatypes.PlayerProfile.<init>(PlayerProfile.java:52)
    at com.gmail.nossr50.Users.addUser(Users.java:66)
    at com.gmail.nossr50.mcPlayerListener.onPlayerLogin(mcPlayerListener.java:81)
    at org.bukkit.plugin.java.JavaPluginLoader$11.execute(JavaPluginLoader.java:292)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:289)
    at net.minecraft.server.ServerConfigurationManager.a(ServerConfigurationManager.java:152)
    at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:82)
    at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:33)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:87)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    2011-05-25 17:03:25 [INFO] a98x [/] logged in with entity id 212
    2011-05-25 17:03:25 [INFO] CommandBook: No intro.mid; not playing intro song.
    2011-05-25 17:03:25 [SEVERE] Nag author: 'w4rgo' of 'FireLord' about the following: onPlayerJoin has been replaced with a new signature, (PlayerJoinEvent)
    2011-05-25 17:03:29 [INFO] [AutoHelp] Searching active plugins' plugin.yml files for command help
    2011-05-25 17:03:29 [INFO] [AutoHelp] Skipping command 'help', already has a help entry
    2011-05-25 17:03:31 [INFO] [AutoHelp] 'Help' support enabled.
    2011-05-25 17:03:37 [INFO] a98x lost connection: disconnect.quitting
    2011-05-25 17:03:37 [INFO] Connection reset
    2011-05-25 17:03:37 [SEVERE] Could not pass event PLAYER_QUIT to mcMMO
    at com.gmail.nossr50.mcPlayerListener.onPlayerQuit(mcPlayerListener.java:84)
    at org.bukkit.plugin.java.JavaPluginLoader$2.execute(JavaPluginLoader.java:238)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:289)
    at net.minecraft.server.ServerConfigurationManager.disconnect(ServerConfigurationManager.java:115)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:581)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:200)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    2011-05-25 17:03:38 [INFO] / lost connection
  13. Offline


    Gravel to Clay (Didn't fit with the mod, might make it into its own plugin if requested)
  14. Offline


  15. Offline


  16. Offline



    Thanks for the fast fix inspite of internet trouble!! I think I saw 5 or so more "cannot pass..blabla" errors earlier but nothing near to what it was before. My log file grew to 8mb in a matter of a few hours XD.

    Just one last thing, I still am unable to get the /accept command to work. Always get the "you dont have permission to use this command" error. I use the phoenix permissions 2.7.4 and CB803. I tried doing mcmmo.commands.* to get around it and still wont work.
    The only plugin I think that can be conflicting is essentials 2.2.20 (not using their groupmanager)
    I found the problem, McMyAdmin has the /accept command also. Is there a way to change it somehow?
  17. Offline


    When will mcMMO support #803 build ?
  18. Offline


    it already does...
  19. Offline


    Hmm, why then doesn't it work on my server after update...
  20. Offline


    topic of this thread: [MECH] mcMMO v1.0.09 - RPG Addiction Redefined! Permissions Support! [803]

    Note the 803? and it works fine on my server, why don't u post the error log?
  21. Offline


    Wait a sec...
  22. Offline


    did u get .09? .08 had all those errors and he just released the fix today with .09.
  23. Offline


    Sorry, my bad, i've didn't seen it updated just now
  24. Offline


    I was wondering if it possible to disable abilities in the settings file or split up the plugins because my admins use "*" and they auto get every command. I don't want them to have abilities and all mcmmo features.
  25. Offline



    Seem to be having some kind of issue where none of the archery abilities are being triggered and no archery xp is being gained, as well as swords. Doing /stats shows archery and swords as skills, I assume that means the permissions are right (and they should be unchanged from a few builds ago when it still worked). Sorry I can't provide more information, was just wondering if anyone else was experiencing the same or if I should check out my other plugins as well for conflicts. Thanks!
  26. Offline


    What is power level and what happens when it exceeds 9000!!!!!!!!! ?
    (What does the scouter say?)
  27. Offline


    Saw this a while back but haven't been able to find it since, where's the chart with the regen to power level?
  28. Offline


    Regen? I gotta toggle it off...

    How to make it gain exp for killing non-monsters, like to train on cows and pigs?
  29. Offline


    I run a pretty popular RPG server and they all requested that I switch over to McMMO from LevelCraft. So i removed LevelCraft and set up a SQL DB and installed McMMO and its not working right. Please Help!.... see my post for more information on the previous page (i.e. page 106) at the bottom.
  30. Offline


    You don't really need mySQL
  31. Offline


    I added SQL for server performance. I run 40 slots and need all the RAM i can get
Thread Status:
Not open for further replies.

Share This Page