Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    How do you set this up with Multicraft?
  3. Offline


    I think 25561 is RemoteToolkit's remote control port, configured in toolkit/
  4. Offline


    Does it work with 1.5 /?????
  5. Offline


    Everything works okay, still trying to port forward 20059,20060,20061 but my problem is that when i write STOP in bukkit, it finishes closeing everything, saves all files and then it automatically restarts! How do i stop the server, can i disable the autorestart?
  6. Offline


    I've setup everything as the instructions say to, and everything seems to be functioning perfectly, except it doesn't automatically recover from crash. I return to my server to see a long line of read timed out messages:

    No restarts. I have it set to restart after 2 missed heartbeats.
  7. Offline


    I don't know if this is an issue with RTK, but I'm running a server using screen on my linux machine and when I type /stop, wait for it to say "Restarting..." and then kill it with ctrl-C, I can't see what I'm typing on-screen until I exit the session and start a new one. Any ideas?
  8. Offline


    This happens to me as well on my VPS, however, it doesn't happen on my local machine. They're both running Ubuntu 12.04 LTS. You can see your text again if you turn the wrapper back on.

    Anyways, I was about to complain about the lack of color in the console, but fixed in the latest version. Thanks.
  9. Offline


    My remotetoolkit cannot detect the remote toolkit plugin no matter what, ive tried reinstalling it. nothing works. any ideas?
  10. Offline


    My remotetoolkit can't detect the plugin either. Using beta build of CB 1.5.1 :/
  11. Offline


    Make sure that the toolkit folder is in the root directory of your server and that the RTK plugin is in your server's plugins folder. Other than that I don't know what the problem could be. Maybe try downgrading the version of RTK.
  12. Offline


    I have a question.

    When starting this it must have user:pass stated, however my host says they cannot run it like that, but im not sure they realize it's just a command switch essentially.

    So they have used their launcher to launch the wrapper jar, without the user:pass switch.
    I found that as long as the user exists in the users.txt file, the wrapper will start without that switch.

    Will running it in this manner cause problems? so far it seems to work except that I cannot shutdown or restart the server from adminium.

    In my console I can see the remotetoolkit.stopserver and remotetoolkit.rstartserver commands being received, but the server never stops or restarts.
  13. Offline


  14. Offline


    remote toolkit is just randomly restart my server every few minutes. What would you need to diagnose the problem.

    EDIT: Problem has something to do with mcMMO, dont know what though
  15. Offline


  16. Offline


    Use .hold (to keep the wrapper running) or .stopwrapper (to stop everything)
  17. Offline


    The console won't type.
    CraftBukkit 1.5.1 r0.2 (RT 10-14?)
  18. hey,

    is there a way to configurate the maxpermsize for the minecraft.jar ?
    this would help me to keep up the server with a wrose written plugin
  19. Offline


  20. Offline


    This is amazing especially with space bukkit :)
  21. Offline


    Not working for SpaceBukkit with me... works when tested on Win 8, but not XP.
  22. Offline


    Spacebukkit is very complicated to set up.... it took me like 3 months......
  23. Offline


    What are you talking about? It's insanely easy. You've just been doing it wrong :3
  24. Offline


    LOL... the computer i was trying to use it on was windows 7 ultimate and lets just say it tries to use port 80 for other stuff i get.... so i used a different computer and it worked great
  25. Offline


    I had it all setup..... but the problem is that it is saying that my OS is not fully supported..... why? and what isn't?

    just got a new error, some http problem, then SpaceBukkit says it failed to respond to ping request. I am running the server in offline mode and on my ip, What's the problem?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
  26. Offline


    Hello. Can you add the translation of "minutes"? In many languages ​​there is no word "minute" and "minutes".
  27. Offline


    Okay, I've said this some time ago but want to repeat.
    I have a server with TerraFirmaCraft mod, it is popular but very bugged and stupid — it crashes very often and cannot be restarted thought telnet, because of making some other cyclic exceptions on /stop and .restart commands. I really need the .kill command to gracefully kill the child java process.
    Also I want to ask you to add mysql support for getting user list (to store all the data from users.txt — username and password hash). I have a couple of servers on different machines and use RTK for each of them.
  28. Offline


    Whats happening is the Java.exe is still running sometimes you just cant see it and must got to your Task Manager > Process find Java.exe Click End Process
  29. Offline


    Hey, I'm running on a dedicated server, and installed it e xcept for one thing, I can't run rtoolkit.bat. I access my server through filezilla. Anyone know how to run it?
  30. Offline


    I own a dedicated server run by MCProHosting, and I can't seem to be able to run through an FTP client. Basically, I can't start the wrapper because I can't run commands through FTP.
  31. Offline


    Well I use rt toolkit with the space bukkit module and it will just randomely freeze and it says something like warning spacebukkit failed to respend to ping test or whatever and i have to kill the java.exe proccess to end it...
    Any ideas?
    Im using the 1.5.2 beta build i think.....
Thread Status:
Not open for further replies.

Share This Page