Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    drdanick

    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!


    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @ irc.esper.net


    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Todo


    [​IMG][​IMG]
    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
     
    Last edited: May 6, 2017
  2. Offline

    blackhawk185

    I get this error every time my server tries to enable heartbeats. Any ideas on what it is?

    First attempt at checking for presence of the RemoteToolkit plugin for Bukk
    it...
    RemoteToolkit plugin for Bukkit found! Enabling heartbeats...
    >heartbeats
    2013-02-25 10:13:33 [INFO] Unknown command. Type "help" for help.
    2013-02-25 10:14:27 [SEVERE] java.lang.IndexOutOfBoundsException: Index: 81
    3, Size: 813
    2013-02-25 10:14:27 [SEVERE] at java.util.ArrayList.rangeCheck(Unknown S
    ource)
    2013-02-25 10:14:27 [SEVERE] at java.util.ArrayList.set(Unknown Source)
    2013-02-25 10:14:27 [SEVERE] at net.minecraft.server.v1_4_R1.RegionFile.
    a(RegionFile.java:197)
    2013-02-25 10:14:27 [SEVERE] at net.minecraft.server.v1_4_R1.ChunkBuffer
    .close(SourceFile:230)
    2013-02-25 10:14:27 [SEVERE] at java.util.zip.DeflaterOutputStream.close
    (Unknown Source)
    2013-02-25 10:14:27 [SEVERE] at java.io.FilterOutputStream.close(Unknown
    Source)
    2013-02-25 10:14:27 [SEVERE] at net.minecraft.server.v1_4_R1.ChunkRegion
    Loader.a(ChunkRegionLoader.java:180)
    2013-02-25 10:14:27 [SEVERE] at net.minecraft.server.v1_4_R1.ChunkRegion
    Loader.c(ChunkRegionLoader.java:167)
    2013-02-25 10:14:27 [SEVERE] at net.minecraft.server.v1_4_R1.FileIOThrea
    d.b(SourceFile:29)
    2013-02-25 10:14:27 [SEVERE] at net.minecraft.server.v1_4_R1.FileIOThrea
    d.run(SourceFile:22)
    2013-02-25 10:14:27 [SEVERE] at java.lang.Thread.run(Unknown Source)
     
  3. Offline

    Mindrun

    My console using the Toolkit is all messed up. No colours show and whenever I'm typing a command and I get a message in the console, the command I was typing goes up in the console like other messages. The field to type commands gets cleared but whatever I typed in before is already there (but you cant see it). Sorry if you don't understand, it's hard to explain.
     

    Attached Files:

  4. Offline

    Caperr

    i get this error message on the server console on load up:

    11:04:12 [INFO] [RemoteToolkitPlugin] Enabling RemoteToolkitPlugin vR10_A14.5
    11:04:12 [INFO] Error loading Toolkit plugin properties: java.io.FileNotFoundException: toolkit/remote.properties (No such file or directory)
    11:04:12 [SEVERE] java.io.FileNotFoundException: toolkit/remote.properties (No such file or directory)
    11:04:12 [SEVERE]at java.io.FileInputStream.open(Native Method)
    11:04:12 [SEVERE]at java.io.FileInputStream.<init>(FileInputStream.java:120)
    11:04:12 [SEVERE]at java.io.FileInputStream.<init>(FileInputStream.java:79)
    11:04:12 [SEVERE]at com.drdanick.McRKit.plugin.RTKPlugin.onEnable(RTKPlugin.java:51)
    11:04:12 [SEVERE]at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    11:04:12 [SEVERE]at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)
    11:04:12 [SEVERE]at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    11:04:12 [SEVERE]at org.bukkit.craftbukkit.v1_4_R1.CraftServer.loadPlugin(CraftServer.java:282)
    11:04:12 [SEVERE]at org.bukkit.craftbukkit.v1_4_R1.CraftServer.enablePlugins(CraftServer.java:264)
    11:04:12 [SEVERE]at net.minecraft.server.v1_4_R1.MinecraftServer.j(MinecraftServer.java:321)
    11:04:12 [SEVERE]at net.minecraft.server.v1_4_R1.MinecraftServer.e(MinecraftServer.java:300)
    11:04:12 [SEVERE]at net.minecraft.server.v1_4_R1.MinecraftServer.a(MinecraftServer.java:259)
    11:04:12 [SEVERE]at net.minecraft.server.v1_4_R1.DedicatedServer.init(DedicatedServer.java:149)
    11:04:12 [SEVERE]at net.minecraft.server.v1_4_R1.MinecraftServer.run(MinecraftServer.java:399)
    11:04:12 [SEVERE]at net.minecraft.server.v1_4_R1.ThreadServerApplication.run(SourceFile:849)
    11:04:12 [SEVERE] Error occurred while enabling RemoteToolkitPlugin vR10_A14.5 (Is it up to date?)
    java.lang.NullPointerException
    at com.drdanick.McRKit.plugin.RTKEventHandler.<init>(RTKEventHandler.java:28)
    at com.drdanick.McRKit.plugin.RTKPlugin.onEnable(RTKPlugin.java:57)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    at org.bukkit.craftbukkit.v1_4_R1.CraftServer.loadPlugin(CraftServer.java:282)
    at org.bukkit.craftbukkit.v1_4_R1.CraftServer.enablePlugins(CraftServer.java:264)
    at net.minecraft.server.v1_4_R1.MinecraftServer.j(MinecraftServer.java:321)
    at net.minecraft.server.v1_4_R1.MinecraftServer.e(MinecraftServer.java:300)
    at net.minecraft.server.v1_4_R1.MinecraftServer.a(MinecraftServer.java:259)
    at net.minecraft.server.v1_4_R1.DedicatedServer.init(DedicatedServer.java:149)
    at net.minecraft.server.v1_4_R1.MinecraftServer.run(MinecraftServer.java:399)
    at net.minecraft.server.v1_4_R1.ThreadServerApplication.run(SourceFile:849)
    sorry :(... help please?
     
  5. Offline

    Liger_XT5

    Read the first part of the error. The location of the files, let alone the files themselves, is not found. Make sure you placed all the files in the right locations. The toolkit folder should be in the same directory as the start files you use to start the server, usually the same location as the server file (craftbukkit, vanilla mc server, spigot, etc.)
     
  6. Offline

    lolmaus

    I've got CraftBukkit running on a Debian VPS as a daemon. I. e. there's an /etc/init.d/minecraft script that lets me start/stop the server in background. The server also starts automatically on server startup.

    I want to install SpaceBukkit. SpaceBukkit requires RemoteToolkit, and RemoteToolkit supposes running a server by launching the wrapper startup script manually. I failed to find any information on how to set up RemoteToolkit wrapper running as a Debian/Ubuntu daemon.

    Could you please help me out with this?
     
  7. Offline

    Sharkykzn

    Running my server on Debian, using Linux launcher. The following appears after a chunk sync crash. During a restart in the console, not as a warning, but wondering why it appears.

    [INFO] Startup script 'start.bat' does not exist!
     
  8. Offline

    chrisk123999

    You need to open a screen first.
    http://www.rackaid.com/resources/linux-screen-tutorial-and-how-to/
     
  9. Offline

    syconomis

    is there an IOS app that goes with Remotetoolkit.
     
  10. Offline

    fabmakesmusic

  11. Offline

    Liger_XT5

    Install JsonAPI and you can use Adminium for the iDevices. Otherwise check out the Telnet feature Rtoolkit uses.
     
  12. Offline

    fabmakesmusic

    Our plugin developer made a plugin that can execute the console command ".restart". But anyhow it does'nt work, we get a "Unknown Command" Message.
     
  13. Offline

    Fuzzwolf

    RemoteToolkitPlugin vR10_A14.5

    CraftBukkit version git-Bukkit-1.4.7-R1.0-b2624jnks (MC: 1.4.7) (Implementing API version 1.4.7-R1.0)


    My config: http://pastie.org/6447506

    Hi, I host locally and have been encountering a problem. I've asked this question here before but never got a proper response.

    Whenever I'm not at my computer (gone for a little bit with monitor off, no actual "sleep mode") and the server crashes, crash detection does not seem to properly function. It seems to detect the crash, but the server will not be saved/restarted until I am physically at my computer. Of course, this nullifies the purpose of crash detection. Any idea why this would happen? I've had this problem for 6 months so version does not seem to matter.

    Here's an example below, when I finally turn on my monitor I only see "Read timed out" before the server restarts itself. If I am on my computer and active, crash detection would trigger automatically.

    Code:
    2013-03-10 19:31:16 [INFO] <Azione> Mars is now deserted
    2013-03-10 20:53:14 [INFO] Read timed out
    2013-03-10 20:53:14 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2013-03-10 20:53:14 [INFO] Read timed out
    2013-03-10 20:53:26 [INFO] Starting minecraft server version 1.4.7
    2013-03-10 20:53:26 [INFO] Loading properties
    2013-03-10 20:53:26 [INFO] Default game type: CREATIVE
    2013-03-10 20:53:26 [INFO] Generating keypair
    2013-03-10 20:53:26 [INFO] Starting Minecraft server on *:25565
    Cheers.
     
  14. Offline

    darkdeath1332

    Guys the wiki is down
     
  15. Offline

    Mindrun

    Any telnet app works with RemoteToolkit, for iOS I would recommend iTelnet.
     
  16. Offline

    cobsad

    Is there a quick couple of files I could alter to make this compatible with CB 1.5? Or should I just wait?
     
  17. Offline

    Mindrun

    I use it with 1.5, and there are no problems.
     
  18. Offline

    cobsad

    Well I am using it with 1.5, and it seems to be working well, it's just that Adminium crashes whenever I try to access the console or chat, so I just assumed that was due to the RemoteToolkit. I guess it's just Adminium. Not surprising, it crashes all the time it's pretty unreasonable.
     
  19. Offline

    nicatronTg

    That only works from the console itself - you have to use the forward slash prefix commands in order to interface with it from ingame.
     
  20. Offline

    codydbgt

    Code:
    java -Xmx30M -Xms30M -XX:MaxPermSize=40M -jar Minecraft_RKit.jar -ominecraft-server-jar=test derp:derp
    the overide -o for the jar file will not work (tested on linux)
     
  21. Offline

    cobsad

    Has anyone had issues with adminium crashing at the console and chat? I don't get any errors, dumbfounded.
     
  22. Offline

    Liger_XT5

    Update Adminium, it was fixed in the latest update.
    If it still crashes, make sure JSONAPI and the server is updated as well.


    Small Feature Request:
    There are many commands that can be used in the console, not many for ingame.
    I was wondering if .restarttime could be added to be used ingame? I don't care if anyone can use it, but with people being in different timezones, it would help.
     
  23. Offline

    BurnseyBoi

    I'm using Release 10, Alpha 14.5 as a wrapper to automatically restart my Voltz minecraft server every 4 hours. Is there a way to schedule backups of the world folder, considering there are no plugins in Voltz? I'm not savvy enough with Windows Task Scheduler to attempt by myself!
     
  24. Offline

    cobsad

    It's all updated, same issue :(

    I despise Windows Task Scheduler, surely there's a simple freeware program you could pickup, even make a simple batch file script?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 2, 2016
  25. Offline

    broomy

    Hi,

    I have a server owned by multiplay so I can only access my server files via FTP. As a result of this I cannot run the server using the custom rtoolkit launch file. Is there any way to run the remote toolkit without actually starting the server via the launch file?
     
  26. Offline

    xDeeKay

    broomy I was in the same situation. If your host is nice enough, they'll set it up for you to work alongside your setup.
     
  27. Offline

    broomy

    xDeeKay yeah I've tried asking but multiplay (my provider) won't allow it.
     
  28. Offline

    LeakCraft

    I keep getting this error, however the problem is that I am positive that nothing is running on this box, as I only use it for web, mysql, and one Minecraft server. If I switch the port to a different port (example: 25562), it'll still say that it failed to bind port. It does this no matter what port I select and I am positive nothing else is using that port. Help?

    EDIT: For the record, as soon as I switch from rtoolkit.sh (which I chmod +x'd to make sure it had full access) to my regular launcher script, my server works absolutely fine. It's JUST with rtoolkit.
     
  29. Offline

    bad339

    Your main port should be 25565... did you change your port in the minecraft config? Because this error has nothing to do with remoteTK, it's vanilla based.
     
  30. Offline

    LeakCraft

    I use port 25561, is that going to cause issues? I run multiple servers and then link them with SRV records (s.survival.com, c.creative.com, etc.)
     
  31. Offline

    bad339

    According to the error, either you put in the wrong local IP address in the config, or 25561 is not opened on your router.

    *Offtopic* I would recommend using Bungee to link your servers together, it's way more efficient and has a lot of other features ;)
     
Thread Status:
Not open for further replies.

Share This Page