Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    This is possible to kick-all before restart?
  3. Offline


    I'm looking into this, but it appears to be something I can't fix without modifying bukkit.

    It does this already.
  4. Offline


    Can you fix the error i keep getting that spams my concole every 5 secconds? it keeps saying that it cant bind to the udp port.
  5. Offline


    That's user error. You need to configure ./toolkit/
  6. Offline


    The new RB for Bukkit came out , I think it is 2377 for CB 1.3.2 R1.0 ... which doesn't work with your plugin :( I have to use 1.3.2 as I have a core feature of my server that uses that version. Any idea when this might happen? This is literally the last step of my 4 step plan to fully automate the server and I have been trying for weeks to find alternative solutions.
  7. Offline


    Can you provide more information about the issues you are having with that bukkit build?
  8. Offline


  9. Offline


    Works fine for me?
  10. Offline


    Well, I can get it loaded on bootup with no problems and can even type the 3 in game commands and it shows they exist. However, I have yet to have any luck being able to remote in so that I can run the wrapper. I have a paid hosting company that I use so I can't just execute the batch file locally, so the only way I can get it working is to terminal in to do it I think. I have tried using Terminal "telnet" and the Java UDP and that other Putty thing as well, but none of them let me connect. I have tried using various ports and still get the same results. When I try to do /restartsrv user:pass for example , (obiously I changed it) it doesn't let me run that due to "wrong password" although I admit the messages you put in there for failed attempts are amusing lol. Any ideas on what to do? (I know the ports are open I am trying to use btw)

    Ahh I see my host company finally responded and they handle the wrapper for me, even with an automated process and control panel of sorts. I was able to use telnet to remote into the server, but I still am unable to do the /restartsrv user:pass command yet, maybe I am missing something. And I picked a heck of a day to do all this, as it seems someone deleted the wiki page with the info to update it?

    It seems like no matter what I type in for the password, it doesn't like it. The console the host made has a thing for a password and username and I put that in, kill server, restart it and its like "nice try" when I attempt to use it. And so far i can't get hte UDP to connect "it is trying just won't authenicate" but the telenet connects just fine but i can't do commands like /restartsrv

    EDIT = okay now after changing the salt instead of using the default one I was able to connect wit the UDP jar, but ultimately that is the only way I can restart the server. I can not get it to issue the in game command nor are any of the .console type commands working for me, perhaps I am still missing something? But I am so close to figuring this out, just need a little help to figure out wtf I can't get to the .commands or use the /restartsrv user:pass without it saying one of the catchy "wrong password" phrases, however at the same time i can log into the telnet and use the password i set and it works to just see console remotely just not use remote toolkit stuff.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
  11. Offline


    Can you explain this? I am using telnet and it lets me use the .<command> commands, perhaps I could help with a better description than it wont work...
  12. Offline


    its more like a remote viewer of the console, any of the DOT commands do not function (granted with the wiki down I was only able to test the ones I could remember) As far as in game, when I do the /restartsrv User:pass command, it always says its the wrong PW. Although I know that the password is set, because I can remote in with telnet and the Java UDP program and all that. WIth the UDP program I can like check version and force a restart and such but I need to be able to issue the command in game so that mods are able to restart the server when I am not around.

    Interesting.. I didn't change anything but I just tried a .restart command in the console and the server Stopped but never auto restarted. However if I use the UDP to restart it with that program, it will restart, so that is kind of weird. Will keep you updated as I get more info of what is and is not functioning for me.

    Not sure why but its working now with no changes, it just started working, lol. I won't complain why... so guess I'm good to go, server automation of map reset, variables scripts data rewiped, and server restart now done :) Nearly full time DvZ server finally, just pending mods being around :0

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
  13. Offline


    hey im back, using remote toolkit with space bukkit! i finally got win7 fer my server too!

    my current problem is the heart-beat exception restart is not working even after 20 mins, and i even tried setting it to sensitivity 2 in config

    HELP PLZ?? :p
  14. Offline


    The heartbeat system relies on the fact that the console is responsive to commands so long as the server itself is responsive. If your server is no longer working, but the console still responds to commands, then there is little the toolkit can do.
    How frequently does your server become unresponsive?
  15. Offline


    its becoming very common. im beset with java fatal crashes, and also i keep getting stacks that really strongly resemble map corruption, but chunkmaster and mcedit dont show any bad regions. im about to start pulling freaking plugins left and right.

    here want to see some of the errors?

    here's one of the corruptions looking errors, and i will attach one of the java death errors

    2012-10-04 00:00:06 [INFO] 0
    2012-10-04 00:00:07 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 1412
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.NibbleArray.a(SourceFile:26)
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.ChunkSection.c(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.Chunk.getBrightness(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.World.b(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.World.c(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.World.x(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.World.x(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.World.g(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.WorldServer.g(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.WorldServer.doTick(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.MinecraftServer.q(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.DedicatedServer.q(
    2012-10-04 00:00:07 [SEVERE] at net.minecraft.server.MinecraftServer.p(
    2012-10-04 00:00:07 [SEVERE] at
    2012-10-04 00:00:07 [SEVERE] at
    2012-10-04 00:00:07 [SEVERE] Encountered an unexpected exception ArrayIndexOutOfBoundsException
    java.lang.ArrayIndexOutOfBoundsException: 1412
    at net.minecraft.server.NibbleArray.a(SourceFile:26)
    at net.minecraft.server.ChunkSection.c(
    at net.minecraft.server.Chunk.getBrightness(
    at net.minecraft.server.World.b(
    at net.minecraft.server.World.c(
    at net.minecraft.server.World.x(
    at net.minecraft.server.World.x(
    at net.minecraft.server.World.g(
    at net.minecraft.server.WorldServer.g(
    at net.minecraft.server.WorldServer.doTick(
    at net.minecraft.server.MinecraftServer.q(
    at net.minecraft.server.DedicatedServer.q(
    at net.minecraft.server.MinecraftServer.p(

    edit: here is a list of my plugins. many are custom:
    Plugins (42): WorldBorder, UltimateArena, PVPGun, WorldEdit, BuyMagic, Buycraft, AntiItem, Flashbangs, Vault, IronDoorProtection, SwornRadio, PermissionsEx, PExChat, SwornJail, WorldGuard, ecoCreature, AutoCraft, RemoteToolkitPlugin, IPCheck, AdminPVP, EnderStuffSucks, MagicSpells, McRPG, SwornShopsPlus, CoreProtect, SwornRefferal, AntiDiamond, SpaceBukkit, Votifier, SwornNether, AutoAnnouncer, Essentials, ChessCraft, JCVaultListener, EssentialsSpawn, SwornBackup, SwornNations, SwornGuard, PvPBounty, SwornCritters, Leaderboard, SwornPatrol

    Attached Files:

  16. Offline


    looks like ur Bukkit Wiki page was removed :p
  17. Offline


    I'm a newb here, but these lines seem to indicate (based on the function names) that it's having issues recalculating lighting. I don't know if any of the plugins you use change lighting, but have you tried the basic troubleshooting by disabling all plugins? I had to do that to figure out that a certain plugin was accidentally leaking memory for no reason ;)

    I'm using the RTK R10 Alpha 13, and I have a few questions. First, how do I disable the disconnect-on-idle feature? I was going to use a standalone terminal for watching the log, but it is difficult to do so when I keep getting disconnected...
    Second is, how would I go about making a module for this kit? The bukkit forum post indicates it will be coming soon, but no timestamp on when that was posted...
    My main reason is for the effect of having a output re-writer of sorts to get around the color bug that apparently plaques the terminal...
    Or perhaps even some kind of "status window" that could get drawn at the top right every now and then with server stats like the tick-rate and mem usage ;)
    My java skills are quite rusty, but I would be interested in seeing this come to fruition.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
  18. Offline


    let me tell you................

    we fixed this error on our map!!!!!

    and are working on an advanced version of chunkster, codenamed: VoidChunk!! it does what chunkster is, and removes lighting corruptions, and corrupted entities.

    it worked on a 850,000 chunk map. it was just 1 chunk that had lighting corruption.
  19. Offline


    I glad you were able to find the error!
  20. Offline


    oh but this is more important that just my map, the important part is that...


    it will be a all-in-one map decorrupter; never again have to delete a map
  21. Offline


  22. Offline


    Apparently, someone thought that:
    content was: "{{Delete|We don't do plugins, this isn't any different|- mbaxter 01:46, 13 September 2012 (EST)}} Server Remote Toolkit is a suite of componen..." (and the only contributor was "Drdanick"))
    So, plugin doc isn't for the bukkit wiki.
    Imho, if this gets submitted to , they do have a "Page" section that may be suitable for this.
  23. Offline


    your wiki is gone and IDK how to get this plugin to work and this is the only way to get JSONAPI to work and the windows batch file does not work. and if i put the .jars i get crap.
  24. Offline


    Oh dear, I'm not entirely sure all what you said. Yes, we know the wiki is gone, check the last few posts.
    Also, if you check the IRC channel, the MOTD includes this pastebin link:
    as a temporary place of what was in the Wiki contents.
  25. Offline


    Ok I have tried going to the IRC and every time I go then no one ever responds to me so I'm going to try and post here. I have followed the instructions posted in your pastie link and I get an error when trying to start it up. It says somthing about a user not specified and it cannot start up or somthing close to that, but I edited the file that I was suppose to. I know the is kind of vague and I can provide the exact error if needed, I just am not home right now to get it. So what am I doing wrong?
  26. Offline


    Well, to begin, there are two parts to the toolkit, the launcher, and the plugin. Make sure you know what the difference is first ;)
    Here are some key points in the setup (As an example):
    If you're on linux, the command line to start should be nearly identical. Notice where it has the section "admin:thepassword". On the default, I believe it is "user:password" which you should change.
    More details if you continue to have issues ;)
  27. Offline


    Ok well Im trying to start this up with Multicraft which may be what the issue is. What I did is installed the plugin, started the server and let it install. Then I shut it down, uploaded the new jar and the other files I need in the root, then restarted the server with the toolkit jar instead of the craftbukkit.jar. I edited the files before I uploaded them to replace the user and password, also with the proper name of my craftbukkit.jar. I tend to try to figure out how to do things before I go running to ask for help, so I have tried to figure it out. I just don't know if it is because Im trying to start it with Multicraft or not since this is what my host uses.
  28. Offline


    Oh no, this plugin won't be useful at all if you're using Multicraft, as the functionality is built into the web application. The primary purpose of this is to ensure that the server remains running, and provide a remote console if you're not at the actual computer. Multicraft provides both of those when you login as an admin, and at least the console if you're just logging in as an owner.
    If you have Multicraft running OK, you should take a look at the server setting pages (On the demo site, login as "admin" at and then click Show Advanced options).
    As a matter of fact, since this toolkit requires a second process spawned (there's the toolkit one's and the actual minecraft server) your issue is probably related to an incompatibility between Multicraft and the toolkit itself.
  29. Offline


    if restart guaranteed why if my server crash and hang (bukkit) I cant do anything? I just see no response to .hold or I seee

    13:47:11 [INFO] Read timed out
    13:48:16 [INFO] Connection reset
    13:49:05 [INFO] Read timed out
    Stopping and holding the server...
    13:50:09 [INFO] Read timed out
    13:50:25 [INFO] Read timed out
  30. Offline


    Are you using both parts of the toolkit (launcher and plugin)? the .hold command only works when you're using the launcher part. If you had a stack trace from the console that would help as well.
  31. Offline


Thread Status:
Not open for further replies.

Share This Page