Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    Hey @drdanick,
    I agree with Jobsti we started to have colors ... but we can't see what we type in console since this build 1.3.1-R2.1 (Build #02351)
    Thank you.
  3. Offline


    Jep, now also on #2351 ;-)

    Console says "...checking presence of RTK Plugin..." 3 times. After that, the heartbeat will be disabled.

    Also hold, stop and restarts took very long time! (Now 70 seconds; before -> 1-3 seconds)
    2012-08-24 06:06:27 .restart
    2012-08-24 06:06:28  ...forcing save... (shutdown delayed)
    2012-08-24 06:06:28 [INFO] CONSOLE: Forcing save..
    2012-08-24 06:06:28 [INFO] CONSOLE: Save complete.
    2012-08-24 06:07:38 [INFO] restarting...
    I think, it's the "new" scheduler.
  4. Offline


    Jobsti Soup This is due a bug (I assume) in the latest development build where jline cannot be correctly disabled through the usual means.
  5. Offline


    Wrote this a few times without response... :

    I would love this feature: have it somehow rotate the server.log file so it's not so HUGE if left running for a few days. Have it rotate daily.. or something configurable?
  6. Offline


    I like this Bug, this should be a feature ;)
  7. Offline


    I like the colors back, but I'd prefer to be able to see what I'm typing.
  8. Offline


    Same problem with Jobsti. Restarting took very long time :)
  9. Offline


    Uh, the 1.3.2 Beta is out... Would be nice to have a RTK build against b#2352
    And Option to press UP in Console, like vanilla Console, for last entered texts
  10. Offline


    Oh no :(, this is not compatible with 1.3.2 CB Beta build, because they changed console a lot (colors added) and heartbeat and typing in console does not show up (-Djline.terminal\=jline.UnsupportedTerminal does not help)
  11. Offline


    I would love to make a contribution to support the dev to continue on this project and release 1.3.1 and 1.3.2 compatible build as soon as possible
  12. Offline


    As I have said, this is a bug on bukkit's end. There is nothing I can do until they fix it. If they're not going to do something about it in a reasonable about of time, I’ll see what I can do myself. And yes, this also applies to the toolkit taking a minute to shut down. With JLine enabled, it cannot parse console output correctly. This is an issue when it waits for the save-all to complete before shutting the server down, since it must now time out while waiting for the response before shutting down.

    Try this in

  13. Offline


    Does not work and spams the console with errors that no does not exist, etc.

    Not being able to see what I typed is pretty ugly. I really hope bukkit or someone can look at this soon. :(


    Seems to work for now. So anyone having trouble seeing what you can type, etc add that to your
  14. Offline


    because the searcht this thread button doesn't work correctly for me, i post my question (maybe again)

    when i use the remotetoolkit, is it possible to enable the command history? when i start the toolkit and tip the "arrow up" key i only get "^[[A" and not the last command :(
  15. Offline


    works :)
  16. Offline


    -nojline fixes the issue with not being able to see your input but it doesn't fix not have the ">" prefix to your text and command history that is in bukkit.
  17. Offline



    I've confirmed this happens only with your wrapper. I've had a vanilla and bukkit instances run that don't have the text randomly "backing out"

    Show Spoiler


    To this. It looks like something is hitting the backspace. And no, no one else is in the console.
    Show Spoiler

  18. Offline


    Can you clarify what you mean? Are you saying that a portion of your console text (more than one line) is wiped occasionally?
  19. Offline


    Yes, that is correct. And it is completely random. Only from the console though, it remains in server.log. If I am in mid typing for example, /say Hey guys, blah blha blha... it will still have it there and I can press enter and it will send whatever was wiped.

    I haven't tried it yet with --nojline.

    I'm on CentOS 6.3 with Java 1.7.0.
  20. Offline

    AadamZ5 socket closed

    I get this whenever i try to call a command in the UDP Client

    Im running it on port 25565.
    Thats all the data I have.
    (I started the srerver with the RTK batch file)
  21. Offline



    And it just happened again with --nojline.
  22. Offline


    I just get RTPING>RTPONG++ and it never finds the plugin... but its there... never had a problem before the beta build of Craftbukkit
  23. Offline


    someonexh I am intentionally leaving that for someone to implement as a module for R11. R10 is currently in a feature freeze.

    Check that UDP port 25561 is forwarded on your router, and that you do not have a firewall blocking UDP traffic to that port.

    This may be a lot to ask, but can you confirm that this happens without any plugins running, and also on a vanilla server run through the toolkit?

    In, set this:
  24. Offline


    No luck. still doing it

    First attempt at checking for presence of Bukkit RTK plugin...
  25. Offline


    I can try it out on my Snapshot server for Vanilla.
    I'm sure I can try without any plugins on a test.

    Edit: Pardon my derp... My test server was using a very old build(1.0_b18_23)....... xD We'll see what happens lol.... *sorry*

    Hmm... Undo that edit. I'll get it testing with and without --nojline. It did it again, but this time it threw "RTPONG++" at the end of the line.
  26. Offline


    I just updated to MC 1.3.2 and started getting the same thing. It will try three times then disable itself until I restart the server.
  27. Offline


    I'm running it on port 25565.

    Does the remote UDP client have a separate port that I can't change?

    And plus, I portforwarded port 25561, addded a rule to the firewall, and i still get the same error. And, what should I set the "Salt" value to? AND my server is running on port 25565, should I enter <my IP address>:25565, or <my IP address>
  28. Hello all !
    I just had the problem of not finding the RTK plugin.
    But it was working fine before, so i know what i changed : i tried using bukkit beta build 1.3.2-R0.1 (to install NoLagg) instead of the latest recommended builds, 1.3.1-R2.0.
    Could you make it working with this version of bukkit ?
  29. Offline



    The wipe just occurred on my Bukkit (1.3.2-R0.2 build 2352) with no plugins (besides your MinecraftRKitPluing.jar) with --nojline argument. Right after this occurred, " RTPONG++" popped up at the end as shown in the spoiler. It was running for about 2 hours and 30 minutes before it happened.

    Show Spoiler


    I haven't noticed this happening with Vanilla at all. I will now try without your plugin running on Bukkit to see what happens.
  30. Offline


    I get that all the time, it doesn't mess with the server.log file though, so it's not damaging.
  31. Offline


    Could you possibly add color support?
Thread Status:
Not open for further replies.

Share This Page