Remapping Particle Library

Discussion in 'Plugin Development' started by Aplexty, May 24, 2022.

  1. Offline

    Aplexty

    Hello, I am getting into java development (next to no experience lol sorry).

    I am trying to update our particle library, currently on 1.12.2 and using the Darkblade Particle library but it does not contain the full particle list associated with 1.12.2. I did read that it would be possible to add later game particles but it's trickier with reflections etc.

    Currently, the particle library is linked to a plugin where the player holds a specific item they get particles around them. When I look for particles they all say its compatible with my version but updated to 1.18 will this be alright aslong as it links up properly?

    I understand not being able to see my screen will be difficult I can paste the example of the code below. So what in this is the particle library from Dark blade? What variable is the reference if you can see? This Particle effect links to a Particle Tick. So just trying to define where this library is and how I can remove it and import a newer version.

    import java.lang.reflect.Constructor;
    import java.lang.reflect.Field;
    import java.lang.reflect.Method;
    import java.util.Arrays;
    import java.util.HashMap;
    import java.util.List;
    import java.util.Map;
    import java.util.Map.Entry;
    import org.bukkit.Bukkit;
    import org.bukkit.Location;
    import org.bukkit.Material;
    import org.bukkit.entity.Player;
    import org.bukkit.util.Vector;
    import think.rpgitems.other.ReflectionUtils.PackageType;
    /**
    * <b>ParticleEffect Library</b>
    * <p>
    * This library was created by @DarkBlade12 and allows you to display all Minecraft particle effects on a Bukkit server
    * <p>
    * You are welcome to use it, modify it and redistribute it under the following conditions:
    * <ul>
    * <li>Don't claim this class as your own
    * <li>Don't remove this disclaimer
    * </ul>
    * <p>
    * Special thanks:
    * <ul>
    * <li>@microgeek (original idea, names and packet parameters)
    * <li>@ShadyPotato (1.8 names, ids and packet parameters)
    * <li>@RingOfStorms (particle behavior)
    * <li>@Cybermaxke (particle behavior)
    * </ul>
    * <p>
    * <i>It would be nice if you provide credit to me if you use this class in a published project</i>
    *
    * @author DarkBlade12
    * @version 1.7
    */
    public enum ParticleEffect {
     
  2. Offline

    DopeBrot

    if i understand correctly you want to update a particle library?
    and the library does not support newer particles?
    i think what you'll need to do is add some enums like:
    Code:
    YOUR_PARTICLENAME("particleNameInMinecraft", id, version),
    if this is not what you're trying to do then please explain it to me once again maybe i can help :)
     

Share This Page