RegionOwn for Java 7

Discussion in 'Archived: Plugin Requests' started by Iomega0318, Sep 13, 2012.

  1. Offline


    First off this plugin already exists but haven't heard from the developer in well over a month his code is open source and is available at his github both the link to the plugin and github are below:

    What I want: Me and a few others are having an error with the plugin and a user stated it was due to the plugin being compiled with Java 6, although I thought Java 7 was backward compatible the plugin fails to load as stated here:
    I cannot use Java 6 as some of my other plugins require Java 7 so my question is this:

    Can someone please compile the plugin to work with Java 7 for us to use? I have tried compiling plugins in the past but have little Java experience and it failed miserably lol..

    When I'd like it by: As soon as you can.
  2. Offline


    HE LIED! :O
  3. Offline


    What lol? Here is the error I get if it helps..
    [SEVERE] Error occurred while enabling RegionOwn v0.2.0 (Is it up to date?)
            at com.codisimus.plugins.regionown.RegionOwn.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(
            at net.minecraft.server.MinecraftServer.t(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
  4. Offline


    uh... maybe read the very first line? :eek: ''(Is it up to date?)''
  5. Offline


    You couldn't load plugin if it were compiled with java 7 and you were using java 6, not backwards..
    The error writes that something in the code has a value of null and cannot be used, so its the plugin fault.
  6. Offline


    Maybe read the Bukkit Plugin page 0.2.0 is the latest version. ;)

    That's kind of what I was thinking with the Java bit.. You wouldn't happen to be able to fix it then would you lol?
  7. Offline


    Why are you talking in bold text?
  8. Offline


    Just wondering, what version of craftbukkit are you using?
  9. Offline


    I've answered this several times on this forum and this is completely irrelevant to the topic, but it's just the style I prefer to type in and use on pretty much every forum I post on, I also color it green.

    It's an MCPC build of 1.2.5.
  10. Offline


    It load's pretty fine for me on both 1.3.1 and 1.3.2.
  11. Offline


    Can I ask if your using Java 6 or 7?
  12. Offline


    I'm using java 7. And the plugin fails on loading, correct?
  13. Offline


    It gets past the world loading and then when it, I assume goes to enable it, throws out the error.

    Hmm so I decided to do some testing.. using a fresh folder I placed nothing but the following:
    and the MCPC build my server is using.
    I then started it up, mind you my server uses Java 7 right now, and no error it actually even works as expected in game! So this leads me to believe it is conflicting with either another plugin or a mod.. is there any way besides one by one to find if anything is conflicting?

    Confirmed it is not a mod, the plugin still works with all 60 I was using.
    Testing Plugins.

    Ok now I am confused even more lol.. I found out that with all 30 of my plugins loaded WorldGuard is actually causing the issue, once removed RegionOwn loads fine.. However if I load the server with WorldGuard, RegionOwn and Vault it will still work fine, which again leads me to believe it could be another plugin but then why does it work with all my plugins by just removing WorldGuard..

    I attached a list of my plugins, if someone can help me figure it out that would be awesome..
    View attachment 11154

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 28, 2016
  14. Offline


    The error occurs when it attempts to register the command. Did you by any chance edit the plugin.yml file to change the command from 'region' to something else? If you did then you may have formatted the file wrong causing it to not find the command. If not then here is a temporary fix that should work for you.

    p.s. the plugin is compiled with Java 7
  15. Offline


    Ahh ok I wasn't sure if it was or not, but cool. and glad to see your alive lol!

    and no I didn't change anything.. with my listed plugins I still get the same error except this time it shows 0.2.1 but upon deletion of WorldGuard it works fine again.. so it's conflicting somewhere somehow because with just WorldGuard/WoldEdit on the server with your plugin it works fine.. but with all my plugins WorldGuard is the only one I have to remove to get it to work again.. very strange..
  16. Offline


    Blah freaking blah blah blah!

    So I've been up all night bored and I don't know why but I thought about what you said about changing the commands.. well it got me thinking what commands does WorldGuard use.. SO I Googled it.. turns out your plugin and WorldGuard BOTH use /region.. Although I cannot explain why your plugin will work alone with WorldGuard and why with many it does not but it would explain why just removing WorldGuard it would work.. SOOooo I am going to test that theory here in a bit and get back to you, but for now here are the commands for both plugins.

    Confirmed, when the command was changed from /region to /regionown it will now load with WorldGuard, again can't explain why it will work with just WorldEdit/WolrdGuard but not with a bunch of plugins.. but got it to work so yay!

Share This Page