"Read Timed Out" This needs to be fixed!

Discussion in 'Bukkit Help' started by rockxz2135, Aug 9, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I run a dedicated server and I get "Read Timed Out" errors at random times. I have searched and looked through countless threads and realized this is a big issue that NEEDS to be fixed.
    Server Specs:
    Host: server4you.com
    OS: Windows Server 2008 SP1
    RAM: 12gb DDR3 (6gb dedicated to the server)
    Connection: 100mbit
    HDD: I have two 1TB drives one for the OS the other for the server ONLY
    Permissions 3.x
    Note: I tried running the server with these plugins but it still generated read timed out errors, I normally use more plugins!
    Bukkit version: Build #1000
  2. Offline


    Can you send me the error
  3. Offline


    'Read Time out' usually means that packets are not being sent properly from one end to another, or they are not getting all of it, it's not an issue with bukkit, it's an issue with your own personal ISP, contact them to get a better internet connection =]
    This happens on things more than bukkit, for example:
    Other games such as Team Fortress
    Even skype!
  4. Offline


    2011-08-09 12:21:10 [INFO] Read timed out
    2011-08-09 12:21:10 [INFO] Read timed out
    2011-08-09 12:21:10 [INFO] Rmondo210 lost connection: disconnect.endOfStream
    2011-08-09 12:21:10 [SEVERE] java.net.SocketException: Socket closed
    2011-08-09 12:21:10 [SEVERE]     at java.net.SocketOutputStream.socketWrite(Unknown Source)
    2011-08-09 12:21:10 [SEVERE]     at java.net.SocketOutputStream.write(Unknown Source)
    2011-08-09 12:21:10 [SEVERE]     at java.io.BufferedOutputStream.flushBuffer(Unknown Source)
    2011-08-09 12:21:10 [SEVERE]     at java.io.BufferedOutputStream.flush(Unknown Source)
    2011-08-09 12:21:10 [SEVERE]     at java.io.DataOutputStream.flush(Unknown Source)
    2011-08-09 12:21:10 [SEVERE]     at net.minecraft.server.NetworkWriterThread.run(SourceFile:116)
    2011-08-09 12:21:10 [INFO] donimo lost connection: disconnect.endOfStream
    2011-08-09 12:21:15 [INFO] Connection reset
    2011-08-09 12:21:15 [INFO] bleckfisken123 lost connection: disconnect.quitting
    2011-08-09 12:21:21 [INFO] Connection reset
    2011-08-09 12:21:21 [INFO] dirtbiker14 lost connection: disconnect.quitting
    It just happened again!
    2011-08-09 14:12:18 [INFO] FactionChat loinhearts: **Kitteh53 he had torches :d
    2011-08-09 14:12:18 [INFO] / lost connection
    2011-08-09 14:12:18 [INFO] [*loinhearts Factions][Citizen]shawick: dont hurt us
    2011-08-09 14:12:19 [INFO] [Celts Factions][Citizen]blake74: thx
    2011-08-09 14:12:23 [INFO] [**Celts Factions][Citizen]gordan_frohman: Dont worry
    2011-08-09 14:12:28 [INFO] [**Celts Factions][Citizen]gordan_frohman: we are freindly
    2011-08-09 14:12:28 [INFO] Creating user kevinaapp
    2011-08-09 14:12:31 [INFO] [HeroicDeath] fredfar fell into the Gap
    2011-08-09 14:12:37 [INFO] Connection reset
    2011-08-09 14:12:37 [INFO] catattacks lost connection: disconnect.endOfStream
    2011-08-09 14:12:40 [INFO] FactionChat loinhearts: **Kitteh53 hes comming back to get his stuff back
    2011-08-09 14:12:48 [INFO] Creating user ElementalBubble
    2011-08-09 14:13:25 [INFO] Connection reset
    2011-08-09 14:13:52 [INFO] Read timed out
    2011-08-09 14:13:59 [INFO] Read timed out

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  5. Offline


    This happend to me sooo many times people always time out , 2 things this could be happening because your connection may be lower than normal and they time out or there connection is low/bad that it will disconnect them!
  6. Offline


    Are yall just gonna ignore my post?
    Upgrade your own personal internet to fix this.
  7. Offline


    I will call my server host find out the problem if it is them and it gets fixed I owe you $10 :D
  8. Offline


    Erm, you don't owe me anything
    I think it may be your own ISP and not your actually VPS host, I'll make a quick post on what Read Time Out is right now.
  9. Offline


    It's not hosted on my home network. I host it on server4you.com
  10. Offline


    You need to understand that it might not have anything to do with the server, everyone has a different connection to that server.

    Thats why some people get lag and some dont, if you are connecting to a server thats 50 miles away your going to have a better connection then the guy who is 3000 miles away.

    He is telling you to focus on your own ISP first, not the servers ISP.
    JerriCop likes this.
  11. Offline


    OOOoooo I see
  12. Offline


    That's what I said it's jut a socket error just bad connection
  13. Offline


    So if I play on the server it will generate this?
  14. Offline


    Try going to a friends house and playing, see if that fixes it. If so, it's your internets problem.
  15. Offline


    It happens to me all the time, usually happens randomly
  16. Offline


    I am not talking about me only getting kicked im talking the entire server freezes and no one can join, then it generates read timed out errors everytime someone tries to join.
  17. Offline


    I use no-ip.com it hosts really good, And make sure you port forward too correctly
  18. Offline


    Listen up. The [INFO] Read Timed Out in a MineCraft server has absolutely nothing to do with client/ISP connectivity, since the server completely freezes and everyone is booted and can't reconnect until the Java task is killed in some other fashion. It's not pretty, it kills people's work and player data and no one out of the hundreds who are getting this error can find a cause.

    So far, the most identifiable cause is probably map corruption. No one has come up with a definite fix yet. Even the Chunkster region scanner did nothing for me. Plugins don't seem to matter too much, though Worldguard and Worldedit seem to be the most popular ones I see on problematic servers (but it might be just due to the fact that they are popular plugins). Even this claim is disputable because some players have reported completely wiping their maps and restarting fresh to no avail.

    My story: I never got the error until one day my RamDisk ran out of memory and stopped the map from saving, leading to OUT OF MEMORY errors. Ever since my RamDisk size was increased to supplement a growing world, I've gotten the [INFO] Read Timed Out errors and the problems associated with them.

    Until a fix is found, Rockx, use Dr.Danick's remote toolkit as your server wrapper (it's a bukkit plugin). Configure it to auto restart after 2 heartbeats are missed and it will automatically force close java and restart the server on [INFO] Read Time Out errors. That way, at least you don't have to babysit your server. Set the auto save to 5m and the auto restart to 1h and you will save your players a lot of problems too. Good luck, and I hope this issue starts getting a little more attention. It's a real buzz kill.
  19. Offline


    I found a fix for my issue I used a custom permissions 3.x
    Fixed the problem hope it helps anyone in this forum!
  20. Offline


    Permissions 3.1.6 --> PermissionsEX, bPermissions or whatever.
    If you are having Read timed out errors AND using permissions 3.1.X try other permissions.
  21. Offline


    Hey there Trollkemada :D I see the Read Timed Out error club is growing by the day.
    If only a solution could be found that works for everyone.
    rockxz2135 likes this.
  22. Offline


  23. Offline


    I don't know I just installed it and My read timed out errors stopped I have had only one since posting that here My server no longer freezes so it had something to do with permissions 3.x
  24. Offline

    The Xlias

    This same thing happens to me, and I think it is the connection. But then, why can't I log on to my own server within the firewall? And even if I have great connection, it doesn't say "Read Time Out," the user just freezes on "Downloading Terrain"
  25. Offline


    Here also happened, but I think it can be the plugin, we had in common

    Permissions 3.x

    I removed WorldGuard and put Residence, and did not happen anymore.
  26. Offline


    The problem is permissions switch to permissionsEx(PEX)
  27. Offline


    Don't necro old threads, especially ones that are over 6 months old. -_-
  28. Offline


    You're running out of RAM, at least according to my experiences. You likely have a memory leak. Get some plugin which keeps a log of RAM usage and you should see it gradually trend upward, and then when it's about to hit the limit you will get the "Read Timed Out..."
Thread Status:
Not open for further replies.

Share This Page