Read Timed Out - IT IS BUKKIT! (Error in post)

Discussion in 'Bukkit Help' started by Flenix, May 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hey guys,

    We, as many others, have been getting Read Timed Out a lot on our server. I have been trawling through posts, to try and work out where it was coming from. I made a list of everyones plugins who had listen them, and ruled out plugins which weren't in common - the only one EVERYONE had was WorldEdit.
    Today, I tried removing that from our server, still got it. Its also been happing a lot more today, as often as every 5-10 minutes now (I've given up rebooting, I'm leaving it til later)

    Anyway, a few times the server has chucked out this error at the same time:
    2011-05-15 11:17:53 [INFO] Read timed out
    2011-05-15 11:18:17 [SEVERE] Broken pipe
    2011-05-15 11:18:17 [SEVERE]     at Method)
    2011-05-15 11:18:17 [SEVERE]     at
    2011-05-15 11:18:17 [SEVERE]     at
    2011-05-15 11:18:17 [SEVERE]     at
    2011-05-15 11:18:17 [SEVERE]     at net.minecraft.server.Packet51MapChunk.a(SourceFile:65)
    2011-05-15 11:18:17 [SEVERE]     at net.minecraft.server.Packet.a(
    2011-05-15 11:18:17 [SEVERE]     at net.minecraft.server.NetworkManager.e(
    2011-05-15 11:18:17 [SEVERE]     at net.minecraft.server.NetworkManager.d(
    2011-05-15 11:18:17 [SEVERE]     at
    2011-05-15 11:18:17 [INFO] Connection reset
    Not sure if it is related at all.

    Anyways, I've since found other posts of people who had disabled plugins and even created a new server, Bukkit is the cause of the error :(
    Do the Bukkit team know about it, and if so are they working on it? I've searched but theres been no posts (that I could find) from any of them about it...

    Edit, here is the form thing:
    1. OS: Windows 7 32 bit
    2. architecture: x86
    3. Not sure what was wanted, so here is everything that appeared:
    Linux 2.6.18-194.26.1.e15.028stab079.2 #1 SMP F
    ri Dec 17 19:25:15 MSK 2010 x86_64 x86_64 x86_64 GNU/Linux
    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine

    4. No wrappers, our hosts do offer a hosting policy but we have root access.
    5. Were using 733 earlier, updated to recommended (766?) today but made no difference.

    Now that you've given us all the basics, now we get into the more advanced stuff. Note, if you haven't answered 1-5 yet, answering 6-10 will be almost pointless.

    6. ./
    7. Irrelivant, already worked out plugins aren't causing it. I can get a list though, but its long...
    8. See above!
    9. "Everything" - tried disabling all plugins, and running vanilla. Vanilla is fine, just CB gives the error, CB with plugins gives the error
    10. Yes I tried the steps mentioned

    Is anyone else getting it this badly? We have an automatic save feature that saves every 5 minutes (got it because of this error, it usually makes us rollback to last save) - most of the time it doesn't even stay up long enough to save...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 16, 2016
  2. Offline


    Last edited by a moderator: Jul 16, 2016
  3. Offline


    Only problem with local is the loss of players, and downgrading most mods don't offer their back versions (which is annoying, doesn't hurt to just move it to a dropdown section or something...)

    And I've been getting Read Timed Out for a long time now, just recently got worse, the Broken Pipe seems to be linked. I don't know which build would be safe from it?

    I can't see anything on there?
  4. Offline


    I get that damn error too, and then the server crashes.
  5. Offline


    The "damn error" might just end up being the end of my server. :(
  6. Offline


    So you're getting that exact error?
    Is there any real error or does the server just go straight to that?
    Are there any players online when the error starts?
    If so, are they connecting through localhost?
    How much RAM do you have allocated to the server?
    What startup script are you using to start the server?
    vvv Also answer TnT's question below vvv
  7. Offline


    What firewall are you running?
  8. Offline


    The server lags out every 3 minutes, so the players that don't go to our website just figure that it's broken and have left. Those that do go to the website and see what the cause for the lag is, don't have the patience to wait for a new build. I'd be happy if I had 3 players left by the time the Bukkit team figures out this issue.
  9. Offline


    Any way that you could post a full server.log on pastebin?
  10. Offline



    So you're getting that exact error?
    Mostly. I haven't seen that exact broken pipe error. But everything seems to be centered around the sudden appearance of "Read Timed Out"
    Is there any real error or does the server just go straight to that?
    Not unless a "Connection Reset" could be related.
    Are there any players online when the error starts?
    Yes, however there have been cases when there were only 1.
    If so, are they connecting through localhost?
    No, it's a public server. However, I do connect through localhost at times.
    How much RAM do you have allocated to the server?
    This thing bugs me. According to GC I've got 2133 MB allocated (but there's usually 1000MB free when the errors start) even though the server itself has 6GB. For some reason, if I try to set RemoteToolkit config for about 3 gigs, it just freaks out when I try to start the server. Could it be a problem with Java?
    What startup script are you using to start the server?
    I'm using RemoteToolkit. So, it starts up with "java -Xmx40M - Xms40M -XX:MaxPermSize=50M -jar Minecraft_RKit.jar ${USER}:${PASS}" But that obviously tells you nothing.

    I'll try to get a full server.log now... Should I move this to another thread? :/
  11. Offline


    Okay, since it's hosted locally, are you usually online when the problem starts?
    Do you have 64-bit java?
    Okay, that should help. Nah, it can stay in this thread.
  12. Offline


    Okay, since it's hosted locally, are you usually online when the problem starts?
    Nope, when I logged on tonight, people were complaining that it had been happening all day.
    Do you have 64-bit java?
    Uh oh... I think it may be 32-bit... Could this be the problem?
    Okay, that should help. Nah, it can stay in this thread.
    All right, I'll get it as soon as possible. Unfortunately, my server.log is just an incredibly long text file containing information from a LONG time ago, so it's incredibly difficult to sort through and impossible to upload the entirety of up to pastebin. I just restarted the server and cleared the log. As soon as the error happens again I'll upload it.

    EDIT: Suddenly the server is running without errors. It'll probably happen again soon, but I can't get a good log until it does.
  13. Offline


    32-bit java can only handle processes with <1.5GB of RAM. If you upgrade to 64-bit java, you can use as much RAM as you want (but it probably won't fix this problem unless it's an outOfMemory error that starts it)
  14. Offline


    Hmm... I think the actual server is 64-bit, is it possible that I just downloaded the wrong version?

    EDIT: I had to log into the server from localhost due to an error with PortalStick (needed to reload the config) and suddenly the error happened. I don't see how it could be a Localhost thing, since it wasn't caused by me before, but I got a pastebin regardless:
    EDIT2: It didn't seem to entirely stop the server this time... For some reason it only momentarily lagged it like hell. I left and now it doesn't seem to be lagging.
    EDIT3: I'm sorry, but I need to go for tonight. If you've got any final suggestions I'm incredibly happy to hear them. Otherwise, I'll report back in like 20 hours if anything has changed. I don't wanna Jinx myself, but I think the 30 minutes I spent screwing with the most recently added plugins might have done something...
  15. Offline


    Yeah, just google 64-bit java and download/install it.

    Okay, problems I see with the startup log:
    • Misc error with ExtraHelp.jar; drop that plugin for now
    • In LogBlock's configuration file, you want to make sure that the user is minecraft, database is whatever you set it as (probably minecraft), and server is localhost. If that doesn't work, make sure you have SQLite installed and set up.
    • Make sure that Essentials is up to date.
    • Update iConomy
    • Delete NoCheatPlugin and install NoCheat (same plugin, new name and you're like 30 versions behind xD)
    • Make sure you didn't accidentally uncomment a comment line in DynMap's configuration file
    • Delete all your configuration files for Citizens, looks like one may be corrupt
    • Update PortalStick
  16. Offline


    All set other than Citizens. I've been aware of the corrupt config and I know I have to clear it, but I need to find some of the players who bought traders and get their items out of those NPCs first. Thanks for the help, I'll make sure to post back if anything continues.

    And the error is still occurring... D:
    ... Just asking random questions here, but what would the solution be if the problem was caused from someone logging on from localhost? I'm not positive it's the cause, but I did notice that today, the major lag started as I logged on and stopped shortly after the server noticed that I had left. :/

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 16, 2016
  17. Offline


    Not much you can do if you're playing on the same system as the server and you get lag - other than not playing on the same server.
  18. Offline


    ... Not on the same SYSTEM, on the same network. I'm connecting from a different box, but the same IP. Sorry if this wasn't clear.
  19. Offline


    My server too says read timed out
  20. Offline


    Getting that error too.
    When people are getting kicked, They recieve a "Read timed out" error.
    Same system as above, Java is 64 bit, there was no problem untill 2 days ago when it suddenly appeared, without updating or changing anything.
    EDIT: It also makes the server lag like hell...
    EDIT 2: Heres my portion of the log
    00:57:36 [INFO] 1306015056461
    00:58:34 [INFO] Read timed out
    00:58:35 [INFO] bharel lost connection: disconnect.endOfStream
  21. Offline


    Any news guys?
  22. Offline

    Daniel Heppner

    This might be helpful: I'm running a 16 player server on 512mb of ram (Java's Garbage Collector is working hard.) and I haven't had this error even at 16 players. One thing I should mention, however, is that I HAVE been disconnected randomly. Actually, it was everyone on the same network as me. Everyone else on the server was fine. My server is hosted at a Softlayer datacenter. I'll record the error and see if it's the same next time it happens. I hasn't happened much, though.
  23. Offline

    Mr. eXoDia

    I (kinna) discovered that it is a problem of my network adapter. I am running a bukkit 803 server with lots of plugins. BUT when I remove all plugins and my world my brother that is on LAN gets the EndOfStream error. The weird thing is that other users that use Hamachi CAN connect to my server and play without any lag. But now Im getting to the point: My bro, who has ALMost the same motherboard as I do (with a different network card and processor) CAN connect if he uses Hamachi! Because we do not always have internet connection in our rooms we cannot play all the time. When I tried to connect from another PC to mine through the network it also fails. with hamchi: no problems. Furthermore I am running a legal (fresh) version of minecraft without mods or tex packs so that shouldn't be a probelm.
    The reason that I don't buy a new card is that my video card gets too hot so every ard I put in burns in like 1min :(
    Can others with this problem maybe try a different network card? To confirm that this theory is right (network card should be a different serie ofc) Im using an onboard network card btw.

    Sorry for the messy post,

    Mr. eXoDia // T.P.o.D.T 2011
    [email protected]

    PS join my hamachi to prove that you can connect without problems: ID: 'tpodt', no pass.
  24. Offline


    Bump. I have this from about 800 bukkit build And it is really annoying. Fix this Please!
  25. Offline


    Sorry for bumping this old thread. I have had this error since i first opened the server.

    I got this god damn error too in build 1185. Just now.

    Java Version :
    ava version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

    Start.Bat :
    java -Xmx768M -Xms768M -Djline.terminal=jline.UnsupportedTerminal -jar "craftbukkit-1185.jar" nogui

    Error Log :
    06.10 09:25:34 [Server] INFO If you get member rank, you will be able to build !
    06.10 09:25:34 [Server] INFO [Tips] Apply for member at
    06.10 09:25:28 [Server] INFO Read timed out
    06.10 09:25:13 [Server] SEVERE at
    06.10 09:25:13 [Server] SEVERE at Source)
    06.10 09:25:13 [Server] SEVERE at Source)
    06.10 09:25:13 [Server] SEVERE at Source)
    06.10 09:25:13 [Server] SEVERE at Source)
    06.10 09:25:13 [Server] SEVERE at Source)
    06.10 09:25:13 [Server] SEVERE Socket closed

    happens completely random time and completely random amount of players.

    i run 768Mb Server at 20 players. Sometimes 2 days without any lag or crash, sometimes only 20 minutes.

    it can happen when only 3 players online, 10 players, 20 players, completely random.

    And the worse thing is it rollbacked palyers inventory, position, and block placing / destroying.

    This errors is really bad for me and my community because it made us lost many many players from the server.

    My Plugins are :
    -Essentials (updated)

    My question :
    1. Is this caused by the internal server error ( config, plugins, etc ) or network error ( Firewall, router, etc)
    Thats all. I hope someone reply me because i know a lot of people are experiencing this error.
  26. Offline


    I get this all the time, to the point where my players can't be on without me constantly reloading it.
  27. Offline


    I believe I solved this awhile back by turning off sleep mode on my computer. It happened about every 30 minutes - right as my computer slept... It's worth a try if you haven't already turned off sleep mode. :p
  28. Offline


    Some of these suggestions are a bit silly. Its either a vanilla craftbukkit or spout issue - always has been. If you are getting read timed out errors (with no other errors visible in the console) and everyone gets disconnected this is due to the network handler methods in either CB or spout failing HARD. No fix for this iteration of this as I am aware.

    Also to further clarify - this issue had been put to bed for us until we updated to 1.2.3. Now it has reared its ugly head again.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 16, 2016
  29. Offline


    Been happening to me too
  30. Offline


    Good sir, I had the same error for a month or more back in December, and this suggestion is something people overlook, and it definitely solved my problem. No harm in trying...
Thread Status:
Not open for further replies.

Share This Page