"Read timed out" and "Socket closed" Errors

Discussion in 'Bukkit Help' started by Samzapp, Aug 10, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    My sister was building when suddenly she was disconnected and I got the following on the console:
    2011-08-10 17:08:12 [SEVERE] java.lang.OutOfMemoryError: Java heap space
    2011-08-10 17:08:20 [SEVERE] 	at java.io.ByteArrayOutputStream.<init>(Unknown Source)
    2011-08-10 17:08:24 [SEVERE] 	at net.minecraft.server.ChunkBuffer.<init>(SourceFile:253)
    2011-08-10 17:08:24 [SEVERE] 	at net.minecraft.server.RegionFile.b(SourceFile:242)
    After trying again, the error was:
    2011-08-10 17:54:23 [SEVERE] java.net.SocketException: Socket closed
    2011-08-10 17:54:23 [SEVERE] 	at java.net.SocketOutputStream.socketWrite(Unknown Source)
    2011-08-10 17:54:23 [SEVERE] 	at java.net.SocketOutputStream.write(Unknown Source)
    2011-08-10 17:54:23 [SEVERE] 	at java.io.BufferedOutputStream.flushBuffer(Unknown Source)
    2011-08-10 17:54:23 [SEVERE] 	at java.io.BufferedOutputStream.flush(Unknown Source)
    2011-08-10 17:54:23 [SEVERE] 	at java.io.DataOutputStream.flush(Unknown Source)
    2011-08-10 17:54:23 [SEVERE] 	at net.minecraft.server.NetworkWriterThread.run(SourceFile:116)
    The error displayed on Minecraft itself was "Internal exception: java.net.SocketTimeoutException: Read timed out"
    Someone please help me with this, or at least tell me a plugin that can fix it. I tried Chunkster already and it didn't show any errors.
  2. Offline


    I tried again later and got this:
    2011-08-13 10:13:33 [SEVERE] Exception in thread "Thread-5" java.lang.reflect.InvocationTar
    2011-08-13 10:14:09 [SEVERE] getException
  3. Offline


    Same error, happens every once in awhile.
  4. Offline


    Is there no solution?
  5. Offline


    Bumping ancient threads will not help. If you have your own thread, wait patiently for a reply :)
Thread Status:
Not open for further replies.

Share This Page