Quitting Putty without quitting the server

Discussion in 'Bukkit Help' started by kingblah, Sep 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hi guys, a bit of a novice here so bear with me ^^

    I've got a VPS running Ubuntu, and I've installed craftbukkit 1185 onto it. It works absolutely fine, I'm using putty to SSH into the server and start it up, but the problem is when I close putty, it seems to also shutdown the server. Is there any way to avoid this? Is it because I'm running the minecraft server as root? I'm a linux newbie so I'm really not well-versed in their multitude of gibberish commands so an explanation of what I'm doing wrong would be greatly appreciated :)

  2. Offline


    Use 'screen', google it :)
  3. Offline


    the usual way to run a program in the background so it continues running when you log off is to put an "&" at the end of the command you use e.g. "java -Xincgc -Xmx1G -jar craftbukkit-0.0.1-SNAPSHOT.jar &".

    but in newer builds this doesn't work for me (server acting weird) and scrren isn't available in my os...
  4. Offline

    Don Redhorse

    well you probably need to install screen...
  5. Offline


    screen is no longer available in freebsd since it was causing problems.
  6. I made 2 tutorials about, my english sucks but maybe it helps you...

    oh and type
    apt-get install screen
    if you don't have screen installed yet

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 20, 2016
  7. Offline

    Don Redhorse

    strange... do you have a link?
  8. Offline


    Just use nohup <command>.
    Like I have a start.sh file so : nohup sh start.sh
    It keeps it in the backround even if the remote session ends.
  9. Offline


    Hi guys, thanks for the suggestions, I tried that screen thing and it worked really well. However, encountered another problem (damn you Linux for never agreeing with me). Tried to connect to my server this morning and I get the following error: Internal Exception: java.net.sockettimeoutexception: read timed out.

    This is what it says in the console:
    2011-09-29 16:24:02 [INFO] kingblah [/] logged in with entity id 257 at ([mcserver] 23.28125, 84.875, 173.09375)
    2011-09-29 16:24:38 [INFO] kingblah lost connection: disconnect.endOfStream
    Along with a load of standard "Can't keep up! Did the system time change, or is the server overloaded?" errors which I always used to get even when I ran the server locally.

    I've tried manually adding ports at the end of the IP and restarting the server and I still can't connect. I haven't changed anything since yesterday so I'm really unsure why this is happening.
    Minecraft version is 1.8.1, craftbukkit version is 1185, the VPS is running Ubuntu 11.04 x64 with 1GB RAM and Java 1.6.

    Any help would be appreciated so I can get this damned difficult thing up and running!
  10. Offline

    Don Redhorse

    looks like the server is overloaded... in which case you can't connect... connect via putty and log at top
  11. Offline


    no, sorry. can'T find the link again... stumbled across it when i read about screen and had to realize it's not present in my system and no package is available. it said something about screen being removed somewhere during version 6.x and in 8.x only some sort of placeholder existing for it.
  12. Offline

    Don Redhorse

    I know you have problems when you are using su to change the context.. just wondering as all other distributions still have it... perhaps licensing?
  13. Offline


    hell what do i know? maybe it's because some minor differences between unix and linux? i can't tell...
    all i know is that somewhere between cb build 766 and 798 something changed and i cannot run cb in background with & anymore... only way now is nohup for me.
  14. Offline

    Don Redhorse

    hmm & isn't the screen program... but I have no idea about freebsd
  15. Offline


    no, it isn't :D i tried screen as an alternative and had to see that it's not present in my system.

    & is used to run a program in the background. it works for everything else and worked with cb up to buil 766.
    every later build results in a cpu load of 100% and weird console output although it should run in background.
    already made 2 threads about it but no help.
  16. Offline

    Don Redhorse

    ah ok, no idea..
  17. Offline


    Screen is in the ports.

Thread Status:
Not open for further replies.

Share This Page