Question QQ About Building CraftBukkit from BuildTools.jar

Discussion in 'Bukkit Help' started by oriamrm, Dec 10, 2021.

Thread Status:
Not open for further replies.
  1. Offline


    I was doing just fine with it until recently. Whenever I use BuildTools.jar, it creates a weird CraftBukkit.jar that only has org.bukkit.craftbukkit.bootstrap.Main.class and some other files, whereas something that looks quite like the actual CraftBukkit is only found in the META-INF of the jar. Thus I cannot use this file to write my plugins. Even the CraftBukkit I downloaded from has this issue. What am I missing here?

    If this isn't the right place to ask this, where should I go? I have known this awesome forum for years and I love this place :)
  2. Offline

    timtower Administrator Administrator Moderator

    @oriamrm 1. Don't use GetBukkit, it violates the DMCA.
    2. Which minecraft version?
  3. Offline


    1. Thanks. I really didn't understand how this site is still up.
    2. MC 1.18
  4. Offline

    timtower Administrator Administrator Moderator

    @oriamrm What other things do you get? As it doesn't create a CraftBukkit.jar by default I believe.
  5. Offline


    The command is:
    java -jar BuildTools.jar --rev 1.18 --compile craftbukkit
    So far it worked for previous versions... And that's the very straightforward instructions on spigot website.

    Does that answer your question?

    For org.bukkit.craftbukkit.* * net.minecraft.*: Used the jar that's within META-INF.
    For org.bukkit.* I downloaded the source code and compiled a jar myself.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 10, 2021
  6. Offline


    I had the same issue from the default spigot jar generated by build tools, with or without craftbukkit command. The solution I found was to use the jar located in the 'Spigot/Spigot-API/target/' folder instead. You can also use the shaded jar here to avoid dependency clashing as well. From what I understand it is the same jar minus the craftbukkit and minecraft sections. I'm assuming that either 1) it is a bug that default spigot output is missing the org.bukkit files or 2) they changed to using the API version for plugin development and haven't updated the docs yet. I suppose if you do need org.bukkit.craftbukkit or net.minecraft you can compile your own jar for now like you already did. I also tried the GetBukkit jars and they didn't work either, had the same issue.
Thread Status:
Not open for further replies.

Share This Page