Solved Port is open but still "can't reach server"

Discussion in 'Bukkit Help' started by Samwarez, Aug 12, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    This is probably more of a general Minecraft server issue, but I am using Bukkit so I guess this fits.

    I have a Bukkit server running on its own Debian 6 VM in on my ESXi 5 server. It runs great, I can access it via its internal IP and play around. However, it seems it cant be accessed via my public IP.

    FYI: The public IP from my ISP is static, and the minecraft server's local IP is a static dhcp assignment.

    Now at this point your probably thinking; another newb needs to forward his ports. However wile im new at pfSense I do believe that should do it:

    And its linked firewall rule:

    And to verify,

    and I think this shows that the Debian server is listing on port 25565

    For reference here is my
    #Minecraft server properties
    #Sat Aug 11 22:29:21 MDT 2012
    motd=Sams Testing Server
    Feel free to call me out on anything stupid I'm missing, but everything seems like it should be working but I still get the "Can't reach server". I'm going to make another basic Debian VM with a simple web server to see if thats accessable, but other then that I'm stumped.

    Anyone got any ideas?
  2. Offline


    i think the ip u entered in the destination part of port forwarding is wrong. usually it would be 192.168.blank blank.
    i have never seen one be
  3. Offline


    Depends on the network... most home routers use 192.169.blah.blah... but 10.1.blah.blah is quite common for older and larger networks.

    Does your OS have a firewall as well? I know with ubuntu you have to disable it within the OS. (ufw disable)

    Also, if you are using VM ware of some sort, does it create virtual network adaptors as well? You might have to bind the server to the external address if this is the case.

    EDIT : open a terminal window and run
    ufw disable
    double edit :

    Also, does this happen to others? I know there are some routers that wont allow you to use the external IP address from inside the network. Anybody using a Telus router in canada will know what I mean by this... it will appear not to work for those inside the network, but anybody external will be able to access it just fine.
  4. Offline


    Yea, its a Class-A network so my internal IPs are, I set it up that way for organization.

    As for the firewall, I never thought to check if Debian installed one by default. It looks like its does come with iptables enabled by default but set to accept all traffic. Here is mine:
    [email protected]:~$ sudo iptables -L
    [sudo] password for minecraft:
    Chain INPUT (policy ACCEPT)
    target    prot opt source              destination
    Chain FORWARD (policy ACCEPT)
    target    prot opt source              destination
    Chain OUTPUT (policy ACCEPT)
    target    prot opt source              destination
    The network adapter is virtualized and bound to a physical port on the server, I know that works because if it didn't it wouldn't work locally.

    Yea that's standard behavior for most routers, however accessing my MC server via my public IP worked previously when I was using MineOS+ in Citrix Xenserver.

    Crap, It just dawned on me that I swapped out my router (a WRT54GL running Tomato) for that pfSense box at the same time I swapped out the Xenserver for ESXi, so that might be it. Ill get some buddies to try it out.
  5. Offline


    im running ubuntu and didnt have to disable the firewall...just saying
  6. Offline


    One of the best things you can do :p

    You can also try:

    Make sure it's got the server IP entered and correct port (both 25565), click "Advance" and on Ping Type, select "Don't Ping".

    If it says Open, then you're server is accessible outside your network.
  7. Offline

    TnT Retired Staff

    What I would do:
    Make sure your WAN IP is correct.
    Get someone else to try to connect via your WAN IP. Your router may not allow loopback routing, or your ISP may be blocking your connection.
    Try a service like to test your port.
  8. Offline


    Buddies weren't online so I used my VPN through work, and it works! So it was my firewall high-jacking the local connection. So Lokpique gets the proverbial cookie, Thank you.

    Funny thing is, I had initially thought of the whole no-external-IP-from-internal-IP-cause-the-router-is-stupid thing, but thought "no way it could be that, lets spend hours digging through server files".

    Thank you everyone

    I wonder what I did to that WRT54gl that allowed the loopback connection?
  9. Offline


    Sometimes it's your router, sometimes it's also you ISP blocking a loopback. They have good reasons for this too, but I won't go into them hehe.

    Glad we could help you figure that out before you spent far too much time fixing something that was already working! (Been there, it sucks)

    Guessing you have a GUI with your Ubuntu as well.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
Thread Status:
Not open for further replies.

Share This Page