Problem/Bug Plugins don't work when server restarts

Discussion in 'Bukkit Help' started by EpiphoneKL, Dec 20, 2016.

Thread Status:
Not open for further replies.
  1. Offline

    EpiphoneKL

    Hey! When my server restarts select plugins stop working. The ones I seem to have problems with are LWC, SignShop, and WorldGuard. When I take the plugins out and put them back in they work but when my server does an auto-restart to save the world I get errors for worldedit and LWC and SignShop just stop working. Does anybody have any idea what it could be? They're all on their latest versions. Thanks!
     
  2. Offline

    timtower Moderator Moderator

  3. Offline

    EpiphoneKL

  4. Offline

    timtower Moderator Moderator

    @EpiphoneKL Please stop the server, start the server, stop the server.
    Then copy the entire content of the latest.log into pastebin.
     
  5. Offline

    EpiphoneKL

    Alright, here's what I pulled from it http://pastebin.com/b0reNSKe

    @timtower If it helps to know when I take out the plugins and put them back in and reload it works. But when my server restarts it comes back and it doesn't work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Dec 21, 2016
  6. Offline

    timtower Moderator Moderator

    @EpiphoneKL Kinda impressive, then you have a plugin that has the drivers needed for the database errors that you are getting.
     
  7. Offline

    EpiphoneKL

    Sorry about the double posting, it won't happen again. Would you mind expanding on that? Is it something to do with another one of my plugins?
     
  8. Offline

    timtower Moderator Moderator

    @EpiphoneKL You are missing a couple classes, not sure why you are missing them but it might be the server version.
    Due to those missing classes some plugins can't load.
     
  9. Offline

    EpiphoneKL

    @timtower That is weird.. I removed LWC and SignShop and WorldGuard works perfectly. Could it be something with those plugins?
     
  10. Offline

    timtower Moderator Moderator

    @EpiphoneKL WorldGuard has nothing to do with it.
    Just LWC and SignShop
     
  11. Offline

    EpiphoneKL

    Okay that's great to hear. Any suggestion on how to fix LWC and SignShop? They're pretty critical for the type of server that I'm running.
     
  12. Offline

    timtower Moderator Moderator

    @EpiphoneKL Don't know, they are missing files, you can ask the developers to add those.
     
    EpiphoneKL likes this.
  13. Offline

    EpiphoneKL

    @timtower Okay I'll try that out. Thank you so much for your help!
     
Thread Status:
Not open for further replies.

Share This Page