Solved Plugin works but after restart it disables....

Discussion in 'Plugin Development' started by VinexAx789, Jul 23, 2016.

Thread Status:
Not open for further replies.
  1. Offline


    Hey guys I'm honestly so confused. My plugin works but doesn't enable after the restart. It has never done this now it's doing this...
  2. Offline


    Do you meam that your plugin enables after restarts? Or when using /reload? Also, we need the following information to help you further:
    • Your plugin.yml file
    • Your Main Class
    • The console log
  3. Offline


    Seemed to fix it by deleting the plugin and replacing it back in.


    When ever the server restarts.

    I finally got the error

    23.07 06:34:20 [Server] ERROR Error occurred while enabling DTP v1.0 (Is it up to date?)
    23.07 06:34:20 [Server] INFO java.lang.NullPointerException
    23.07 06:34:20 [Server] INFO at com.venomsurge.dtp.DTP.onEnable( ~[?:?]
    23.07 06:34:20 [Server] INFO at ~[patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at [patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at org.bukkit.plugin.SimplePluginManager.enablePlugin( [patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugin( [patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugins( [patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at net.minecraft.server.v1_10_R1.MinecraftServer.t( [patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at net.minecraft.server.v1_10_R1.MinecraftServer.l( [patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at net.minecraft.server.v1_10_R1.MinecraftServer.a( [patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at net.minecraft.server.v1_10_R1.DedicatedServer.init( [patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at [patched_1.10.2.jar:git-Paper-818]
    23.07 06:34:20 [Server] INFO at [?:1.8.0_66]
    23.07 06:34:20 [Server] INFO Disabling DTP v1.0
    I might of fixed it, I accidently created a map last night that didn't have spawns nor lobbies etc. So therefor it wouldn't load...
    Last edited: Jul 23, 2016
Thread Status:
Not open for further replies.

Share This Page