Plugin won't load

Discussion in 'Plugin Development' started by AlfieJay, Jan 16, 2020.

Thread Status:
Not open for further replies.
  1. Offline

    AlfieJay

  2. Online

    timtower Moderator Moderator

    Moved to plugin development
    @AlfieJay Add an : after hello
     
    AlfieJay likes this.
  3. Offline

    pietermantel

    Your plugin.yml command definition is not correct. You must also give a usage and description of a command:
    Code:
    main: me.AlfieJay.HelloWorld.Main
    name: HelloWorld
    version: 1.0
    author: AlfieJay
    commands:
        hello:
            description: Says hello to the player
            usage: /hello
     
    AlfieJay likes this.
  4. Offline

    AlfieJay

    I tried doing that but I still get an error message (https://pastebin.com/zZDDkPuF). I copy and pasted the yml you suggested but it still doesn't work. Any suggestions? (Also thx for responding so quickly)

    Okay, sorry to annoy people but I managed to fix it. Basically I my computer wasn't allowed me to update the plugins file on my server so it wasn't updating... Anyways thanks for all the help!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jan 17, 2020
Thread Status:
Not open for further replies.

Share This Page