Plugin for 1.18

Discussion in 'Plugin Development' started by The_Spaceman, Dec 1, 2021.

  1. Offline

    The_Spaceman

    Hello,

    I've downloaded craftbukkit-1.18.jar and imported into IntelliJ.
    IntelliJ cant find anything bukkit related, a quick search into the jar and in the META-INF/libraries is the bukkit.jar with all the classes.

    Is this the one I should be using? And should I extract that jar from the main one and use it like that?

    Update:
    When using the bukkit-1.18-R0.1-SNAPSHOT from the craftbukkit jar IntelliJ can find all the bukkit related classes, but all the other libraries I've used are still missing, should I extract all and use it like the bukkit-1.18-R0.1-SNAPSHOT or is there anything easier?

    Any help is appreciated.
     
  2. Offline

    timtower Administrator Administrator Moderator

    @The_Spaceman Why are you building on CraftBukkit? Should be building on Bukkit itself
     
  3. Offline

    The_Spaceman

    The craftbukkit jar has all the other libraries in it. Like json-simple and minecraft self
     
  4. Offline

    timtower Administrator Administrator Moderator

    Why do you need those?
    Can you get anything working when using just the Bukkit.jar?
     
  5. Offline

    The_Spaceman

    Most of it, but not all (only from org.bukkit).
    I got it working when using the server/bundler/libraries and server/bundler/versions folder.
    In here are all the jars I need.

    Im using minecraft self to open inventories with names that are parsed through the translater in the client (same with ItemStacks), used for better language options for a plugin.
    The StringUtils from Apache is another one Im using (not in the bukkit.jar).
     
  6. Offline

    KarimAKL

    This might be what you're looking for.
     

Share This Page