Solved Plugin Already Initialized Glitch?

Discussion in 'Plugin Development' started by Wintergrasped, Nov 23, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    Okay Ive Been working on a Fairly advanced plugin with a group of friends but for some reason when ever I export the plugin and try to load it on a test server I get a Plugin Already initialized Error.

    Error Code Here

    What Ive Done To Fix:
    • Refresh Eclipse Project
    • Restart Eclipse
    • Change Package Name
    • Change Class Names
    • Making a FRESH Test server
    • Making a FRESH Multicraft based Test Server

    I am getting the SAME error No mater wat

    In Eclipse there is NO ERRORs
  2. Offline


    That means that there is a plugin with that name installed in the server
    Change plugin name in plugin.yml
  3. Offline


    Ill try that but it is the ONLY plugin on the server :-/
  4. Offline


    Make sure you don't create another instance of your main class somewhere else.
  5. Offline


    That Did Not Work........
  6. Offline


    You could be creating a second instance of your main class which extends JavaPlugin.
    mine-care likes this.
  7. Offline


    Okay thats possible Ill look

    Yup Fund it

    1. public MainClass main =new MainClass();

    Testing It Now

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 13, 2016
  8. Offline


    Skionz :eek: i really didnt notice that :3 you are really observant :)
  9. Offline


    mine-care I didn't look at anything. Just a usual problem I see so I guessed:p
  10. Offline


    Skionz xD yeah i mean that didnt even cross my mind at this time...
    Skionz likes this.
Thread Status:
Not open for further replies.

Share This Page