Please Help! Bukkit Plugins Bug!

Discussion in 'Bukkit Discussion' started by Darkraipikachu, Jul 12, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    Darkraipikachu

    Ok, so I have a pretty new Bukkit server and everything is going fantastically, except for one bug with my plugins! Basically, when I download a plugin with a .jar at the end (From dl.bukkit.org), it doesn't install in my plugins folder, nor will it show up when I type /plugins! This is a problem with nearly all plugins, but a few work, but almost none! I will put a link to my bukkit startup log, but first, here's a list of information that you NEED to know!

    - While trying to run the startup, I have StopThatLag.jar trying to load, but it won't (same with DisguiseCraft)!
    - I use CraftBukkit 1.7.9 R0.1 (Beta Build)!

    - I home host my server!

    - I have a Mac OS X Version 10.8.5, 27 inch late 2013 model!

    - I have 2GB of RAM on my server, but more soon because I'm buying 8 more GB's of RAM!

    - This has been a problem for probably a while, but I just recently noticed it!

    - my Java is 100% up to date, Java 7 Update 60!

    - I use Port Map to activate a 25565 port!

    - Here is a list of my plugins:

    [11:44:04 INFO]: Plugins (30): GroupManager, WorldEdit, Simple-AutoSave, Buycraft, Vault, PlotMe, MobBountyReloaded, uSkyBlock, WorldGuard, AutoMessage, ColoredBooks, iConomy, TNTRun, SurvivalGames, WarpSigns, CompatNoCheatPlus, Lockette, Votifier, Essentials, EssentialsProtect, NoCheatPlus, EssentialsSpawn, Multiverse-Core, EssentialsAntiBuild, EnjinMinecraftPlugin, ChestShop, EssentialsChat, Factions, Multiverse-Portals, Multiverse-Inventories
    >

    NOW THAT YOU KNOW THAT, HERE IS THE LINK TO MY STARTUP LOG:

    http://pastebin.com/4HCjp6kv
     
  2. Offline

    LugnutsK

    Try updating to 1.7.9 R0.3 then post the startup log again.
    The plugins that aren't loading aren't correctly finding the NMS classes, updating may help.
     
  3. Offline

    Syd

    Darkraipikachu
    Based on your startup log:
    DisguiseCraft - outdated Plugin
    StopThatLag - outdated Java
    uSkyBlock - some error, better ask author
    EnjinMinecraftPlugin - can't find a Java class, most likely caused by outdated Java
     
  4. Offline

    Darkraipikachu

    Thanks, but no plugins are working! Everything else works fine, but nothing is working! Basically, no lag plugins work, either…Should I just wait for maybe CB 1.8 for when everything else is up to date?
     
  5. Offline

    Necrodoom

    Darkraipikachu "Everything else works fine, but nothing is working!" ..?
    Also, describe the problem, and did you do the things he told you?
     
  6. Offline

    Darkraipikachu

    Wow…just realized how stupid I sounded…Basically every time I get a new plugin, the plugin doesn't install nor will it show up when I type /plugins! Most of mine work that I have now, but only with their plugin config folder, but since others won't install, I can't get a config folder, nor can I get it to work!
     
  7. Offline

    Necrodoom

  8. Offline

    Darkraipikachu

    Read the top! I have my startup error! It's the paste bin link!
     
  9. Offline

    Necrodoom

    Darkraipikachu Thats your old startup log. We need to see the startup log showing the new plugins you have problems with. Unless you did not actually did what Syd said, in which case, do them.
     
  10. Offline

    Darkraipikachu

    No it's not! That startup log is new! I made it literally like 3 days ago WITH all the same exact plugins in the plugins folder! Also, my Java isn't outdated like Syd said, I have the newest version…Java 7 Update 60…so he didn't help! That's not an old startup log! I'm not a noob to this, I've been making this server for months and I've experienced many errors! I know what I'm doing when it comes to asking for help!
     
  11. Offline

    Syd

    Darkraipikachu
    I only translated the exceptions for you. If a Java programm says "Unsupported major.minor version 51.0" it means that it's compiled to Java 7, but running on lower.
    Maybe you still have Java 6 installed and it's used for your server?
    (Your start file and the "java -version" output would be helpfull)
     
  12. Offline

    Jeyge

    FYI - you can see which version a server is running on in the stack trace. It will be the numbers at the end of any of the java class lines like the one below.
    Code:
            at java.lang.Class.forName0(Native Method) ~[?:1.6.0_65]
    
    Their server is running on 1.6 which is Java 6 and the update is 65.
     
  13. Offline

    Darkraipikachu

    I don't know what the hell you guys are talking about! I use CraftBukkit 1.7.9 R0.1 Beta Build, and I have Java 7 Update 60!
     
  14. Offline

    Necrodoom

  15. Offline

    Darkraipikachu

    I literally check Java…the last update was Java 7 Update 60 and I checked for it on my PC and I have it!
     
  16. Offline

    Necrodoom

    Darkraipikachu then you also have Java 6 installed, and your server is using it. Uninstall Java 6 aand/or set the used Java path in your start file to point to your Java 7 install.
     
  17. Offline

    Darkraipikachu

    Ok…I think now I only have Java 7 Update 65 installed…but i'm not sure! After going through this it's still not working, not sure why! I did notice that in my log I had a few Java errors…I'll give you a link to my newest startup! Please tell me what other errors I may have! Also, I have StopThatLag in my plugins filer (Not working)!
    LINK: http://pastebin.com/RU7vE3nW

    Also, How do I set my Start file to a certain Java Update?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 9, 2016
  18. Offline

    Syd

    Darkraipikachu
    Please paste the contens of your start file, whatever it's called under OS X. (.sh?)
    Also, please post the console output when you type in 'java -version'. (Terminal, not Server)

    Btw. the installed DisguiseCraft version is still incompatible with your CraftBukkit version.
     
  19. Offline

    Darkraipikachu

    I have my Startup log! Can't you read the last comment AND the title of this forum? Also, I have Java 7 Update 65 and Java 6 uninstalled from my PC…Now I need to know how to open my server and mine craft WITH Java 7 and not Java 6!

    OH! Sorry! I thought you meant startup file! My bad! Here it is! http://pastebin.com/HwtB5vBL

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 9, 2016
  20. Offline

    Syd

    Darkraipikachu
    Okay, you're using the java command, so it should use the default JRE.
    Could you now try to enter 'java -version' into a normal terminal? The output should look like this:
    Code:
    java version "1.8.0_05"
    Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
    Java HotSpot(TM) 64-Bit Server VM (build 25.5-b02, mixed mode)
    The 'java version "1.8.0_05"' line shows which Java version is run when 'java' is called.
    It should return something with 1.6.0_xx, as your MC server reports that it's using Java 6.
    So I guess you have to find a way to tell your OS to use a newer Java version.

    Under Linux you can do it with 'sudo update-alternatives --config java', but I don't know if it's the same on OS X.
     
  21. Offline

    Darkraipikachu

    Kind of confused by this…What do you mean by entering java-version in terminal…I tried but it said "Command not found"! So should I just get a Java 6 update instead of Java 7? Or make my server and Minecraft Java 7 and not Java 6? I'm not sure how to do either of these, and I've searched for help, so do you have any suggestions where I can find this out? I'll make a new discussion page for help!
     
  22. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    Darkraipikachu

    You forgot to put a space after 'java' before '-version'
     
  23. Offline

    Darkraipikachu

    So java -version? And also, how does this help with my problem? I know how to do this, but how do I make my server RUN with Java 7
     
  24. Offline

    dsouzamatt

    We don't know for sure what version you're running at the moment; this is a way of checking.
     
  25. Offline

    Darkraipikachu

    Ok…this is what I got:
    java version "1.6.0_65"
    Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
    Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

    How do I change this to say what it should say? (1.8.0_0.5 and not 1.6.0_65)?

    Have no Idea what you're talking about with 'sudo update-alternatives --config java'…can you clarify what this means and do you have any ideas on how to change the versions or what to search? I can't find a thing and I don't know what to search for! Should I search "How to change Java version 1.6.0_xx on mac to 1.8.0_05"? Or what?

    OMG I FIXED IT! All I had to do was download not only ire but JDK as well! Thanks guys! Without you I wouldn't still hav a server :,)! All of you made a 13 year old kid's day! I'll never forget your help and generosity :D!!!!!!!!!!
     
Thread Status:
Not open for further replies.

Share This Page