Solved Players unable to interact with blocks, other permissions work

Discussion in 'Bukkit Help' started by Halfclick, Feb 12, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    Hi, I'm using bukkit and PermissionsEx, also trying to add a multiworld plugin into my server. The multiworld stuff seems to work fine, most permissions work fine, but for some reason the only person able to place/break/interact with blocks is me, and in the permissions file I have my character specifically listed as part of an admin group, which has all permissions. The modifyworld.* is listed in the permissions for the basic group (the one I have set to default), which I think is supposed to allow all kinds of interaction with all blocks.

    Here's the permissions.yml (from the permissionsEx folder, the original bukkit permissions file is empty)

    Also, here's my essentials config.yml, most isn't changed, but a few bits are. The old one I had was changed quite a bit, but after dealing with this issue for quite a while I got a fresh config just incase, and only changed a few bits so far.

    Specifically, the error that pops up ingame when someone in the basic group (basically everyone) tries to, for example, dig sand, is this: "You are not permitted to interact with SAND."
    Other permissions seem to work, for example, members of the basic group are able to use the command "/exp", but are not able to use the command "/exp set", just as intended in the permissions. Also, the prefix [D ] does show up for members of the default group (I put that there just for testing purposes).

    List of plugins that I'm using, as listed by the server GUI:
    - ChatManager (a part of PermissionsEx I think)
    - Essentials
    - EssentialsAntiBuild (could this have something to do with it?)
    - EssentialsChat
    - EssentialsProtect (or this?)
    - EssentialsSpawn
    - Modifyworld
    - Multiworld
    - PermissionsEx

    I use the BukkitGUI by the way. (

    All plugins are updated to their newest versions, which are all supposed to be compatible with 1.4.7. I originally had some issues with the interface thinking I was using bukkit 1.4.7-R0.1, when it was really 1.4.7-R1.0, so every time the server would start it would try updating it, but I tried updating manually from the bukkit website and have that bit working now. The only problem left is that no one can interact with stuff, with the exception of me, being part of the admin group. After checking some stuff, this same error also seems to occur with PermissionsEx and Multiworld removed, preventing me from being able to fall back onto the old settings to at least keep the server running until this issue is resolved. I'm guessing I have something with essentials or bukkit set up wrong, would explain why the issue occurs even without a permissions plugin or multiworld. Any ideas? Any and all help would be greatly appreciated. This server is run as a private server, with only a few people currently using it. If you guys need any other config files or info or something, let me know.
  2. Offline


    You shouldn't need both Modifyworld and EssentialsAntiBuild but if you do want to keep them, then give everyone
  3. Offline


    EssentialsAntiBuild was installed automatically when I installed the core part of essentials I think, just tried deleting that part of it, and the block interaction seems to be working great now! Thanks for the help, and the quick reply! :D
    Jeyge likes this.
Thread Status:
Not open for further replies.

Share This Page