Solved Player-Level/Exp isnt being saved

Discussion in 'Bukkit Help' started by Mojo_Blaster, Apr 18, 2012.

Thread Status:
Not open for further replies.
  1. Offline



    At first, some informations for you:

    Bukkit: 1.2.5-R1.0-2149

    Plugins: Blocklog, SpawnerAdjuster, Groupmanager, ChestHarvester, WolrdEdit, WorldGuard, Torture, LWC, Falsebook, BukkitManager, Essentials

    Problem: I joined, played a little bit, left again and as I joined again, my level was like I havent been online the time before. So if I join the game with level 10, kill some mobs so my level is 15, leave and join again, my level is still 10. Some other players got the same problem

    I already tried to reduce the Autosavetime in the BukkitManager-settings to 60 seconds, but that didnt change anything.

    Any ideas?

    Mfg Mojo_Blaster

    Ps: Sorry for my terrible english!
  2. Offline


    I don't think I have as much constructive ideas as everyone else, but check disk space on your server (if packed tight it wont be able to write to files and will make it appear nothing gets save, of df -h (for linux) or build something and restart the service to check) also check file permissions.

    Also, your English isn't terrible, better than most people!


  3. Offline


    thx for the fast answer.

    I've got ca 9 Gb of free space, so i don't think this is the problem.

    I'm running bukkit as an administrator on a second HDD, so file permissions are ok,too.

    I think i forgot to say, that the problem only shows up sometimes.

    Mfg Mojo_Blaster
  4. Offline


    It could be a writeback error, like: if your server is working hard (saving world, lots of blocked changed in one go, generating large chunks of world) if you were to quit at these times then its possible it could timeout or "loose" the data being written to file.
    I'm not sure what java api bukkit uses but I know there are some issues with data structures going empty between calls between hard working functions/classes. try reproducing it under hard load, fly up somewhere and head out as fast as you can or use compass (with worldguard) and zip accross the land super quick, then logout and see if that replicates it.
    Or using worldguard alter a large(ish) volume of blocks (//pos1 //pos2 //outset 200 //set wool ) and see how sensative your system is to that kind of workload.

    I'm not really experienced with mc or bukkit (I'm still learning) but I have done alot of programming and RPM game platform development and overloading hooks has always been the main stumbling block.

    Are you using win or linux? you could use process viewer or top to check. or even set tripwaite to examine the file structure and watch the files grow as you use it, once you can replicate the problem these tools could identify where its dropping data.
    Also try removing your plugins one at a time to make sure its not one of those.

    Perhaps this helps.

  5. Offline



    I had a look at the taskmanager, but the cpu-load was always around 30 %. I noticed now, that it happens at 95 % of my tries.

    I just joined the server at 04:00 AM so I was alone there, playced a block, removed it again and killed 3 mobs. Than I left again. I did nothing cpu- or ram-expensive. I checked the cpu/ram-load while the savong and backup-processes,too, but it is always under 50 %. Btw I'm using Windows Server 2008 r2.

    Today afternoon I'm going to check every single plugin.

    Mfg Mojo_Blaster

    I guessed the problem is caused by BukkitManager, so I restarted the server without it....and now everything works fine.

    If you tell me how to post it as a spoiler, I can show you my BukkitManager-config. Maybe I'm just not able to adjust it the right way.

    Mfg Mojo_Blaster

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
Thread Status:
Not open for further replies.

Share This Page