Solved Picks up items too feet? [BUG]

Discussion in 'Bukkit Help' started by Tboz97, Dec 11, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    WorldBorder v1.6.1, PlugMan v1.6.8, Craftconomy3 v3.0.4-SNAPSHOT b617, WorldEdit v5.4.5, Buycraft v4.7, SimpleAnnouncer v1.8, Vault v1.2.20-b264, PermissionsEx v1.19.4, LogBlock v1.60, CombatTag v5.2, NoEnderpearl v1.3, WorldGuard v5.6.5, DispenserRefill v1.0.0, StopWitherSpawns v1.0, CraftBookCommon v1300-f6a5393, LimitedCreative v1.4.0a, BKCommonLib v1.38, ProtocolLib v1.7.1, Modifyworld v1.19.4, SimpleSpleef v3.4.1, BattleArena v3.7.7.3, VoteNow v1.2, Votifier v1.8, CraftBookCircuits v1300-f6a5393, SimpleReserve v0.5.0, WeatherMan v0.4.6, mcMMO v1.3.11-b1030, FoundDiamonds v3.6.2, Essentials vPre2.9.6.1, Orebfuscator v1.7.6, CraftBookMechanisms v1300-f6a5393, ChatManager v1.19.1, EssentialsSpawn vPre2.9.6.1, iZone v7.6.1, VanishNoPacket v3.12.4, DisguiseCraft v3.9, CraftBookVehicles v1300-f6a5393, NoLagg v1.89.1, CompatNoCheatPlus v6.3.5-RC-b28, ChestShop v3.46, EssentialsChat vPre2.9.6.1, Factions v1.6.9.3, NoCheatPlus v3.8.4-RC-b271, FactionsPlus v0.4.8
    This server is running CraftBukkit version git-Bukkit-1.4.5-R0.2-12-g4f69634-b2503jnks (MC: 1.4.5) (Implementing API version 1.4.5-R0.3-SNAPSHOT)

    Back too the bug.
    BACKSTORY: After trying too fix nocheatplus not blocking fastplace+fastbreak we finally decided too update plugins, so we updated plugins (WorldGuard, NCP).

    BUG: After ^ everytime you drop something, it gets instantly picked up and placed into the FEET/Boots armour slot, ANY ITEM.

    Need a fix for this QUICKLY as we have 20+ players all the time.

    Solution: Delete playerfile in your world! Mine was corrupted!

    EDIT: everything worked fine after disabling NCP, but after throwing a pickaxe which got placed into boots, everything got placed there when dropped.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 30, 2016
  2. Offline


    I am having the same problem, with no plugins installed too.

    I run git-Bukkit-1.4.5-R0.2-b2448jnks.
  3. Same here, no plugins with the server, no mods with the client, most picked up items immediately appear in the boots slot. Haven't experienced this issue before today, though it now happens with older builds too, as well as the latest ones. Not sure what else to do.

    I've created a ticket over at the bukkit issue tracker (bug report):
  4. Offline


    Also having this problem.
  5. The issue was solved for the next development build only a few hours after I created the ticket (see my previous post). Since then, it hasn't been happening for me anymore. You should be fine too after updating to the latest Recommended Build of CraftBukkit (that's 1.4.5-1.0 which was released just yesterday 19/Dec/2012 and includes all fixes & contributions up to that date.)
    The address to get the latest RB is always this (direct download):
    Or you could get the latest development builds here:
  6. Offline


    I ended up updating, fixed the problem. Thanks!
Thread Status:
Not open for further replies.

Share This Page