Problem/Bug Pex doesn't work.

Discussion in 'Bukkit Help' started by thethiccbish, Jun 30, 2017.

Thread Status:
Not open for further replies.
  1. Offline

    thethiccbish

    Pex doesn't work idk why. After I did my ranks pex doesn't work
    Code:
    groups:
      default:
        options:
          default: true
        permissions:
        - essentials.help
        - essentials.rules
        - essentials.motd
        - essentials.afk
        - essentials.depth
        - essentials.help
        - essentials.list
        - essentials.mail
        - essentials.mail.send
        - essentials.me
        - essentials.motd
        - essentials.msg
        - essentials.rules
        - essentials.seen
        - essentials.signs.use.disposal
        - essentials.spawn
        - essentials.suicide
        - essentials.tpa
        - essentials.tpaccept
        - essentials.tpahere
        - essentials.tpdeny
        - essentials.realname
      Owner:
        options:
          default: false
          prefix: '&5&l[Owner]&f'
        permissions:
        - modifyworld.*
        - '*'
      Helper:
        options: false
          prefix: '&2&l[Helper]&f'
          inheritance:
          - default
        permissions:
        - essentials.kick
        - essentials.kick.exempt
        - essentials.kick.notify
        - essentials.mute
        - essentials.mute.exempt
        - essentials.mute.notify
        - essentials.mute.offline
        - essentials.invsee
        - essentials.kill
        - essentials.kill.exempt
        - essentials.tp
        - essentials.tpo
        - essentials.tpohere
        - essentials.nick
        - essentials.ban.exempt
        - essentials.ban.notify
        - essentials.vanish.see
        Mod:
        options: false
          prefix: '&4&l[Mod]&f'
          inheritance:
          - default
          - Helper
        permissions:
        - essentials.god
        - essentials.ban
        - essentials.ban.exempt
        - essentials.ban.offline
        - essentials.ban.notify
        - essentials.broadcast
        - essentials.socialspy
        - essentials.tempban
        - essentials.tempban.exempt
        - essentials.tempban.offline
        - essentials.tempban.unlimited
        - essentials.ban.notify
        - essentials.vanish
        - essentials.vanish.see
        - essentials.weather
        - essentials.firework
        - essentials.firework.fire
        - essentials.fly
        - essentials.fly.safelogin
      Mod+:
        options: false
          prefix: '&c&l[Mod+]&f'
          inheritance:
          - default
          - Helper
          - Mod
        permissions:
        - essentials.gamemode
        - essentials.antioch
        - essentials.banip
        - essentials.burn
        - essentials.clearinventory
        - essentials.clearinventory.others
        - essentials.invsee
        - essentials.kickall
        - essentials.nuke
        - essentials.remove
        - essentials.unban
        - essentials.unbanip
        - essentials.ext
      Admin:
        options: false
          prefix: '&c&l[&2Admin]&f'
          inheritance:
          - default
          - Helper
          - Mod
          - Mod+
        permissions:
        '*'
      Co-Owner:
        options: false
          prefix: '&6&l[Co-Owner]&6'
          inheritance:
          - default
          - Helper
          - Mod
          - Mod+
        permissions:
        '*'
      Builder:
        options: false
          prefix: '&d&l[Helper]&f'
          inheritance:
          - default
        permissions:
        - modifyworld.*
        - essentials.fly
        - essentials.fly.safelogin
       Awesome:
        options: false
          prefix: '&e&l[Awesome]&f'
          inheritance:
          - default
        permissions:
        - essentials.fly
        - essentials.fly.safelogin
        - essentials.nick
    schema-version: 1
    users:
      ae3741e6-c69a-409b-b797-7d959a2e417b:
        group:
        - Owner
        options:
          name: Assthethicc
    
    And this is the thing I get on console
    http://prntscr.com/fq6i16
    http://prntscr.com/fq6iaq
     
  2. Offline

    timtower Moderator Moderator

    @thethiccbish You have: "options: false" a couple times, that is not valid yml.
    Mod is not correctly indented.
    Admin has no - for the permissions
     
  3. Offline

    thethiccbish

    What do I put in the options to now make all players get the rank. Also does this fix it?
    Code:
    groups:
      default:
        options:
          default: true
        permissions:
        - essentials.help
        - essentials.rules
        - essentials.motd
        - essentials.afk
        - essentials.depth
        - essentials.help
        - essentials.list
        - essentials.mail
        - essentials.mail.send
        - essentials.me
        - essentials.motd
        - essentials.msg
        - essentials.rules
        - essentials.seen
        - essentials.signs.use.disposal
        - essentials.spawn
        - essentials.suicide
        - essentials.tpa
        - essentials.tpaccept
        - essentials.tpahere
        - essentials.tpdeny
        - essentials.realname
      Owner:
        options: false
          prefix: '&5&l[Owner]&f'
        permissions:
        - modifyworld.*
        - '*'
      Helper:
        options: false
          prefix: '&2&l[Helper]&f'
          inheritance:
          - default
        permissions:
        - essentials.kick
        - essentials.kick.exempt
        - essentials.kick.notify
        - essentials.mute
        - essentials.mute.exempt
        - essentials.mute.notify
        - essentials.mute.offline
        - essentials.invsee
        - essentials.kill
        - essentials.kill.exempt
        - essentials.tp
        - essentials.tpo
        - essentials.tpohere
        - essentials.nick
        - essentials.ban.exempt
        - essentials.ban.notify
        - essentials.vanish.see
       Mod:
        options: false
          prefix: '&4&l[Mod]&f'
          inheritance:
          - default
          - Helper
        permissions:
        - essentials.god
        - essentials.ban
        - essentials.ban.exempt
        - essentials.ban.offline
        - essentials.ban.notify
        - essentials.broadcast
        - essentials.socialspy
        - essentials.tempban
        - essentials.tempban.exempt
        - essentials.tempban.offline
        - essentials.tempban.unlimited
        - essentials.ban.notify
        - essentials.vanish
        - essentials.vanish.see
        - essentials.weather
        - essentials.firework
        - essentials.firework.fire
        - essentials.fly
        - essentials.fly.safelogin
      Mod+:
        options: false
          prefix: '&c&l[Mod+]&f'
          inheritance:
          - default
          - Helper
          - Mod
        permissions:
        - essentials.gamemode
        - essentials.antioch
        - essentials.banip
        - essentials.burn
        - essentials.clearinventory
        - essentials.clearinventory.others
        - essentials.invsee
        - essentials.kickall
        - essentials.nuke
        - essentials.remove
        - essentials.unban
        - essentials.unbanip
        - essentials.ext
      Admin:
        options: false
          prefix: '&c&l[&2Admin]&f'
          inheritance:
          - default
          - Helper
          - Mod
          - Mod+
        permissions:
        - '*'
      Co-Owner:
        options: false
          prefix: '&6&l[Co-Owner]&6'
          inheritance:
          - default
          - Helper
          - Mod
          - Mod+
        permissions:
        - '*'
      Builder:
        options: false
          prefix: '&d&l[Helper]&f'
          inheritance:
          - default
        permissions:
        - modifyworld.*
        - essentials.fly
        - essentials.fly.safelogin
       Awesome:
        options: false
          prefix: '&e&l[Awesome]&f'
          inheritance:
          - default
        permissions:
        - essentials.fly
        - essentials.fly.safelogin
        - essentials.nick
    schema-version: 1
    users:
      ae3741e6-c69a-409b-b797-7d959a2e417b:
        group:
        - Owner
        options:
          name: Assthethicc
    
     
    Last edited by a moderator: Jun 30, 2017
  4. Offline

    timtower Moderator Moderator

    @thethiccbish You need to remove the "options: false", not add more of them.
     
  5. Offline

    thethiccbish

    Last edited: Jun 30, 2017
  6. Offline

    timtower Moderator Moderator

  7. Offline

    thethiccbish

  8. Offline

    timtower Moderator Moderator

    @thethiccbish That is the regular permissions.yml, not the pex one.
     
  9. Offline

    thethiccbish

    thanks
     
    Last edited: Jul 1, 2017
Thread Status:
Not open for further replies.

Share This Page