PermissionsEx - How to give OP all permissions

Discussion in 'Bukkit Help' started by blameless, Mar 13, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    blameless

    Could someone take a look at this permission ex config file:

    http://pastebin.com/cNeByW4y

    permissions:
    backend: file
    backends:
    file:
    file: permissions.yml
    allowOps: true
    superperms: {}




    In my permissions.yml file i only want the default group. I would like for anyone who is given /op to bypass these restrictions. I have tried fooling around in the PEX config file, but without success.

    It should be very doable according to the PEX documentation. I dont want to make own group for admins/OP and have to rank / downrank them all the time -I just want to do /op and know they have access to everything.


    Thanks for any help on this issue!
     
  2. Offline

    Jeyge

    What is it that isn't working? Making someone an OP should give them access to all OP commands as defined by the plugin.yml files.
     
  3. Offline

    blameless

    PermissionsEX overrides - causing OPs to be as limited as the default group.
     
  4. Offline

    Jeyge

    You must be running a different version of PEx than I am. When I op myself, I gain all of the permissions I would expect. I even tried with allowOps set to true and I was still able to do more than I could as the default rank.
     
  5. Offline

    Lolmewn Retired Staff

    Are you sure there's no other plugin denying you the right of OP?
    Your PEX seems to be configured fine, since allowOPs is true.
     
  6. Offline

    blameless

    Once i remove PEX - OPs gain control over all permissions (set by plugin)

    I have slimmed down the plugin folder for testing: only PEX and Essentials

    In the permissions.yml file there is only one group - default.
    It has positive nodes for only a couple commands, and a negative wildcard at the end.

    Even with the allowOps: true - OPs will not be allowed to perform commands that is not defined in the permissions file.

    The negative wildcard on the default group definitively affects OPs - allowOps: true.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 31, 2016
  7. Offline

    Jeyge

    I just tried with the following permissions.yml and config.yml and when I'm an OP, I can do everything I want.
    Code:
    groups:
      Guest:
        default: true
        prefix: '&7(Player)'
        permissions:
        - -'*'
        options:
          rank: '1000'
    users:
      Jeyge:
        group:
        - Guest
    
    Code:
    permissions:
      backend: file
      backends:
        file:
          file: permissions.yml
      allowOps: true
      superperms: {}
    
    If it only breaks when you set allowOps to true, maybe you should set it to false.
     
  8. Offline

    RPGCraft

    Using PEx, if you OP someone on our servers you get all permissions? I'm not sure what you're running...
     
  9. Offline

    blameless

    Thanks alot for all the feedback. It is good to know that it is suppose to work - even though it does not.

    I have tried running a clean startup with only PEX as plugin - and the config and permissions files as above.

    The problem is still there, so now I am beginning to think that PEX is unable to read the ops.txt file successfully.
    No errors in the server log about it.

    I am running it on a Mac OSX - might got something to do with it?
     
  10. Offline

    fredghostkyle1

    make a admin/staff group give it '*'
     
  11. Offline

    blameless

    I appreciate your contribution fredghostkyle1, but that would not be the same. I am trying to avoid the need to rank, but instead make the /op work as it is suppose to.

    I will try on a Windows platform at a later time and of course update if that solved it.
     
  12. Offline

    Jeyge

    The problem is that being an OP isn't supposed to give you all permissions. You are likely trying to give someone a permission that they will never have by being in the ops.txt file no matter what permissions system you are using.
     
  13. Offline

    blameless

    The story has a sad ending.

    The allowOps: true in PEX config.yml does NOT override the permissions.yml file.

    The type of commands I where trying to use are suppose to be OP commands.

    e.g. /time set xxxx

    Ive tried on windows and super clean run ect. ect. ect.
     
Thread Status:
Not open for further replies.

Share This Page