Solved PermissionsEx Double Prefix

Discussion in 'Bukkit Help' started by hectorsouthern, Jul 28, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    I have set up PermissionsEx and when i moved it into my server, (different server to the one I was making it on) It started making Double Prefix's (If my Prefix was set to say "Owner" in game it would say "Owner Owner" <message>. Even if I change the prefix they both change. I have also checked that there are no other chat plugins and checked the ChatManager config and its OK.

  2. Offline


    Have you got Towny or Essentials installed? Both of these plugins (and a lot of others) have built-in chat managers, resulting in multiple prefixes.
  3. Offline


    I have Essentials, I look through it now, is the chat part in the main config?

    Got it, thanks

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  4. Offline


    so how did u fix it cuz i got the same thing and i got essentials too
  5. Offline


    prefix being set in both essentialschat, and permissionsex. you just remove one.
  6. Offline


    I worked it out and u dont need to remove essentials or essentials chat u just need to change in the essentials main config YAML file the "add-prefix-suffix: true" to "add-prefix-suffix: false" and it fixed it but thanks anyways
  7. Offline


    i have towny, so how to you fix the prefixs mine looks like: [g][Owner]Owner King_Ender
Thread Status:
Not open for further replies.

Share This Page