Permissions problem. need help.

Discussion in 'Bukkit Help' started by epic000, Nov 2, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    hello people on this forum,

    i am asking your help because i have a bukkit 1.6.4 server with loads of plugins and i am planning to have multiple gamemodes but i have a huge problem with the permissions.
    i dont understand the permissions so someone needs to explain to me how you set the permissions.
    i want to learn how to:
    -make a group of people with the same permissions.
    -give a someone a permission.
    -how to limit what people can do.
    and how to make changes in the permissions.

    i googled this over and over and i came up with search results that didnt work for me or i didnt know where they were talking about.

    i have a server for minecraft 1.6.4 running on bukkit.
    i am confident that the server will be awesome but i cannot achieve that unless i get the permissions working.
    i have the plotme-plugin but normal players cant use it because when they enter "/plotme claim" the server tells them that they dont have permission for that command.

    you can except me to be a noob with permissions so you have to explain everythin
    i need your help.
    please help me out...

  2. Offline


    This basically varies between permission plugin, you need to choose one and use it. I use GroupManager, but there are a lot of permission plugins out there, such as PermissionsEx or BukkitPermissions.

    Once you choose one, you can read how it works and how to use it in the documentation. If you still dont understand something, paste your permissions file using and explain your problem.
  3. Offline


    first of all thank you for your response.
    i used to have bPermissions but i removed the plugin so i am going to try group manager.

    [written 5 minutes after the text above]
    but were do i download it?
    i searched bukkit for group manager but i didnt find the plugin.
    could you tell me were i can download it or pass me a download link?

    i found a download link:
    <Removed insecure download link - Necrodoom>
    i downloaded the file so i am going to test it now

    another update:
    it kindof works, when i did /listgroups it said "You are not allowed to use that command."
    i'm trying to fix that...

    third update:
    i now discovered that group manager is part of essentials.
    i am removing group manager now and i am now installing essentials.
  4. Offline


    Essentials group Manager can be found here -
    The wiki in here might be useful -
    Also, here are some example files :)

    You are supposed to code your groups in groups.yml . Also, in the Config you can configure child worlds. Also remember to use a YAML parser before trying the permissions -
    Hope this helps :)
  5. Offline


    Also, GroupManager is a standalone plugin and is not a part of the essentials package on
  6. Offline


    I already found the group manager but thanks anyway.
    Before making this thread i already tried to code the perms in the .yml file(s) but i think i did something wrong because when i copied a perm that was generated by the server and *example* just replaced "bukkit.*" with "plotme.*" and that didnt work.
    I am uaing groupmanager now and it seems to be working
  7. Offline


    epic000 Please mark as solved.
  8. Offline



    srry everybody but i encountered a new problem.
    when a op issues the "/plugins" command it gives the no-permission error.
    i dont have a single clue what i did wrong and how i can fix it.
    please explain it to me so that i can configure the whole thing without consulting you guys (i always change everything in configuration files).
    could someone help me out, please?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 5, 2016
  9. Offline


    I'd suggest looking at your group manager file and see if you gave any plugin viewing permission to any group. If you did, just remove the permission and the permission should be for everyone, or only for opped players.
  10. Offline


    thank you for replying.
    i am going to see if this is the problem.

    and to you, i am going to try the parser.
    i will let you know how it went.
    sorry, but this isnt solved yet.
    i will try to mark this "solved" if it is solved.
    b.t.w, i didnt see a "mark as solved" button anywhere...
  11. Offline


    Can you do any other essentials commands? This happened to me when I forgot to take my server off of offline mode (in
  12. Offline


    my server is as cracked as a crackhead so i am not taking it off offlinemode, sorry.
    i think i figured it out.
    i am doing it a little bit complicated now but i think it works.
    i have a command block with a pressure plate and set command block to something like "/manuaddp @p plotme.use".
    i am testing it now...

    it works...
    it did not even display the annoying message that command block issued a command.
    if anyone here has a suggestion on how to make it better, i happen to have eyes to read their posts.

    update #2:
    i have gone to my plot world to make things OK there but when i am standing on a empty plot my plotme-plugin claims that "this is not a plotworld", if anyone knows how i can fix it that would be great.

    update #3:
    never mind with the plotworld thingy, i solved it by regenerating the world.
    thank you all for your time and attention.
    i dont think i am going to close this thread right away because sometimes people want to reply to this post, i will wait not more then 2 days.
    tcvs i will mark this solved if i dont encounter anymore problems in the next 2 days...
Thread Status:
Not open for further replies.

Share This Page