Permission's Help (bPerms based)

Discussion in 'Bukkit Help' started by Lama_0, Jan 30, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hello all,

    I have a recurring problem with just one type of permission. the /spawn (etc, you'll see) command.

    I am wanting to allow players on my server to have access to a /spawn command, however, no matter how many different /spawn featured plugins seem to want to allow players to have permission. I have tried: CommandBook, Essentials, SideKick, and SuperSpawn. I give the default group all the respective permissions nodes, but no matter what, they get the error of, you do not have permission.

    This is the current setup for the default group, it currently only has the SuperSpawn perm, but I really want SuperSpawn over the other alternatives, due to its simplicity, and amazing-ness in the spawn category:

    I truly dont know what I am doing wrong, ive tried the essentials: essentials.spawn, ive tried sidekick.spawn(or w/e its respective perm is for spawn, I honestly cant remember exactly off the top of my head). And also the commandbook.

    Any wisdom to shed?

  2. Offline


    My advice is that, well: 1. You only have one superspawn permission node in the permission setup. 2. You might have forgot to put the people inside that specific group.
  3. Offline


    Spacing is incorrect? If you have multiple plugins that control spawn ( or any other command for that matter ) the one that is first in alphabetical order will be used. So, using Cmdbook, download a customized version, or if your plugin has an option, like HSP, "steal" the command.
  4. Offline


    It would help to know which plugin you're using for /spawn
  5. Offline


    I am trying to use just SuperSpawn (cmd = /ss, /superspawn) Other plugins shouldn't have interfered, as I only defined one permission for the group. And

    It is the only one needed for players to have access to the /ss command.

    The default group upon arrival for all players is default. So theoretically, they should have permission.

    I am using the default spacing provided by bPerms.

    Maybe I should incorporate ALL permissions that relate to /spawn? Like, the essentials perm, the cmdbook perm, the superspawn perm, and the sidekick perm? Im not sure if I tried that, but it seems like an in-efficient way to setup up permissions, if that happens to work, I would definitely want a more efficient alternative.
  6. Offline


    You need to find out which plugin is actually "handling" the command as that'll be the relevant permission

    IF you want to test and see if it works, the best way is to remove EVERYTHING except SuperSpawn and bPermissions and test with ONLY those two plugins (as there will be no conflicts and it will let you test your setup properly)

    Also are you running an online mode or an offline mode server?
  7. Offline


    Im sorry if I must ask, but what do you mean by "handling?" Im fairly sure I have SuperSpawn handling it, I've defined the permission. I've completely disabled essentials spawn as of right now, and SideKick/CmdBook perms are not defined at all. And also, I am running in online mode. Other than this, I may try removing everything but the two plugins, if all other alternatives are exhausted. Thanks for the effort so far!

    EDIT: I think I may have fixed it everyone. I made a customized CommandBook, removing all /setspawn and /spawn elements, and now it appears to work! Thanks for the advice whoever said to try making it customized. :)
Thread Status:
Not open for further replies.

Share This Page